summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-08-22 00:27:53 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-08-22 00:27:53 (GMT)
commitdb17e125c87e8056e2d0cdc5f1985ab62e713c84 (patch)
tree0e2c84550d6ffdfd33cc84c12c396db9ce3c987b /abs/core-testing
parente067093b13fb71f9d928ccf7a1b3ce6dd0124795 (diff)
parentd630a6ae3ada088453209270791ae281e2d5e393 (diff)
downloadlinhes_pkgbuild-db17e125c87e8056e2d0cdc5f1985ab62e713c84.zip
linhes_pkgbuild-db17e125c87e8056e2d0cdc5f1985ab62e713c84.tar.gz
linhes_pkgbuild-db17e125c87e8056e2d0cdc5f1985ab62e713c84.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing')
-rwxr-xr-xabs/core-testing/LinHES-config/mv_software.py38
-rw-r--r--abs/core-testing/dvb-firmware/PKGBUILD2
-rw-r--r--abs/core-testing/fftw2/PKGBUILD4
-rw-r--r--abs/core-testing/glib/PKGBUILD4
-rw-r--r--abs/core-testing/glib/__changelog2
-rw-r--r--abs/core-testing/gtk/PKGBUILD2
-rw-r--r--abs/core-testing/gtk/__changelog1
-rw-r--r--abs/core-testing/lirc/PKGBUILD4
-rw-r--r--abs/core-testing/lirc/lirc.fdi2
-rwxr-xr-xabs/core-testing/mythtv/trunk/mythtv/PKGBUILD3
-rwxr-xr-x[-rw-r--r--]abs/core-testing/mythtv/trunk/mythtv/pretty2
11 files changed, 41 insertions, 23 deletions
diff --git a/abs/core-testing/LinHES-config/mv_software.py b/abs/core-testing/LinHES-config/mv_software.py
index e5b96b2..7421e08 100755
--- a/abs/core-testing/LinHES-config/mv_software.py
+++ b/abs/core-testing/LinHES-config/mv_software.py
@@ -4,29 +4,47 @@ import os, re
def setup_software(systemconfig, data_config):
logging.info("____Start of Software install____")
- default_disabled = ("mythphone", "mytharchive", "mythbrowser", "mythnews",
- "mythgame", "mythflix", "mythweather",
- "mythappletrailers", "mythstream", "mythvodka")
+ postfix=''
+ if data_config.SYSTEMTYPE == "MythVantage":
+ #look for the installed prefix
+ cmd="pacman -Q mythtv-release-fixes"
+ rc = mv_common.runcmd(cmd)
+ if rc == 0:
+ postfix = "-release-fixes"
+ else:
+ postfix = "-svn"
- default_installed=("mythcontrols", "mythgallery", "mythmovies",
- "mythmusic", "mythsmolt", "mythvideo")
- other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes")
+ default_disabled = ("mythphone", "mytharchive", "mythbrowser", "mythnews",
+ "mythgame", "mythflix", "mythweather" )
+
+ default_installed=("mythcontrols", "mythgallery", "mythmovies",
+ "mythmusic", "mythsmolt", "mythvideo")
+ other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "mythappletrailers", "mythstream", "mythvodka")
+ else:
+ default_disabled = ("mythphone", "mytharchive", "mythbrowser", "mythnews",
+ "mythgame", "mythflix", "mythweather",
+ "mythappletrailers", "mythstream", "mythvodka")
+
+ default_installed=("mythcontrols", "mythgallery", "mythmovies",
+ "mythmusic", "mythsmolt", "mythvideo")
+ other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes")
for pkg in default_disabled:
+ pkgname=pkg+postfix
try:
if systemconfig[pkg] == "1":
- mv_common.pacinstall(pkg)
+ mv_common.pacinstall(pkgname)
else:
- mv_common.pacremove(pkg)
+ mv_common.pacremove(pkgname)
except:
logging.debug(" ERROR-- %s is not defined", pkg)
for pkg in default_installed:
try:
if systemconfig[pkg] == "0":
- mv_common.pacremove(pkg)
+ mv_common.pacremove(pkgname)
else:
- mv_common.pacinstall(pkg)
+ mv_common.pacinstall(pkgname)
except:
logging.debug(" ERROR-- %s is not defined", pkg)
diff --git a/abs/core-testing/dvb-firmware/PKGBUILD b/abs/core-testing/dvb-firmware/PKGBUILD
index 24224e7..5531f86 100644
--- a/abs/core-testing/dvb-firmware/PKGBUILD
+++ b/abs/core-testing/dvb-firmware/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=dvb-firmware
pkgver=1
-pkgrel=7
+pkgrel=8
pkgdesc="Firmware for DVB cards"
arch=('i586' 'i686' 'x86_64')
url="http://linuxtv.org/"
diff --git a/abs/core-testing/fftw2/PKGBUILD b/abs/core-testing/fftw2/PKGBUILD
index 4b95f97..18aa473 100644
--- a/abs/core-testing/fftw2/PKGBUILD
+++ b/abs/core-testing/fftw2/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=fftw2
pkgver=2.1.5
-pkgrel=8
+pkgrel=9
pkgdesc="FFTW is a C subroutine library for computing the discrete Fourier transform (DFT) in one or more dimensions, of both real and complex data, and of arbitrary input size. This is package is offering backwards compatibility version 2.x.y. of fftw."
arch=(i686 x86_64)
url="http://www.fftw.org/"
license=('GPL2')
depends=('glibc')
-options=(!libtool !emptydirs)
+options=(!libtool !emptydirs !docs)
source=(http://www.fftw.org/fftw-${pkgver}.tar.gz)
md5sums=('8d16a84f3ca02a785ef9eb36249ba433')
diff --git a/abs/core-testing/glib/PKGBUILD b/abs/core-testing/glib/PKGBUILD
index cb97a5b..42f4420 100644
--- a/abs/core-testing/glib/PKGBUILD
+++ b/abs/core-testing/glib/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=glib
pkgver=1.2.10
-pkgrel=8
+pkgrel=10
pkgdesc="Common C routines used by Gtk+ and other libs"
arch=('i686' 'x86_64')
url="http://www.gtk.org/"
license=('LGPL')
depends=('glibc')
-options=('!libtool' '!emptydirs')
+options=('!libtool' '!emptydirs' '!docs' )
source=(ftp://ftp.gtk.org/pub/gtk/v1.2/$pkgname-$pkgver.tar.gz \
gcc340.patch \
aclocal-fixes.patch)
diff --git a/abs/core-testing/glib/__changelog b/abs/core-testing/glib/__changelog
index 93f6b06..f2439db 100644
--- a/abs/core-testing/glib/__changelog
+++ b/abs/core-testing/glib/__changelog
@@ -1 +1 @@
-added !emptydir to options
+added !emptydir !docs to options
diff --git a/abs/core-testing/gtk/PKGBUILD b/abs/core-testing/gtk/PKGBUILD
index bb47b2b..48c4972 100644
--- a/abs/core-testing/gtk/PKGBUILD
+++ b/abs/core-testing/gtk/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=gtk
pkgver=1.2.10
-pkgrel=10
+pkgrel=11
pkgdesc="The GTK+ toolkit"
arch=('i686' 'x86_64')
url="http://www.gtk.org/"
diff --git a/abs/core-testing/gtk/__changelog b/abs/core-testing/gtk/__changelog
index 014bc64..5d6d4d6 100644
--- a/abs/core-testing/gtk/__changelog
+++ b/abs/core-testing/gtk/__changelog
@@ -1,2 +1,3 @@
added !emptydir to options
+!docs
diff --git a/abs/core-testing/lirc/PKGBUILD b/abs/core-testing/lirc/PKGBUILD
index 5406783..d15cf1d 100644
--- a/abs/core-testing/lirc/PKGBUILD
+++ b/abs/core-testing/lirc/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=lirc
pkgver=0.8.5CVS
-pkgrel=14
+pkgrel=15
_kernver=2.6.28-LinHES
pkgdesc="Linux Infrared Remote Control kernel modules for stock arch kernel"
arch=(i686 x86_64)
@@ -83,4 +83,4 @@ md5sums=('b96dae91b566143b3af433fa2714ec9a'
'f059f4030afc682c9539a03bf837c1cf'
'4e698654cc44fc6c4163814acda5a7ee'
'9a3a6dc03647ee6674a166dfb884ddd6'
- '664fb04b51396628300daf8befd0db77')
+ '203d9cd014c4276be4c84cecd103919d')
diff --git a/abs/core-testing/lirc/lirc.fdi b/abs/core-testing/lirc/lirc.fdi
index 7a8c8ad..6f2443a 100644
--- a/abs/core-testing/lirc/lirc.fdi
+++ b/abs/core-testing/lirc/lirc.fdi
@@ -3,7 +3,7 @@
<deviceinfo version="0.2">
<device>
<!-- This rule prevents the Dvico dual digital4 rev 2
- remote input device from making your keyboard act wierd>
+ remote input device from making your keyboard act wierd. -->
<match key="info.product" contains_ncase="IR-receiver inside an USB DVB receiver">
<merge key="info.ignore" type="bool">true</merge>
</match>
diff --git a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
index df4afb8..422ec64 100755
--- a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
@@ -86,7 +86,6 @@ build() {
mkdir -p $startdir/pkg/etc/logrotate.d
cp $startdir/src/*.lr $startdir/pkg/etc/logrotate.d
mkdir -p $startdir/pkg/etc/cron.hourly/
- cp $startdir/src/pretty $startdir/pkg/etc/cron.hourly/
-
+ install -m0755 $startdir/src/pretty $startdir/pkg/etc/cron.hourly/
}
diff --git a/abs/core-testing/mythtv/trunk/mythtv/pretty b/abs/core-testing/mythtv/trunk/mythtv/pretty
index e47aaec..24b7658 100644..100755
--- a/abs/core-testing/mythtv/trunk/mythtv/pretty
+++ b/abs/core-testing/mythtv/trunk/mythtv/pretty
@@ -1,2 +1,2 @@
#!/bin/bash
-su mythtv -c "perl /usr/share/mythtv/contrib/mythrename.pl --link /myth/pretty"
+su mythtv -c "perl /usr/share/mythtv/contrib/user_jobs/mythrename.pl --link /myth/pretty"