summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-05 14:38:10 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-05 14:38:10 (GMT)
commitee33ddf6f3657ff6384de9c6e517511f0427ffc7 (patch)
treec02a8afa5bdd1099494f7d436a58dec4bf086b12 /abs/core-testing
parentd6049e8a38b8babf070b6f2183c336334ed97fd9 (diff)
downloadlinhes_pkgbuild-ee33ddf6f3657ff6384de9c6e517511f0427ffc7.zip
linhes_pkgbuild-ee33ddf6f3657ff6384de9c6e517511f0427ffc7.tar.gz
linhes_pkgbuild-ee33ddf6f3657ff6384de9c6e517511f0427ffc7.tar.bz2
Goodbye chroot-devel.
All things chroot-devel have been moved and split between core and extra
Diffstat (limited to 'abs/core-testing')
-rw-r--r--abs/core-testing/git/ChangeLog26
-rw-r--r--abs/core-testing/git/PKGBUILD49
-rw-r--r--abs/core-testing/rsync/ChangeLog20
-rw-r--r--abs/core-testing/rsync/PKGBUILD29
-rw-r--r--abs/core-testing/rsync/rsync.xinetd11
-rw-r--r--abs/core-testing/rsync/rsyncd37
-rw-r--r--abs/core-testing/rsync/rsyncd.conf16
7 files changed, 188 insertions, 0 deletions
diff --git a/abs/core-testing/git/ChangeLog b/abs/core-testing/git/ChangeLog
new file mode 100644
index 0000000..54cdeec
--- /dev/null
+++ b/abs/core-testing/git/ChangeLog
@@ -0,0 +1,26 @@
+Simple version bumps are ommitted from the following ChangeLog.
+
+2008-09-14 Dan McGee <dan@archlinux.org>
+ Version 1.6.0.2-1
+ * Moved optional depends from install file to optdepends array
+
+2008-06-15 Dan McGee <dan@archlinux.org>
+ Version 1.5.6-1
+ * Removed 'cpio' dependency, clone is now a builtin and no longer needs it
+
+2008-02-02 Dan McGee <dan@archlinux.org>
+ Version 1.5.4-1
+ * Upstream version 1.5.4
+ * Enable pthreads support in pack-objects. To use, set the pack.threads
+ git config option. Read manpages of pack-objects and config for more
+ details.
+ * Changelog added (with entries going back a bit).
+
+2008-01-28 Kevin Piche <kevin@archlinux.org>
+ Version 1.5.3.7-2
+ * Updated for new perl policy (vendor dirs)
+ * Change license to GPL2
+
+2007-11-01 Eric Belanger <eric@archlinux.org>
+ Version 1.5.3.5-2
+ * Fix Perl module location
diff --git a/abs/core-testing/git/PKGBUILD b/abs/core-testing/git/PKGBUILD
new file mode 100644
index 0000000..dec7a3a
--- /dev/null
+++ b/abs/core-testing/git/PKGBUILD
@@ -0,0 +1,49 @@
+# $Id: PKGBUILD 12487 2008-09-14 16:45:00Z dan $
+# Maintainer: Dan McGee <dan@archlinux.org>
+
+pkgname=git
+pkgver=1.6.0.2
+pkgrel=3
+pkgdesc="GIT - the stupid content tracker"
+arch=(i686 x86_64)
+url="http://git.or.cz/"
+license=('GPL2')
+depends=('curl' 'expat>=2.0' 'perl-error' 'perl>=5.10.0')
+optdepends=('tk: gitk and git gui'
+ 'perl-libwww: git svn'
+ 'subversion: git svn'
+ 'cvsps: git cvsimport')
+replaces=('git-core')
+provides=('git-core')
+source=("http://kernel.org/pub/software/scm/git/${pkgname}-${pkgver}.tar.bz2" \
+ "http://kernel.org/pub/software/scm/git/git-manpages-${pkgver}.tar.bz2")
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make THREADED_DELTA_SEARCH=1 \
+ prefix=/usr gitexecdir=/usr/lib/git-core || return 1
+ make THREADED_DELTA_SEARCH=1 \
+ prefix=/usr gitexecdir=/usr/lib/git-core \
+ INSTALLDIRS=vendor DESTDIR=${pkgdir} install
+
+ # let's plop gitweb in /usr/share
+ mkdir -p $pkgdir/usr/share/ || return 1
+ cp -dR ./gitweb $pkgdir/usr/share/gitweb || return 1
+
+ #bash completion
+ mkdir -p $pkgdir/etc/bash_completion.d/ || return 1
+ install -m644 ./contrib/completion/git-completion.bash $pkgdir/etc/bash_completion.d/git || return 1
+
+ # how 'bout some manpages?
+ for mansect in man1 man5 man7; do
+ for manpage in $srcdir/$mansect/*; do
+ install -D -m644 $manpage $pkgdir/usr/share/man/$mansect/$(basename $manpage)
+ done
+ done
+
+ # remove perllocal.pod, .packlist, and empty directories.
+ rm -rf $pkgdir/usr/lib/perl5
+}
+
+md5sums=('1e4d9bfc1cb0abf165d4de93b5172324'
+ '30bd29d96b4576ef8b7b48ad791f613e')
diff --git a/abs/core-testing/rsync/ChangeLog b/abs/core-testing/rsync/ChangeLog
new file mode 100644
index 0000000..1e26b1c
--- /dev/null
+++ b/abs/core-testing/rsync/ChangeLog
@@ -0,0 +1,20 @@
+2008-09-06 Eric Belanger <eric@archlinux.org>
+
+ * rsync 3.0.4-1
+ * Upstream update
+
+2008-07-05 Eric Belanger <eric@archlinux.org>
+
+ * rsync 3.0.3-1
+ * Upstream update
+
+2008-04-13 Eric Belanger <eric@archlinux.org>
+
+ * rsync 3.0.2-1
+ * Upstream update
+
+2008-03-01 Eric Belanger <eric@archlinux.org>
+
+ * rsync 3.0.0-1
+ * Upstream update
+ * Updated license
diff --git a/abs/core-testing/rsync/PKGBUILD b/abs/core-testing/rsync/PKGBUILD
new file mode 100644
index 0000000..d9f2968
--- /dev/null
+++ b/abs/core-testing/rsync/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=rsync
+pkgver=3.0.4
+pkgrel=2
+pkgdesc="A file transfer program to keep remote files in sync"
+arch=('i686' 'x86_64')
+url="http://samba.anu.edu.au/rsync/"
+license=('GPL3')
+depends=('acl')
+backup=('etc/rsyncd.conf' 'etc/xinetd.d/rsync')
+source=(http://rsync.samba.org/ftp/rsync/${pkgname}-${pkgver}.tar.gz \
+ rsyncd.conf rsyncd rsync.xinetd)
+md5sums=('2b2d159c9bd1b5f8adfd8b13da3a1f3f' '4395c0591638349b1a7aeaaa4da1f03a'\
+ '9de4d03d49f4b5c73ffd67d452716a49' 'ea3e9277dc908bc51f9eddc0f6b935c1')
+sha1sums=('e89ed8d84fe0b6740208ba8183ee1dbc220ba5e5'
+ '48be09294134dfed888818872fe552a59c29147a'
+ 'ebec275bbd0c11692c91dc59368349601bd9eaf4'
+ 'fdb99785bc87ee13d77aa90dc1804f3f75dd7fc1')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./prepare-source || return 1
+ ./configure --prefix=/usr --with-included-popt \
+ --enable-acl-support --enable-xattr-support || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+ install -D -m 755 ../rsyncd ${pkgdir}/etc/rc.d/rsyncd || return 1
+ install -D -m 644 ../rsyncd.conf ${pkgdir}/etc/rsyncd.conf || return 1
+ install -D -m 644 ../rsync.xinetd ${pkgdir}/etc/xinetd.d/rsync || return 1
+}
diff --git a/abs/core-testing/rsync/rsync.xinetd b/abs/core-testing/rsync/rsync.xinetd
new file mode 100644
index 0000000..f5b6b1e
--- /dev/null
+++ b/abs/core-testing/rsync/rsync.xinetd
@@ -0,0 +1,11 @@
+service rsync
+{
+ socket_type = stream
+ wait = no
+ user = root
+ server = /usr/bin/rsync
+ server_args = --daemon
+ log_on_success += HOST DURATION
+ log_on_failure += HOST
+ disable = yes
+}
diff --git a/abs/core-testing/rsync/rsyncd b/abs/core-testing/rsync/rsyncd
new file mode 100644
index 0000000..e1313dc
--- /dev/null
+++ b/abs/core-testing/rsync/rsyncd
@@ -0,0 +1,37 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+case "$1" in
+ start)
+ stat_busy "Starting rsyncd"
+ [ ! -f /var/run/daemons/rsyncd ] && /usr/bin/rsync --daemon
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ pgrep -of "/usr/bin/rsync --daemon" > /var/run/rsyncd.pid
+ add_daemon rsyncd
+ stat_done
+ fi
+ ;;
+
+ stop)
+ stat_busy "Stopping rsyncd"
+ [ -f /var/run/rsyncd.pid ] && kill `cat /var/run/rsyncd.pid`
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon rsyncd
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
+exit 0
diff --git a/abs/core-testing/rsync/rsyncd.conf b/abs/core-testing/rsync/rsyncd.conf
new file mode 100644
index 0000000..f7161f3
--- /dev/null
+++ b/abs/core-testing/rsync/rsyncd.conf
@@ -0,0 +1,16 @@
+uid = nobody
+gid = nobody
+use chroot = no
+max connections = 4
+syslog facility = local5
+pid file = /var/run/rsyncd.pid
+
+[ftp]
+ path = /home/ftp
+ comment = ftp area
+
+#[cvs]
+# path = /data/cvs
+# comment = CVS repository (requires authentication)
+# auth users = tridge, susan
+# secrets file = /etc/rsyncd.secrets