summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-16 06:05:25 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-16 06:05:25 (GMT)
commitfac3c8c6017a5f39ca1aca36f01493fa016d962c (patch)
treed253676e03ac3569b1a4f6b47531e74232f3bf7b /abs/core-testing
parent38194ecb24d72258fd994cdb8aef7d34035c19b3 (diff)
parente2f581d7a980085e0078e01f1a38886ab88127ec (diff)
downloadlinhes_pkgbuild-fac3c8c6017a5f39ca1aca36f01493fa016d962c.zip
linhes_pkgbuild-fac3c8c6017a5f39ca1aca36f01493fa016d962c.tar.gz
linhes_pkgbuild-fac3c8c6017a5f39ca1aca36f01493fa016d962c.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing')
-rw-r--r--abs/core-testing/mysql/PKGBUILD7
-rw-r--r--abs/core-testing/mysql/__changelog7
-rw-r--r--abs/core-testing/mysql/my.cnf4
-rwxr-xr-xabs/core-testing/mysql/mysqld2
-rw-r--r--abs/core-testing/mysql/mysqld.conf.d2
5 files changed, 12 insertions, 10 deletions
diff --git a/abs/core-testing/mysql/PKGBUILD b/abs/core-testing/mysql/PKGBUILD
index 4def9e3..8c9763a 100644
--- a/abs/core-testing/mysql/PKGBUILD
+++ b/abs/core-testing/mysql/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: judd <jvinet@zeroflux.org>
pkgname=mysql
pkgver=5.0.75
-pkgrel=1
+pkgrel=2
pkgdesc="A fast SQL database server"
arch=(i686 x86_64)
backup=(etc/my.cnf etc/conf.d/mysqld)
@@ -48,8 +48,3 @@ build() {
install -D -m644 ../mysqld.conf.d ${startdir}/pkg/etc/conf.d/mysqld
rm -f ${startdir}/pkg/usr/bin/mysql_config
}
-md5sums=('a234f0a60a7f8c290d9875cba3a2c5a2'
- 'e892aac36cbeb57f0e003ec0936afb3b'
- '247e9fa664bccaca62ca0e42a6cfae20'
- '0ee035590ffc61d32de994f461fd2bd2'
- '4a9077fc95ec6db1d5420e0cdc74d31c')
diff --git a/abs/core-testing/mysql/__changelog b/abs/core-testing/mysql/__changelog
new file mode 100644
index 0000000..5e620ec
--- /dev/null
+++ b/abs/core-testing/mysql/__changelog
@@ -0,0 +1,7 @@
+my.cnf
+-enable networking
+-datadir /data/srv/mysql
+
+mysqld
+ -redirect output to /dev/null
+ --skip-name-resolve \ No newline at end of file
diff --git a/abs/core-testing/mysql/my.cnf b/abs/core-testing/mysql/my.cnf
index 927b9c8..7202fcd 100644
--- a/abs/core-testing/mysql/my.cnf
+++ b/abs/core-testing/mysql/my.cnf
@@ -20,7 +20,7 @@ socket = /tmp/mysql.sock
[mysqld]
port = 3306
socket = /tmp/mysql.sock
-datadir = /var/lib/mysql
+datadir = /data/srv/mysql
skip-locking
key_buffer = 16M
max_allowed_packet = 1M
@@ -35,7 +35,7 @@ myisam_sort_buffer_size = 8M
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
#
-skip-networking
+#skip-networking
# Replication Master Server (default)
# binary logging is required for replication
diff --git a/abs/core-testing/mysql/mysqld b/abs/core-testing/mysql/mysqld
index 843397e..7bada3d 100755
--- a/abs/core-testing/mysql/mysqld
+++ b/abs/core-testing/mysql/mysqld
@@ -31,7 +31,7 @@ case "$1" in
start)
stat_busy "Starting MySQL"
if [ -z "$PID" ]; then
- /usr/bin/mysqld_safe --datadir=$MYSQLD_ROOT &>/dev/null &
+ /usr/bin/mysqld_safe --skip-name-resolve --datadir=$MYSQLD_ROOT >/dev/null 2>/dev/null &
if [ $? -gt 0 ]; then
stat_fail
exit 1
diff --git a/abs/core-testing/mysql/mysqld.conf.d b/abs/core-testing/mysql/mysqld.conf.d
index 04752b1..10b7098 100644
--- a/abs/core-testing/mysql/mysqld.conf.d
+++ b/abs/core-testing/mysql/mysqld.conf.d
@@ -1 +1 @@
-MYSQLD_ROOT="/var/lib/mysql"
+MYSQLD_ROOT="/data/srv/mysql"