summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-config
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-03-25 19:25:59 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-03-25 19:25:59 (GMT)
commit21454b205c83cacadc9773dfda8db67fd5820bfb (patch)
tree84e6087a4b2d942d3740bc0b4d1ac38431fc3f90 /abs/core/LinHES-config
parentf3dc167e69299c96c759c86c96a8af44e05e2ff1 (diff)
downloadlinhes_pkgbuild-21454b205c83cacadc9773dfda8db67fd5820bfb.zip
linhes_pkgbuild-21454b205c83cacadc9773dfda8db67fd5820bfb.tar.gz
linhes_pkgbuild-21454b205c83cacadc9773dfda8db67fd5820bfb.tar.bz2
LinHES-config: mv_ir.py: mv /etc/lircd.conf to /etc/lircd.conf.d/ for lirc 0.9.2
Diffstat (limited to 'abs/core/LinHES-config')
-rwxr-xr-xabs/core/LinHES-config/PKGBUILD4
-rwxr-xr-xabs/core/LinHES-config/mv_ir.py30
2 files changed, 23 insertions, 11 deletions
diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index e35f4a4..4bdde13 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=8.3
-pkgrel=12
+pkgrel=13
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
pkgdesc="Install and configure your system"
depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -162,7 +162,7 @@ md5sums=('17d9dd5a097fbbd4dae75dff8e2677ff'
'c0549457750c4f8e8038d904a0f3012a'
'cb7abd558b6540bc5e2232866a2a42f8'
'b845de3e05c1734cce4b9ac5e8f1baaf'
- '077ebce663edba30ba7f93e4d245d125'
+ '02b4378b17bca6bebdcc2258a80dfc6b'
'8b7dce4a3a0a281fa6656aa8781a648e'
'4b10fff21a0274f950f97f2b61e92463'
'824e49d9b01fed295c704ab68908b464'
diff --git a/abs/core/LinHES-config/mv_ir.py b/abs/core/LinHES-config/mv_ir.py
index 8eab7b0..bab77a5 100755
--- a/abs/core/LinHES-config/mv_ir.py
+++ b/abs/core/LinHES-config/mv_ir.py
@@ -34,13 +34,15 @@ def setup_lirc_links(mythhome):
if os.path.exists("/etc/lircrc"):
if not os.path.exists(mythhome+"/.mythtv/lircrc"):
logging.debug(" Creating symlink for myth lircrc")
- os.symlink("/etc/lircrc",mythhome+"/.mythtv/lircrc")
+ #os.symlink("/etc/lircrc",mythhome+"/.mythtv/lircrc")
+ mv_common.link_file("/etc/lircrc",mythhome+"/.mythtv/lircrc")
else:
logging.debug(" %s/lircrc already present",mythhome)
if not os.path.exists(mythhome+"/.lircrc"):
logging.debug(" Creating symlink for lircrc")
- os.symlink("/etc/lircrc",mythhome+"/.lircrc")
+ #os.symlink("/etc/lircrc",mythhome+"/.lircrc")
+ mv_common.link_file("/etc/lircrc",mythhome+"/.lircrc")
else:
logging.debug(" %s/.lircrc already present",mythhome)
else:
@@ -49,7 +51,8 @@ def setup_lirc_links(mythhome):
if os.path.exists("/etc/wol-lircrc"):
if not os.path.exists(mythhome+"/.wol-lircrc"):
logging.debug(" Creating symlink for .wol-lircrc")
- os.symlink("/etc/wol-lircrc",mythhome+"/.wol-lircrc")
+ #os.symlink("/etc/wol-lircrc",mythhome+"/.wol-lircrc")
+ mv_common.link_file("/etc/wol-lircrc",mythhome+"/.wol-lircrc")
else:
logging.debug(" %s/.wol-lircrc already present",mythhome)
else:
@@ -108,6 +111,12 @@ def setup_ir_remote(Remotetype,templates,mythhome,HostBlasterType,remotebucket):
currenttime = strftime("%b-%d-%Y-%H:%M:%S", localtime())
cmd = "mv /etc/lircd.conf /etc/lircd.conf-%s" %currenttime
mv_common.runcmd(cmd)
+ cmd = "mv /etc/lirc/lircd.conf.d/remote_lircd.conf /etc/lirc/lircd.conf.d/remote_lircd.conf-%s" %currenttime
+ mv_common.runcmd(cmd)
+ cmd = "mv /etc/lirc/lircd.conf.d/blaster_lircd.conf /etc/lirc/lircd.conf.d/blaster_lircd.conf-%s" %currenttime
+ mv_common.runcmd(cmd)
+ cmd = "mv /etc/lirc/lircd.conf.d/lcd_lircd.conf /etc/lirc/lircd.conf.d/lcd_lircd.conf-%s" %currenttime
+ mv_common.runcmd(cmd)
cmd = "mv /etc/lircrc /etc/lircrc-%s" %currenttime
mv_common.runcmd(cmd)
cmd = "mv /etc/wol-lircrc /etc/wol-lircrc-%s" %currenttime
@@ -121,13 +130,14 @@ def setup_ir_remote(Remotetype,templates,mythhome,HostBlasterType,remotebucket):
files = remote_path + "/lircd*"
logging.debug(" Using %s",files)
- # /etc/lircd.conf symlink
+ # was /etc/lircd.conf symlink
+ # /etc/lirc/lircd.conf.d/remote_lircd.conf symlink
for filename in glob.glob(files):
# Ignore subfolders
if os.path.isdir (filename):
logging.debug(" %s is a dir, skipping",filename)
continue
- os.symlink(filename,"/etc/lircd.conf")
+ mv_common.link_file(filename,"/etc/lirc/lircd.conf.d/remote_lircd.conf")
#files = templates + "/remotes/" + Remotetype + "/lircrc*"
# include lircrc
@@ -198,7 +208,7 @@ def setup_ir_remote(Remotetype,templates,mythhome,HostBlasterType,remotebucket):
cmd = ''' rm -f %s''' %(userLircmap)
mv_common.runcmd(cmd)
logging.debug(" Creating symlink for %s Lircmap.xml",app)
- os.symlink(kodifile, mythhome+"/"+userdirname+"/userdata/Lircmap.xml")
+ mv_common.link_file(kodifile, mythhome+"/"+userdirname+"/userdata/Lircmap.xml")
except:
pass
else:
@@ -316,8 +326,9 @@ def setup_blaster_proto(HostBlasterType,Hostnumblaster,TEMPLATES,systemconfig):
continue
template=TEMPLATES+"/transmit/%s/lircd.conf" %proto
if os.path.exists(template):
- logging.debug(" include blaster template: %s",proto)
- include_file("/etc/lircd.conf",template)
+ logging.debug(" link blaster template: %s",proto)
+ mv_common.link_file(template,"/etc/lirc/lircd.conf.d/blaster_lircd.conf")
+ #include_file("/etc/lircd.conf",template)
else:
logging.debug(" template: %s is not present",template)
@@ -400,7 +411,8 @@ def setup_lcd(LCDtype, TEMPLATES, Remotetype, this_is_install):
if os.path.isdir (filename):
logging.debug(" %s is a dir, skipping",filename)
continue
- include_file("/etc/lircd.conf",filename)
+ mv_common.link_file(filename,"/etc/lirc/lircd.conf.d/lcd_lircd.conf")
+ #include_file("/etc/lircd.conf",filename)
files = lcdlirc+"/lircrc*"
logging.debug(" Using %s",files)
for filename in glob.glob(files):