summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-config
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-10-31 15:09:21 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-10-31 15:09:21 (GMT)
commit2424137eb9b302aaaab20dc49dc2d6afe4d3f107 (patch)
tree9af08503ee9e9c21d5d5c1b888fd0369d82f1ae1 /abs/core/LinHES-config
parent1485cf1105f30b4542c28b688c3478ce39b883c7 (diff)
downloadlinhes_pkgbuild-2424137eb9b302aaaab20dc49dc2d6afe4d3f107.zip
linhes_pkgbuild-2424137eb9b302aaaab20dc49dc2d6afe4d3f107.tar.gz
linhes_pkgbuild-2424137eb9b302aaaab20dc49dc2d6afe4d3f107.tar.bz2
LinHES-config: change location of config for installs. The new location is /etc/install_layout
Fix bug with new installs, where backendIP was being set to 127.0.01 after restoring distro defaults. We still want defaults restored, but after restoring run hostype to set the backendserver ip again refs #858 refs #790
Diffstat (limited to 'abs/core/LinHES-config')
-rwxr-xr-xabs/core/LinHES-config/PKGBUILD4
-rwxr-xr-xabs/core/LinHES-config/mv_install.py11
2 files changed, 10 insertions, 5 deletions
diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index 4954da3..b86421e 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=2.3
-pkgrel=174
+pkgrel=175
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
pkgdesc="Install and configure your system"
depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -125,7 +125,7 @@ build() {
install -o root -g root -D -m 0755 blacklist_pcspkr.conf $startdir/pkg/etc/modprobe.d/blacklist_pcspkr.conf
install -o root -g root -D -m 0755 blacklist_nouveau.conf $startdir/pkg/etc/modprobe.d/blacklist_nouveau.conf
}
-md5sums=('cf5c419e6a719ba9be3f266038727bba'
+md5sums=('6a9a22b3c3cb74d9f1ac595cf437a7b7'
'f33e1a6f7985091b8d47cbaf7433f90f'
'17677b9e25b8fe3511ad3a139ed91eea'
'2596460462cf6c889cf8f95485537b20'
diff --git a/abs/core/LinHES-config/mv_install.py b/abs/core/LinHES-config/mv_install.py
index 61e4405..522fc23 100755
--- a/abs/core/LinHES-config/mv_install.py
+++ b/abs/core/LinHES-config/mv_install.py
@@ -17,7 +17,7 @@ def usage():
print "The conf file is read when no command line options are given"
print " /etc/systemconfig must also be present "
- print "Create /etc/install_conf, with contents similiar to this. Sizes are in MB"
+ print "Create /etc/install_layout, with contents similiar to this. Sizes are in MB"
print " rootdisk=sda"
print " rootfs=ext4"
print " rootsize=5000"
@@ -1558,7 +1558,7 @@ def full_install(hostoptions):
logging.info("______Configuring system________")
cp_and_log("/etc/systemconfig", data_config.MOUNTPOINT+"/etc/systemconfig")
- cp_and_log("/etc/install_conf", data_config.MOUNTPOINT+"/etc/install_conf")
+ cp_and_log("/etc/install_layout", data_config.MOUNTPOINT+"/etc/install_layout")
cp_and_log("/root/xorg.conf.install", data_config.MOUNTPOINT+"/etc/X11/xorg.conf.install")
restore_default_settings() #also calls copy_updates, fix permissions
@@ -1634,6 +1634,11 @@ def full_install(hostoptions):
cmd = "chroot %s %s/bin/myth_settings_wrapper.sh -c ACCESSCONTROL " %(data_config.MOUNTPOINT, MVROOT)
runcmd(cmd)
+
+ #run hostype again to set BackendServerIP. This value is overwritten with distro_default restore
+ cmd = "chroot %s %s/bin/systemconfig.sh hostype,this_is_install" %(data_config.MOUNTPOINT, MVROOT)
+ runcmd(cmd)
+
umount_bind_chroot()
cmd = "chroot %s touch %s/.configure" %(data_config.MOUNTPOINT, data_config.MYTHHOME)
@@ -2115,7 +2120,7 @@ for line in config_file:
#Read in install_conf
global install_conf
install_conf = {}
-file_name = "/etc/install_conf"
+file_name = "/etc/install_layout"
try:
config_file = open(file_name)
except: