summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-config
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-11 18:46:05 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-11 18:46:05 (GMT)
commit3b85d20d92918dd93f864366a9b42fac49650dd8 (patch)
tree99a54195e2e9ec44e2888f22b8bf559fb5fa857b /abs/core/LinHES-config
parent11f9af48eacb4a109936361cbf963bd834d7e3c8 (diff)
downloadlinhes_pkgbuild-3b85d20d92918dd93f864366a9b42fac49650dd8.zip
linhes_pkgbuild-3b85d20d92918dd93f864366a9b42fac49650dd8.tar.gz
linhes_pkgbuild-3b85d20d92918dd93f864366a9b42fac49650dd8.tar.bz2
LinHES-config: mv_install.py Only add storage groups on machine classes that use the backend. So FE only machines end up with no SG associated with it's hostname.
refs #880
Diffstat (limited to 'abs/core/LinHES-config')
-rwxr-xr-xabs/core/LinHES-config/PKGBUILD4
-rwxr-xr-xabs/core/LinHES-config/mv_install.py5
2 files changed, 5 insertions, 4 deletions
diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index 1e415a7..e5b1120 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=2.3
-pkgrel=192
+pkgrel=194
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
pkgdesc="Install and configure your system"
depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -127,7 +127,7 @@ build() {
install -o root -g root -D -m 0755 blacklist_pcspkr.conf $startdir/pkg/etc/modprobe.d/blacklist_pcspkr.conf
install -o root -g root -D -m 0755 blacklist_nouveau.conf $startdir/pkg/etc/modprobe.d/blacklist_nouveau.conf
}
-md5sums=('0bde52e0cc7708f3c208d4b424da49cc'
+md5sums=('26e20dba8d1bea96a07131ef945fd2f7'
'3f6855b7bb860a44f96a972c2e80f497'
'17677b9e25b8fe3511ad3a139ed91eea'
'2596460462cf6c889cf8f95485537b20'
diff --git a/abs/core/LinHES-config/mv_install.py b/abs/core/LinHES-config/mv_install.py
index cb19f2b..e78c548 100755
--- a/abs/core/LinHES-config/mv_install.py
+++ b/abs/core/LinHES-config/mv_install.py
@@ -1154,10 +1154,10 @@ def double_mount(fe_only=False, upgrade=False):
cmd = "chroot " + data_config.MOUNTPOINT +" /usr/LH/bin/add_storage.py --reconstruct --no_mount"
else:
if fe_only == True:
- cmd = "chroot " + data_config.MOUNTPOINT +" /usr/LH/bin/add_storage.py --double_myth --no_mount --fe_only"
+ cmd = "chroot " + data_config.MOUNTPOINT +" /usr/LH/bin/add_storage.py --double_myth --no_mount"
else:
#cmd = "chroot " + data_config.MOUNTPOINT +" /usr/LH/bin/add_storage.py --double_myth --no_mount"
- cmd = "chroot " + data_config.MOUNTPOINT +" /usr/LH/bin/add_storage.py --double_myth "
+ cmd = "chroot " + data_config.MOUNTPOINT +" /usr/LH/bin/add_storage.py --double_myth --add_fe_sg --add_be_sg "
if runcmd(cmd)[0] == 0:
logging.debug(" Add storage worked, breaking out of loop")
@@ -1586,6 +1586,7 @@ def full_install(hostoptions):
mount_bind_chroot()
logging.info("Running systemconfig in chroot")
cmd = "chroot %s %s/bin/systemconfig.sh config_xml,this_is_install" %(data_config.MOUNTPOINT, MVROOT)
+ runcmd(cmd)
umount_bind_chroot()