summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-config
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-01-27 20:43:45 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-01-27 20:43:45 (GMT)
commit5211b30fbeab9533f21e3d320ca1d8494d50a86b (patch)
tree796dd4b6d5c5c916df3bb8f29c1e5cee7ce460d8 /abs/core/LinHES-config
parent777eac25810b40d03602036f3a28466d0db83adc (diff)
downloadlinhes_pkgbuild-5211b30fbeab9533f21e3d320ca1d8494d50a86b.zip
linhes_pkgbuild-5211b30fbeab9533f21e3d320ca1d8494d50a86b.tar.gz
linhes_pkgbuild-5211b30fbeab9533f21e3d320ca1d8494d50a86b.tar.bz2
LinHES-config, supplimental-web: Fix proxy numbering for Ceton infiniTV
refs #899
Diffstat (limited to 'abs/core/LinHES-config')
-rwxr-xr-xabs/core/LinHES-config/PKGBUILD4
-rw-r--r--abs/core/LinHES-config/autocard.py14
2 files changed, 11 insertions, 7 deletions
diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index df3bbb6..e1e78cb 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=2.3
-pkgrel=211
+pkgrel=216
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
pkgdesc="Install and configure your system"
depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -152,7 +152,7 @@ md5sums=('32fc2b52809231d75a72492b91eeed74'
'ab2aa42c2947148c2b1cac0ade6d1d55'
'd429b59d3cfb37b0624c6a4a71a7c2c0'
'f6a935c35123fdc7c259c01cbc794a64'
- 'd318046ff657ddec6f701bb9f52e9cce'
+ '5e865cc04fe5de8a39d9c1e377fc4ebe'
'd3490e93f313bbbcbc6c3693c56b9c17'
'3d1e4a119f38cff0498bf8a67e94e4b3'
'71fd2d0d448fc2fcd15415a1beed7109'
diff --git a/abs/core/LinHES-config/autocard.py b/abs/core/LinHES-config/autocard.py
index 48b6e06..c461714 100644
--- a/abs/core/LinHES-config/autocard.py
+++ b/abs/core/LinHES-config/autocard.py
@@ -556,6 +556,7 @@ class dvb_tuners():
class infinitv_tuner():
def __init__(self, tuner_number,ip):
self.tuner_number = tuner_number
+ self.ceton_defined_tuner = tuner_number + 1
self.ip = ip
self.serial_num = self.find_serial()
self.connection = self.find_connection()
@@ -590,7 +591,7 @@ class infinitv_tuner():
def find_description(self):
desc="Ceton InfiniTV %s Tuner %s" %(self.connection,
- self.tuner_number)
+ self.ceton_defined_tuner)
return desc
def do_insert(self):
@@ -762,7 +763,7 @@ def gather_ceton(tuner_list):
for iface in ceton_network_list:
#command="cat /tmp/find_ceton.txt"
print "Scanning %s network for ceton infinitv" %iface
- command="/root/discover_infinitv.py %s" %iface
+ command="/usr/MythVantage/bin/discover_infinitv.py %s" %iface
results=os.popen(command,'r')
lines=results.readlines()
#try:
@@ -774,7 +775,7 @@ def gather_ceton(tuner_list):
#cetondevice = line.strip().split()[0]
cetonip = line.strip().split("/")[2]
- tuners = [1,2,3,4]
+ tuners = [0,1,2,3]
for t in tuners:
tuner_list.append(infinitv_tuner(t,cetonip))
#except:
@@ -1008,6 +1009,7 @@ def main(argv):
if "insertdb" in argv:
insertdb = True
udev = True
+ write_proxy = True
if "write_proxy" in argv:
write_proxy = True
@@ -1022,11 +1024,11 @@ def main(argv):
rule_list = []
#setting the proxy port for ceton webpage
- ceton_proxy = 0
+ ceton_proxy = 1
for i in tuner_list:
if i.get_card_type() == "infinitv":
- ceton_proxy = ceton_proxy + 1
i.set_proxy(ceton_proxy)
+ ceton_proxy = ceton_proxy + 1
#setting the hostname for each tuner
i.set_hostname(localhostname)
@@ -1050,6 +1052,8 @@ def main(argv):
restart_proxy=True
if restart_proxy == True:
+ command="add_service.sh cetonproxy"
+ os.system(command)
print" Restarting ceton proxy"
command="sv restart cetonproxy"
os.system(command)