summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-config
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-09-10 22:47:02 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-09-10 22:47:02 (GMT)
commit64127038ec022ae71473719254c71f5efa79bf82 (patch)
treeac21a7c22c91977349bc66fce46dcff266f2c7b0 /abs/core/LinHES-config
parent9390f29e452fe94e48ffbb7674f8ce5cc045cc3a (diff)
downloadlinhes_pkgbuild-64127038ec022ae71473719254c71f5efa79bf82.zip
linhes_pkgbuild-64127038ec022ae71473719254c71f5efa79bf82.tar.gz
linhes_pkgbuild-64127038ec022ae71473719254c71f5efa79bf82.tar.bz2
mv_install: change partition layout to 5 partition instead of the older 3 style
1 = / 2 swap 3 extended { 5,6,7 } home/mysql/myth
Diffstat (limited to 'abs/core/LinHES-config')
-rwxr-xr-xabs/core/LinHES-config/PKGBUILD6
-rwxr-xr-xabs/core/LinHES-config/mv_install.py25
2 files changed, 22 insertions, 9 deletions
diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index 7eb4cae..2d9e0d6 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=2.3
-pkgrel=127
+pkgrel=132
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
pkgdesc="Install and configure your system"
depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -125,7 +125,7 @@ build() {
install -o root -g root -D -m 0755 blacklist_pcspkr.conf $startdir/pkg/etc/modprobe.d/blacklist_pcspkr.conf
install -o root -g root -D -m 0755 blacklist_nouveau.conf $startdir/pkg/etc/modprobe.d/blacklist_nouveau.conf
}
-md5sums=('98706973a3266476fb6414ffa8e8a18f'
+md5sums=('5d5a33523956d3e56d8d5913fcdc0855'
'f33e1a6f7985091b8d47cbaf7433f90f'
'04c72de15178f1577ce40a8cb045930a'
'2596460462cf6c889cf8f95485537b20'
@@ -160,7 +160,7 @@ md5sums=('98706973a3266476fb6414ffa8e8a18f'
'cc5ee06e2182bb825ca3712a1c1afb64'
'919909f4d23b9ee3caf71193c042cc40'
'85101b79d1ee30bff8244c810828033f'
- 'd81d7ee9996e61ec859f3338ee10fce8'
+ 'f15d7fef91565494deb0de50bb67a957'
'419a2eaa52b8639da1076828a85bf355'
'2596460462cf6c889cf8f95485537b20'
'4cba2bb55c6b8e27c57a6171f42d0455'
diff --git a/abs/core/LinHES-config/mv_install.py b/abs/core/LinHES-config/mv_install.py
index a447851..ccfcb8e 100755
--- a/abs/core/LinHES-config/mv_install.py
+++ b/abs/core/LinHES-config/mv_install.py
@@ -1142,7 +1142,7 @@ def grub_it():
cmd="chroot %s grub-mkconfig -o /boot/grub/grub.cfg" %data_config.MOUNTPOINT
runcmd(cmd)
-def double_mount(fe_only=False):
+def double_mount(fe_only=False, upgrade=False):
logging.info(" double bind mount attempt")
cmd = "mkdir %s/run/dbus" %data_config.MOUNTPOINT
runcmd(cmd)
@@ -1150,10 +1150,14 @@ def double_mount(fe_only=False):
cmd = " mount --bind /run/dbus %s/run/dbus" %data_config.MOUNTPOINT
runcmd(cmd)
for i in range(0,5):
- if fe_only == True:
- cmd = "chroot " + data_config.MOUNTPOINT +" /usr/LH/bin/add_storage.py --double_myth --no_mount --fe_only"
+ if upgrade == True:
+ cmd = "chroot " + data_config.MOUNTPOINT +" /usr/LH/bin/add_storage.py --reconstruct --no_mount"
else:
- cmd = "chroot " + data_config.MOUNTPOINT +" /usr/LH/bin/add_storage.py --double_myth --no_mount"
+ if fe_only == True:
+ cmd = "chroot " + data_config.MOUNTPOINT +" /usr/LH/bin/add_storage.py --double_myth --no_mount --fe_only"
+ else:
+ cmd = "chroot " + data_config.MOUNTPOINT +" /usr/LH/bin/add_storage.py --double_myth --no_mount"
+
if runcmd(cmd)[0] == 0:
logging.debug(" Add storage worked, breaking out of loop")
break
@@ -1576,13 +1580,13 @@ def full_install(hostoptions):
if rc != 0 :
error_out("Running systemconfig")
- move_myth_home("backup")
+ #move_myth_home("backup")
mysqldb("start","chroot")
double_mount()
mysqldb("stop", "chroot")
- move_myth_home("restore") #restoring after the bind mound/symlink has occured
+ #move_myth_home("restore") #restoring after the bind mound/symlink has occured
#kill_dhcp_chroot()
logging.info("____End Database in CHROOT____")
@@ -1793,12 +1797,19 @@ def upgrade(hostoptions):
cp_and_log("/tmp/alsa/", data_config.MOUNTPOINT+"/alsa.old/")
cp_and_log("/tmp/oss", data_config.MOUNTPOINT+"/var/lib/oss.old")
+
srcfile = "%s/etc.old/ssh/" %(data_config.MOUNTPOINT)
destfile = "%s/etc/ssh/" %(data_config.MOUNTPOINT)
cp_and_log2(srcfile, destfile, '*.pub')
cp_and_log2(srcfile, destfile, '*.key')
cp_and_log2(srcfile, destfile, '*key')
+ srcfile = "%s/etc.old/storage.d/" %(data_config.MOUNTPOINT)
+ destfile = "%s/etc/storage.d/" %(data_config.MOUNTPOINT)
+ cp_and_log2(srcfile, destfile, '*.conf')
+ cp_and_log2(srcfile, destfile, '*.pkl')
+
+
mdfile = mdadm_find("/tmp")
cp_and_log("/tmp"+mdfile, data_config.MOUNTPOINT+"/etc")
@@ -1908,6 +1919,8 @@ def upgrade(hostoptions):
#run systemconfig in chroot
mount_bind_chroot()
+ #make symlink only..no need to double_mount as fstab should already have that, unless it's a clean upgrade
+ double_mount(upgrade=True)
logging.info("Running systemconfig in chroot time")
cmd = "chroot %s %s/bin/systemconfig.sh all,this_is_install" %(data_config.MOUNTPOINT, MVROOT)
rc = runcmd(cmd)[0]