summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-config
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-08-19 19:24:34 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-08-19 19:24:34 (GMT)
commit684d6d5183cd2a664461de2c1768e79ab719edb6 (patch)
treed33cfaef25693db555291b445fb6e021b29b13c8 /abs/core/LinHES-config
parentd8d2aae879a6204510120d6056df61ae0f249c3c (diff)
downloadlinhes_pkgbuild-684d6d5183cd2a664461de2c1768e79ab719edb6.zip
linhes_pkgbuild-684d6d5183cd2a664461de2c1768e79ab719edb6.tar.gz
linhes_pkgbuild-684d6d5183cd2a664461de2c1768e79ab719edb6.tar.bz2
LinHES-config: minor update to help.
systemconfig.py -h will not list all the available modules
Diffstat (limited to 'abs/core/LinHES-config')
-rwxr-xr-xabs/core/LinHES-config/PKGBUILD4
-rwxr-xr-xabs/core/LinHES-config/systemconfig.py36
2 files changed, 34 insertions, 6 deletions
diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index 978e0db..adf5d69 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=8.2
-pkgrel=2
+pkgrel=3
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
pkgdesc="Install and configure your system"
depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -171,7 +171,7 @@ md5sums=('63f1a1f3725f28b1c07875f4f43bdd6a'
'299c24c0820fc9c483c820db2595e3cb'
'73ed13881c748375296454746c865cd2'
'781f161a79c3188a31c8615b8258b241'
- '18370d92ba6b467bcc4996c377e1fa1f'
+ '888a6c57f272d9fa3e77e216a421562b'
'2596460462cf6c889cf8f95485537b20'
'dc3c5270691a62600475705f4cb78b56'
'4804aa93aaad3dfcfff08cd9ffd68836'
diff --git a/abs/core/LinHES-config/systemconfig.py b/abs/core/LinHES-config/systemconfig.py
index ed19675..c7cbb8a 100755
--- a/abs/core/LinHES-config/systemconfig.py
+++ b/abs/core/LinHES-config/systemconfig.py
@@ -33,7 +33,35 @@ logging.getLogger('').addHandler(infofile)
def usage():
- logging.info("tell people how to use this")
+ logging.info("List of available modules")
+ logging.info("more then one module by be called")
+ logging.info("Ex: misc,sleep,audio")
+ cmd_list = ["misc",
+ "sleep",
+ "hostype",
+ "hostypec" ,
+ "advanced" ,
+ "audio" ,
+ "network" ,
+ "advancedX" ,
+ "webuser" ,
+ "restartfe" ,
+ "reloadfe" ,
+ "ddns" ,
+ "screensaver" ,
+ "ir" ,
+ "user",
+ "software",
+ "plugins",
+ "smolt",
+ "all",
+ "func",
+ "supplemental",
+ "vnc",
+ "fileshare",
+ "config_xml"]
+ for i in cmd_list:
+ logging.info(i)
def setup_x(systemconfig):
if mv_common.read_config(mv_common.module_config,"xorg") == False :
@@ -95,9 +123,9 @@ def generate_config_xml(uuid,dbhost):
</UPnP>
</Configuration>
'''
-
-
-
+
+
+
configxml= configxml_t %(dbhost,uuid)
return configxml