summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-config
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-02-19 20:58:28 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-02-19 20:58:28 (GMT)
commit7e6f7ca174e1af67178dc5293a312a4a733eb095 (patch)
tree40951fb8e7fdbe28a0baa324ae615055203f1e2e /abs/core/LinHES-config
parent02bf569b82235df729c93238104467df7013f9d7 (diff)
downloadlinhes_pkgbuild-7e6f7ca174e1af67178dc5293a312a4a733eb095.zip
linhes_pkgbuild-7e6f7ca174e1af67178dc5293a312a4a733eb095.tar.gz
linhes_pkgbuild-7e6f7ca174e1af67178dc5293a312a4a733eb095.tar.bz2
LinHES-config: during install don't kill off lirc. This keeps the remote active all the way to the finish
Diffstat (limited to 'abs/core/LinHES-config')
-rwxr-xr-xabs/core/LinHES-config/PKGBUILD6
-rwxr-xr-xabs/core/LinHES-config/mv_ir.py37
-rwxr-xr-xabs/core/LinHES-config/systemconfig.py2
3 files changed, 24 insertions, 21 deletions
diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index c7cf189..449f456 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=8.0
-pkgrel=1
+pkgrel=2
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
pkgdesc="Install and configure your system"
depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -159,7 +159,7 @@ md5sums=('7cdc9bc678ab02a2d30444e20a3c71eb'
'c0549457750c4f8e8038d904a0f3012a'
'3d1e3c7315881a109fb089a540d2262c'
'b845de3e05c1734cce4b9ac5e8f1baaf'
- '33941466545815c58e8e49190cf04eaa'
+ 'f9b38f3d8e6d25b7c67b4c33cdee58db'
'8b7dce4a3a0a281fa6656aa8781a648e'
'f7f2dc11d1ba454cd25eeaa133104b62'
'824e49d9b01fed295c704ab68908b464'
@@ -171,7 +171,7 @@ md5sums=('7cdc9bc678ab02a2d30444e20a3c71eb'
'299c24c0820fc9c483c820db2595e3cb'
'cf51cb22e23218ae7e9b55cac1ba3a7f'
'e4b61402858058f7575b776d62d5ee89'
- 'c2ef0f1140bd3fbeb44294fdf5415a32'
+ '1a17256202d851f37c54f2836c244b5d'
'2596460462cf6c889cf8f95485537b20'
'dc3c5270691a62600475705f4cb78b56'
'4804aa93aaad3dfcfff08cd9ffd68836'
diff --git a/abs/core/LinHES-config/mv_ir.py b/abs/core/LinHES-config/mv_ir.py
index 40e5fee..d77f64f 100755
--- a/abs/core/LinHES-config/mv_ir.py
+++ b/abs/core/LinHES-config/mv_ir.py
@@ -56,18 +56,19 @@ def add_module(filename,module):
cmd = ''' echo "%s" >> %s ''' %(module,filename)
mv_common.runcmd(cmd)
-def unload_all_lirc(Remotetype):
- logging.debug(" Unloading all remote modules")
- #ati bucket specific
- if "snapstream_firefly" in Remotetype :
- cmd = "rmmod ati_remote"
+def unload_all_lirc(Remotetype, this_is_install):
+ if this_is_install == False:
+ logging.debug(" Unloading all remote modules")
+ #ati bucket specific
+ if "snapstream_firefly" in Remotetype :
+ cmd = "rmmod ati_remote"
+ mv_common.runcmd(cmd)
+ cmd = "sv stop remotes"
+ mv_common.runcmd(cmd)
+ cmd = "killall -9 lircd"
+ mv_common.runcmd(cmd)
+ cmd = '''modprobe -r $(lsmod |grep ^lirc |awk '{print $1}') '''
mv_common.runcmd(cmd)
- cmd = "sv stop remotes"
- mv_common.runcmd(cmd)
- cmd = "killall -9 lircd"
- mv_common.runcmd(cmd)
- cmd = '''modprobe -r $(lsmod |grep ^lirc |awk '{print $1}') '''
- mv_common.runcmd(cmd)
@@ -273,7 +274,7 @@ def setup_blaster_transmiter(HostBlasterType):
else:
scrub_modules("/etc/modules.mythvantage","blaster")
-def setup_lcd(LCDtype, TEMPLATES, Remotetype):
+def setup_lcd(LCDtype, TEMPLATES, Remotetype, this_is_install):
logging.debug("____Start of setup_lcd____")
logging.debug(" LCDType: %s", LCDtype)
logging.debug(" Remotetype: %s", Remotetype)
@@ -286,8 +287,9 @@ def setup_lcd(LCDtype, TEMPLATES, Remotetype):
cmd = "sv stop lcdd"
mv_common.runcmd(cmd)
#sometimes it doesn't want to die
- cmd = "killall -9 LCDd"
- mv_common.runcmd(cmd)
+ if this_is_install == False:
+ cmd = "killall -9 LCDd"
+ mv_common.runcmd(cmd)
cmd = "load-modules-mythvantage.sh UNLOAD LCD"
mv_common.runcmd(cmd)
scrub_modules("/etc/modules.mythvantage", "LCD")
@@ -336,7 +338,7 @@ def setup_lcd(LCDtype, TEMPLATES, Remotetype):
mv_common.restart_service("lcdd")
logging.debug("__End of setup_lcd")
-def setup_ir(systemconfig, data_config):
+def setup_ir(systemconfig, data_config, this_is_install):
rc = [ False , False ]
if mv_common.read_config(mv_common.module_config,"ir") == False :
logging.info("____Skipping of IR, config disabled____")
@@ -372,7 +374,7 @@ def setup_ir(systemconfig, data_config):
systemconfig.get("mythip"))
else:
setup_ir_receiver("unknown", systemconfig.get("TEMPLATES"),'','127.0.0.1')
- unload_all_lirc(remotetype)
+ unload_all_lirc(remotetype, this_is_install)
setup_blaster_proto(HostBlasterType,
Hostnumblaster,
systemconfig.get("TEMPLATES"),
@@ -388,7 +390,8 @@ def setup_ir(systemconfig, data_config):
if systemconfig.get("LCDtype"):
setup_lcd(systemconfig.get("LCDtype"),
systemconfig.get("TEMPLATES"),
- systemconfig.get("Remotetype"))
+ systemconfig.get("Remotetype"),
+ this_is_install)
else:
logging.debug(" LCD not defined")
logging.info("__End IR\n")
diff --git a/abs/core/LinHES-config/systemconfig.py b/abs/core/LinHES-config/systemconfig.py
index d9c83b7..f7e3f5d 100755
--- a/abs/core/LinHES-config/systemconfig.py
+++ b/abs/core/LinHES-config/systemconfig.py
@@ -255,7 +255,7 @@ def main(argv):
if cmdmodule["ir"] == True:
import mv_ir
- restart = mv_ir.setup_ir(systemconfig,data_config)
+ restart = mv_ir.setup_ir(systemconfig,data_config,cmdmodule["this_is_install"])
restartfe = restart[0]
restartlcd = restart[1]
if restartfe == True :