summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-config
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-09-09 20:56:47 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-09-09 20:56:47 (GMT)
commit83ccffcdbdebaf747577922ea38ac1cfb0e70fc8 (patch)
tree3f19dc3ddc07eb0dc732971652f9910df85268ea /abs/core/LinHES-config
parentff296c28a08ebd2922eb71278372159b6b75dd1b (diff)
downloadlinhes_pkgbuild-83ccffcdbdebaf747577922ea38ac1cfb0e70fc8.zip
linhes_pkgbuild-83ccffcdbdebaf747577922ea38ac1cfb0e70fc8.tar.gz
linhes_pkgbuild-83ccffcdbdebaf747577922ea38ac1cfb0e70fc8.tar.bz2
LinHES-config: autocard.py: change dvb-fe-tool cmd line for new version.
cleanup help a bit
Diffstat (limited to 'abs/core/LinHES-config')
-rwxr-xr-xabs/core/LinHES-config/PKGBUILD4
-rwxr-xr-xabs/core/LinHES-config/autocard.py37
2 files changed, 23 insertions, 18 deletions
diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index fb88b0a..64ee3b3 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=8.3
-pkgrel=20
+pkgrel=21
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
pkgdesc="Install and configure your system"
depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -157,7 +157,7 @@ md5sums=('17d9dd5a097fbbd4dae75dff8e2677ff'
'ab2aa42c2947148c2b1cac0ade6d1d55'
'd429b59d3cfb37b0624c6a4a71a7c2c0'
'f6a935c35123fdc7c259c01cbc794a64'
- 'b3ce302473883ca118d4a58f1b1306e2'
+ 'ccf7b6a8d0ccf2360a57384b45437e58'
'd3490e93f313bbbcbc6c3693c56b9c17'
'e959df98947eb0d2ea64ff616b61aab5'
'2506860a416e1988934225d80d501c2c'
diff --git a/abs/core/LinHES-config/autocard.py b/abs/core/LinHES-config/autocard.py
index 19563a4..cb0a746 100755
--- a/abs/core/LinHES-config/autocard.py
+++ b/abs/core/LinHES-config/autocard.py
@@ -399,11 +399,12 @@ class dvb_tuners():
#self.staticdevice is set in create_udev_rule
def find_description(self):
- command = '/usr/bin/dvb-fe-tool -g -a %s' %self.dvb_number
+ command = '/usr/bin/dvb-fe-tool -a %s' %self.dvb_number
results=os.popen(command,'r')
line = results.readline().strip()
- d = line.split('''(''')
- return d[0]
+ d = line.split('''Frontend (''')
+ dd = d[0].split('''Device ''')
+ return dd[1]
def find_full_udev_attribs(self):
cmd = 'udevadm info -a -p $(udevadm info -q path -n %s)' %self.device
@@ -974,19 +975,23 @@ def find_in_use_card_list():
def usuage():
help='''
- Autocard.py is a program that will take the guess work out of setting up tuner/capture cards.
- There are 4 options:
- help : This help screen
- print: Will find and printout any detected capture cards, including network based tuners like the hdhomerun_config
- udev : This option creates a set of static device nodes for the local capture cards.
- Rules are based on pci/usb path so moving the card into a different expansion slot will nullify the udev rule
- HDPVR devices use the serial number as the primary key for the udev rule_list
-
- insertdb : This option will insert any detected cards into the MythTV database using the static device generated by udev.
- This option will also generate udev rules. Tuners that are already defined will not be readded.
-
- write_proxy: This will write out the config used by the service ceton_proxy
- all : The same as using print udev insertdb write_proxy
+ autocard.py takes the guess work out of setting up tuner/capture cards.
+
+ Options:
+ help: This help screen.
+ print: Find and printout any detected capture cards, including
+ network based tuners like the HDHomeRun.
+ udev: Creates a set of static device nodes for local capture cards.
+ Rules are based on pci/usb path so moving the card into a
+ different expansion slot will nullify the udev rule.
+ HDPVR devices use the serial number as the primary key for
+ the udev rule list.
+ insertdb: Insert any detected cards into the MythTV database using the
+ static device generated by udev.
+ insertdb will also generate udev rules. Tuners that are
+ already defined will not be readded.
+ write_proxy: Write out the config used by the service ceton_proxy.
+ all: The same as using: print udev insertdb write_proxy
EX: