summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-config
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-01-05 21:34:14 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-01-05 21:34:14 (GMT)
commitb41855ed0f9cd489fe3d9af1acd6e6b2fd80e922 (patch)
treec789fa79e1eac363e8f5e25491e4f3603c37ed47 /abs/core/LinHES-config
parentdf4d86040c76eabf0a13048079c621ac84963728 (diff)
downloadlinhes_pkgbuild-b41855ed0f9cd489fe3d9af1acd6e6b2fd80e922.zip
linhes_pkgbuild-b41855ed0f9cd489fe3d9af1acd6e6b2fd80e922.tar.gz
linhes_pkgbuild-b41855ed0f9cd489fe3d9af1acd6e6b2fd80e922.tar.bz2
LinHES-config:add call to sfdisk to set the active partition
refs #952
Diffstat (limited to 'abs/core/LinHES-config')
-rwxr-xr-xabs/core/LinHES-config/PKGBUILD4
-rwxr-xr-xabs/core/LinHES-config/mv_install.py9
2 files changed, 11 insertions, 2 deletions
diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index 5ca210b..a47d7ea 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=8.1
-pkgrel=9
+pkgrel=11
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
pkgdesc="Install and configure your system"
depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -133,7 +133,7 @@ package() {
install -o root -g root -D -m 0755 blacklist_nouveau.conf $pkgdir/etc/modprobe.d/blacklist_nouveau.conf
}
-md5sums=('8ee14247b04ab4152d4919d4d4b8d869'
+md5sums=('e4faaa3d5f180d796e200b701048b008'
'3f6855b7bb860a44f96a972c2e80f497'
'f6e9dd7bc6cf0aaa3bd203dab4cb79b9'
'2596460462cf6c889cf8f95485537b20'
diff --git a/abs/core/LinHES-config/mv_install.py b/abs/core/LinHES-config/mv_install.py
index ba88ade..fe4a395 100755
--- a/abs/core/LinHES-config/mv_install.py
+++ b/abs/core/LinHES-config/mv_install.py
@@ -506,6 +506,15 @@ def partition_disk():
else:
create_partitions_gpt(datadisk, start_sector, hostoptions["datasize"], "primary")
+ #set active
+ logging.debug("setting active partition for mbr")
+
+ cmd = "parted %s set 1 boot on" %rootdisk
+ runcmd(cmd)
+
+ cmd = "sfdisk --force -A1 %s" %rootdisk
+ runcmd(cmd)
+
logging.debug("sleeping for 5 seconds")
time.sleep(5)