summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-config
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-12 18:55:08 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-12 18:55:08 (GMT)
commitc06b231cb8d754b8b39efc26f15226fc57e70e54 (patch)
tree6293f5f95971f3d0cb2ec2dd1ac92fbe86d9efef /abs/core/LinHES-config
parentb93628bae449bd9c92aa465b9fb4e13405ae2c19 (diff)
downloadlinhes_pkgbuild-c06b231cb8d754b8b39efc26f15226fc57e70e54.zip
linhes_pkgbuild-c06b231cb8d754b8b39efc26f15226fc57e70e54.tar.gz
linhes_pkgbuild-c06b231cb8d754b8b39efc26f15226fc57e70e54.tar.bz2
LinHES-config: mv_network.py: add network fixed name link
mv_install.py: remove devpts and shm from fstab
Diffstat (limited to 'abs/core/LinHES-config')
-rwxr-xr-xabs/core/LinHES-config/PKGBUILD8
-rwxr-xr-xabs/core/LinHES-config/mv_fileshare.py4
-rwxr-xr-xabs/core/LinHES-config/mv_install.py16
-rwxr-xr-xabs/core/LinHES-config/mv_network.py8
4 files changed, 14 insertions, 22 deletions
diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index 3c3c06f..23d3057 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=8.1
-pkgrel=16
+pkgrel=17
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
pkgdesc="Install and configure your system"
depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -133,7 +133,7 @@ package() {
install -o root -g root -D -m 0755 blacklist_nouveau.conf $pkgdir/etc/modprobe.d/blacklist_nouveau.conf
}
-md5sums=('e4faaa3d5f180d796e200b701048b008'
+md5sums=('63f1a1f3725f28b1c07875f4f43bdd6a'
'3f6855b7bb860a44f96a972c2e80f497'
'f6e9dd7bc6cf0aaa3bd203dab4cb79b9'
'2596460462cf6c889cf8f95485537b20'
@@ -161,7 +161,7 @@ md5sums=('e4faaa3d5f180d796e200b701048b008'
'b845de3e05c1734cce4b9ac5e8f1baaf'
'6356c271bf6639002d4c59406250a1f6'
'8b7dce4a3a0a281fa6656aa8781a648e'
- 'f7f2dc11d1ba454cd25eeaa133104b62'
+ '8903d2e17a6955ba59e6f17a65bfc082'
'824e49d9b01fed295c704ab68908b464'
'fe5e31b833cc6707209e9d656b6eb53c'
'71b4860bbc8b7d94311acee7efa7269c'
@@ -169,7 +169,7 @@ md5sums=('e4faaa3d5f180d796e200b701048b008'
'38665330aeb3a8bdf7be24857fe035bb'
'80685e047993b00161be29e3580f3a40'
'299c24c0820fc9c483c820db2595e3cb'
- 'cf51cb22e23218ae7e9b55cac1ba3a7f'
+ '73ed13881c748375296454746c865cd2'
'781f161a79c3188a31c8615b8258b241'
'18370d92ba6b467bcc4996c377e1fa1f'
'2596460462cf6c889cf8f95485537b20'
diff --git a/abs/core/LinHES-config/mv_fileshare.py b/abs/core/LinHES-config/mv_fileshare.py
index 746dbbf..14ce26b 100755
--- a/abs/core/LinHES-config/mv_fileshare.py
+++ b/abs/core/LinHES-config/mv_fileshare.py
@@ -196,11 +196,11 @@ def setup_samba(systemconfig,data_config):
outline = line
if re.match("^.*workgroup", line):
logging.debug(" Setting workgroup to %s",domain)
- outline="workgroup = %s\n" %domain
+ outline=" workgroup = %s\n" %domain
logging.debug(" %s",outline)
if re.match("^.* server string",line):
logging.debug(" Setting server name to %s",servername)
- outline="server string = %s\n" %servername
+ outline=" server string = %s\n" %servername
logging.debug(" %s",outline)
f.write(outline)
diff --git a/abs/core/LinHES-config/mv_install.py b/abs/core/LinHES-config/mv_install.py
index fe4a395..4abdaa7 100755
--- a/abs/core/LinHES-config/mv_install.py
+++ b/abs/core/LinHES-config/mv_install.py
@@ -946,10 +946,6 @@ def create_fstab(extralines):
f = open(fstabfile, 'w')
line = '''# <file system> <dir> <type> <options> <dump> <pass> \n'''
fstab_list.append(line)
- line = '''devpts /dev/pts devpts defaults 0 0 \n'''
- fstab_list.append(line)
- line = '''shm /dev/shm tmpfs nodev,nosuid 0 0 \n'''
- fstab_list.append(line)
line = '''/dev/sr0 /media/cdrom auto ro,user,noauto,unhide 0 0\n'''
fstab_list.append(line)
line = '''UUID=ROOTUID / %s defaults,noatime 0 1\n''' %(hostoptions["rootfs"])
@@ -1162,18 +1158,6 @@ def fstab_it(install_type):
newfstab.append(line)
- elif line.startswith("none"):
- templine = line.split()
- if ( templine[1] == "/dev/pts" ):
- newline = '''devpts /dev/pts devpts defaults 0 0 \n'''
- logging.debug(" New fstab line (converted):")
- logging.debug( newline)
- newfstab.append(newline)
- if ( templine[1] == "/dev/shm" ):
- newline = '''shm /dev/shm tmpfs nodev,nosuid 0 0 \n'''
- logging.debug(" New fstab line(converted):")
- logging.debug( newline)
- newfstab.append(newline)
else:
logging.debug(" Line didn't match, adding to newfstab:")
logging.debug( line)
diff --git a/abs/core/LinHES-config/mv_network.py b/abs/core/LinHES-config/mv_network.py
index f011970..cf01c31 100755
--- a/abs/core/LinHES-config/mv_network.py
+++ b/abs/core/LinHES-config/mv_network.py
@@ -385,6 +385,14 @@ def devcheck(netdev):
return False
def udev_rules(netdev):
+ logging.info(" Disable network fixed name assignment")
+ mv_common.remove_file("/etc/udev/rules.d/80-net-setup-link.rules") #systemd v209+
+ mv_common.remove_file("/etc/udev/rules.d/80-net-name-slot.rules") #systemd v197-v208
+ cmd = "ln -s /dev/null /etc/udev/rules.d/80-net-setup-link.rules"
+ mv_common.runcmd(cmd)
+ cmd = "ln -s /dev/null /etc/udev/rules.d/80-net-name-slot.rules"
+ mv_common.runcmd(cmd)
+
filename = "/etc/udev/rules.d/net.rules"
if devcheck(netdev):
logging.info(" Finding macaddress for %s",netdev)