summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-config
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-11-28 22:45:34 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-11-28 22:49:21 (GMT)
commitd438d076a7bf6b55097942b45f0fe2466e0cfef7 (patch)
tree0019d093881cbb689d4e1b9538ff61d319295a52 /abs/core/LinHES-config
parent55e4254a334f68d02416baa99285d7afe5bba209 (diff)
downloadlinhes_pkgbuild-d438d076a7bf6b55097942b45f0fe2466e0cfef7.zip
linhes_pkgbuild-d438d076a7bf6b55097942b45f0fe2466e0cfef7.tar.gz
linhes_pkgbuild-d438d076a7bf6b55097942b45f0fe2466e0cfef7.tar.bz2
LinHES-config: add systemd-coredump.conf to disable coredumps
xconfig.sh: make sure Xres is set
Diffstat (limited to 'abs/core/LinHES-config')
-rwxr-xr-xabs/core/LinHES-config/PKGBUILD9
-rwxr-xr-xabs/core/LinHES-config/systemd-coredump.conf2
-rwxr-xr-xabs/core/LinHES-config/xconfig.sh71
3 files changed, 53 insertions, 29 deletions
diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index eea1dfa..a3096f0 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=8.4.2
-pkgrel=2
+pkgrel=3
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
pkgdesc="Install and configure your system"
depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -48,6 +48,7 @@ source=(mv_install.py 09_mythvantge_runit_grub
mv_fileshare.py
mv_locale.py
systemconfig.py
+ systemd-coredump.conf
pinkNoise_3s.wav
myth_user_call.py
mythvantage.cfg
@@ -132,6 +133,9 @@ package() {
#sysctrl conf
install -o root -g root -D -m 0755 hdhr.conf $pkgdir/etc/sysctl.d/hdhr.conf
+ #systemd conf
+ install -o root -g root -D -m 0755 systemd-coredump.conf $pkgdir/etc/systemd/coredump.conf.d/coredump.conf
+
#modules blacklist files
install -o root -g root -D -m 0755 blacklist_pcspkr.conf $pkgdir/etc/modprobe.d/blacklist_pcspkr.conf
install -o root -g root -D -m 0755 blacklist_nouveau.conf $pkgdir/etc/modprobe.d/blacklist_nouveau.conf
@@ -148,7 +152,7 @@ md5sums=('97b810ddc35d1f441dbe8cdd6886e2af'
'27e4fcacca9b9662dd782fbdc92fceea'
'2a7f3b34e522acfd08283b86c8926aba'
'b596d2e3779a434435bc0f0277b1ba3e'
- 'a751a88268029989f0067e2c9e75bf6e'
+ 'fe80b54657f456e5f3d55f4bd5f5f768'
'f0376c98a7986897406d393186c0365e'
'157e73d0f90d7b306aba8f5921aeedd3'
'1f58c0393a131f4a8f9a84b3fe08a7e4'
@@ -177,6 +181,7 @@ md5sums=('97b810ddc35d1f441dbe8cdd6886e2af'
'3cb673adb83b6afa52cffaa621b9d96b'
'781f161a79c3188a31c8615b8258b241'
'888a6c57f272d9fa3e77e216a421562b'
+ '6cb0aac63623a44463c4209862d2baa0'
'cdd5008ee77e67c1d51ad73a24612485'
'2596460462cf6c889cf8f95485537b20'
'dc3c5270691a62600475705f4cb78b56'
diff --git a/abs/core/LinHES-config/systemd-coredump.conf b/abs/core/LinHES-config/systemd-coredump.conf
new file mode 100755
index 0000000..519f838
--- /dev/null
+++ b/abs/core/LinHES-config/systemd-coredump.conf
@@ -0,0 +1,2 @@
+[Coredump]
+Storage=none
diff --git a/abs/core/LinHES-config/xconfig.sh b/abs/core/LinHES-config/xconfig.sh
index b5693b9..3f0a0d2 100755
--- a/abs/core/LinHES-config/xconfig.sh
+++ b/abs/core/LinHES-config/xconfig.sh
@@ -1,7 +1,13 @@
#!/bin/bash
#set -x
#SET DISPLAYRES to force Xres, ENV takes precendent over cmdline
-
+#SET VGACARDTYPE to force card type:
+ #VGACARDTYPE="intel" xconfig.sh
+ #VGACARDTYPE="nvidia" xconfig.sh
+ #VGACARDTYPE="nvidia-340xx" xconfig.sh
+ #VGACARDTYPE="nvidia-304xx" xconfig.sh
+ #VGACARDTYPE="VMware" xconfig.sh
+ #VGACARDTYPE="vesa" xconfig.sh
LOGFILE=/tmp/xconfig.log
for i in ati intel mga savage sis unichrome
@@ -26,11 +32,11 @@ function Xvalues {
VGAFORCED=0
if [ "x$VGACARDTYPE" = "x" ]
then
- CMDLINE=$(cat /proc/cmdline)
+ CMDLINE=$(cat /proc/cmdline)
echo "$CMDLINE" | grep -q forceXvesa
if [ $? = 0 ]
then
- echo "Forcing driver to vesa"
+ echo "Forcing driver to vesa from kernel cmdline"
VGACARDTYPE=vesa
Xcardtype=$VGACARDTYPE
else
@@ -49,7 +55,7 @@ function Xvalues {
}
function presetupX {
- if [ "$XIgnoreConfig" = 1 ]
+ if [ "$XIgnoreConfig" = 1 ]
then
echo "Using User Supplied X"
if [ -f "$MYTHHOME/templates/xorg.user" ]
@@ -226,8 +232,8 @@ function intel_driver_install {
}
function set_res {
- echo " Setting modeline to ${Xres}"
- echo " Setting modeline to ${Xres}" >> $LOGFILE 2>&1
+ echo "Setting resolution to ${Xres}"
+ echo "Setting resolution to ${Xres}" >> $LOGFILE 2>&1
cat > /etc/X11/xorg.conf.d/30-screen.conf <<EOF
Section "Screen"
Identifier "Screen0" #Collapse Monitor and Device section to Screen section
@@ -249,15 +255,12 @@ function setupX {
case $VGACARDTYPE in
nvidia|nvidia-340xx|nvidia-304xx)
nvidia_driver_install
- if [ \"$Xres\" = "Auto" ]
- then
- Xres="nvidia-auto-select"
- fi
-
- if [ ${Xres} != "Auto" ]
+ if [[ $Xres != "Auto" ]]
then
set_res
else
+ echo "Setting resolution to ${Xres}"
+ echo "Setting resolution to ${Xres}" >> $LOGFILE 2>&1
rm -f /etc/X11/xorg.conf.d/30-screen.conf
fi
;;
@@ -270,10 +273,12 @@ function setupX {
echo "#!/bin/bash" > /etc/X11/autostart/vmware.sh
echo "/usr/bin/vmware-user-suid-wrapper" >> /etc/X11/autostart/vmware.sh
chmod 755 /etc/X11/autostart/vmware.sh
- if [ ${Xres} != "Auto" ]
+ if [[ $Xres != "Auto" ]]
then
set_res
else
+ echo "Setting resolution to ${Xres}"
+ echo "Setting resolution to ${Xres}" >> $LOGFILE 2>&1
rm -f /etc/X11/xorg.conf.d/30-screen.conf
fi
;;
@@ -281,25 +286,29 @@ function setupX {
intel)
intel_driver_install
cp $TEMPLATES/xorg/xorg.intel /etc/X11/xorg.conf.d/20-automv.conf
- if [ ${Xres} != "Auto" ]
+ if [[ $Xres != "Auto" ]]
then
set_res
else
+ echo "Setting resolution to ${Xres}"
+ echo "Setting resolution to ${Xres}" >> $LOGFILE 2>&1
rm -f /etc/X11/xorg.conf.d/30-screen.conf
fi
;;
vesa|innotek|*) #leaving this as * and vesa for no real reason other then it's explicit to catch vesa
- if [[ $VGACARDTYPE != "vesa" && $VGACARDTYPE != "innotek" ]]
- then
- echo "Unknown card type, using Vesa."
- fi
- vesa_driver_install
- cp $TEMPLATES/xorg/xorg.vesa /etc/X11/xorg.conf.d/20-automv.conf
- if [ ${Xres} != "Auto" ]
+ if [[ $VGACARDTYPE != "vesa" && $VGACARDTYPE != "innotek" ]]
+ then
+ echo "Unknown card type, using Vesa."
+ fi
+ vesa_driver_install
+ cp $TEMPLATES/xorg/xorg.vesa /etc/X11/xorg.conf.d/20-automv.conf
+ if [[ $Xres != "Auto" ]]
then
set_res
else
+ echo "Setting resolution to ${Xres}"
+ echo "Setting resolution to ${Xres}" >> $LOGFILE 2>&1
rm -f /etc/X11/xorg.conf.d/30-screen.conf
fi
@@ -333,7 +342,7 @@ function pacman_wait {
LINE=`grep -i xorg /etc/mythvantage.cfg|grep -q False`
rc=$?
-if [ $rc = 0 ]
+if [ $rc = 0 ]
then
echo "** xorg configuration disabled in /etc/mythvantage.cfg"
exit 1
@@ -345,16 +354,14 @@ then
exit 1
fi
-
if [ -f /etc/systemconfig ]
then
. /etc/systemconfig
else
- #Xres="800x600"
- Xres="Auto"
- echo " Setting modeline to ${Xres}"
- echo " Setting modeline to ${Xres}" >> $LOGFILE 2>&1
+ echo " systemconfig not found."
+ echo " systemconfig not found." >> $LOGFILE 2>&1
fi
+
CMDLINE=$(cat /proc/cmdline)
echo $CMDLINE | grep -q displayres
if [ $? = 0 ]
@@ -365,10 +372,20 @@ fi
if [ ! x$DSR = x ]
then
Xres=$DSR
+ echo " Setting resolution to ${Xres} from kernel cmdline"
+ echo " Setting resolution to ${Xres} from kernel cmdline" >> $LOGFILE 2>&1
fi
if [ ! x$DISPLAYRES = x ]
then
Xres=$DISPLAYRES
+ echo "Resolution forced to ${Xres}"
+ echo "Resolution forced to ${Xres}" >> $LOGFILE 2>&1
+fi
+if [ x$Xres = x ]
+then
+ Xres="Auto"
+ echo "Resolution not set. Setting to ${Xres}"
+ echo "Resolution not set. Setting to ${Xres}" >> $LOGFILE 2>&1
fi