summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-10-01 15:55:35 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-10-01 15:55:35 (GMT)
commit75e9f21c438349435454c641737877df18a35098 (patch)
tree65bb0d8d09f5d0bac8baf2f8ce555b9062249a61 /abs/core/LinHES-system/PKGBUILD
parent5d454195edb24b42fcf3637b7c50f90aaa1529a5 (diff)
downloadlinhes_pkgbuild-75e9f21c438349435454c641737877df18a35098.zip
linhes_pkgbuild-75e9f21c438349435454c641737877df18a35098.tar.gz
linhes_pkgbuild-75e9f21c438349435454c641737877df18a35098.tar.bz2
LinHES-system: cleaned up install file and moved sudo rules to their own file.
Diffstat (limited to 'abs/core/LinHES-system/PKGBUILD')
-rwxr-xr-xabs/core/LinHES-system/PKGBUILD27
1 files changed, 20 insertions, 7 deletions
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 7c63ce0..8abecab 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,10 +1,10 @@
pkgname=LinHES-system
pkgver=2
-pkgrel=109
+pkgrel=113
arch=('i686' 'x86_64')
MVDIR=$startdir/pkg/usr/LH
BINDIR=$startdir/pkg/usr/bin
-#install=LinHES-system.install
+install=system.install
pkgdesc="scripts and things related to having an automated system"
depends=(linhes-sounds xdotool tilda keylaunch python_aosd 'linhes-scripts>=7-24' 'udisks' 'LinHES-config>=2.3-59' 'sudo' 'python2-dbus' 'unclutter' 'wmctrl' 'archlinux-xdg-menu')
backup=(etc/modprobe.d/alsa-base)
@@ -30,8 +30,12 @@ binfiles="LinHES-start optimize_mythdb.py
misc_upcoming_recordings.pl
misc_which_recorder.pl"
-source=(LinHES-session LinHES-profile.sh $binfiles alsa-base myth_mtc.lr
- diskspace cacheclean.cron readme_is_xml add_storage.readme)
+source=(LinHES-session
+ LinHES-profile.sh $binfiles
+ alsa-base myth_mtc.lr
+ diskspace cacheclean.cron
+ readme_is_xml add_storage.readme
+ system-sudo.rules )
build() {
cd $startdir/src
@@ -42,7 +46,7 @@ build() {
do
item=$i
install -m755 -D $item $MVDIR/bin/$item
- echo $item
+ echo "installing $item to $MVDIR"
done
cd $startdir/bin
@@ -50,7 +54,7 @@ build() {
do
item=$i
install -m755 -D $item $MVDIR/bin/$item
- echo $item
+ echo "bin stuff: $item"
done
install -m644 -D $startdir/src/alsa-base $startdir/pkg/etc/modprobe.d/alsa-base.conf
@@ -62,6 +66,14 @@ build() {
install -m755 -D $startdir/src/diskspace $startdir/pkg/etc/cron.tenminutes/diskspace
mkdir $startdir/pkg/etc/logrotate.d
cp $startdir/myth_mtc.lr $startdir/pkg/etc/logrotate.d
+
+ #sudo rules
+ mkdir -p $startdir/pkg/etc/sudoers.d/
+ chmod 750 $startdir/pkg/etc/sudoers.d/
+ chown -R root:root $startdir/pkg/etc/sudoers.d
+ install -o root -g root -m 0750 $startdir/src/system-sudo.rules $startdir/pkg/etc/sudoers.d/system_sudo
+
+
}
md5sums=('5bd4938cf41b63787aa4cdfd76423e09'
'5881bdb43d578ec3a79d1f77ea58a3db'
@@ -102,4 +114,5 @@ md5sums=('5bd4938cf41b63787aa4cdfd76423e09'
'84492954db16740f949d795b74383189'
'02c810c2f47b7c4495fdacaf54189473'
'1e2ca4dd872a50df6b70528e06df558a'
- 'da432d68962e109e09beb2b71c8c8571')
+ 'da432d68962e109e09beb2b71c8c8571'
+ '366ccb097d1c221389709485c3b2d159')