summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system/firstboot.sh
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 06:13:57 (GMT)
commitb172f79fadb565ecfbcec9508f9377d8618a4f4c (patch)
treebf8823b07e3313c3afa000a9b31e4f9a735cb818 /abs/core/LinHES-system/firstboot.sh
parentf9d54ab7c3853208484e304bc6cf40ab0f79d400 (diff)
parent5e7027c6194237ca1dc5fcbb3648483a970fb500 (diff)
downloadlinhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.zip
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.gz
linhes_pkgbuild-b172f79fadb565ecfbcec9508f9377d8618a4f4c.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core/LinHES-system/firstboot.sh')
-rwxr-xr-xabs/core/LinHES-system/firstboot.sh33
1 files changed, 20 insertions, 13 deletions
diff --git a/abs/core/LinHES-system/firstboot.sh b/abs/core/LinHES-system/firstboot.sh
index 47aa0f9..7e2f603 100755
--- a/abs/core/LinHES-system/firstboot.sh
+++ b/abs/core/LinHES-system/firstboot.sh
@@ -1,22 +1,29 @@
#!/bin/bash
. ~/.configured
ATTEMPT=0
+
function try_smolt {
- ((ATTEMPT=ATTEMPT+1))
- status=$(echo "jump mythsmolt" | telnet localhost 6546 2>&1)
- echo $status|grep -q refused
- status=$?
- if [ $status != 0 ]
- then
- fb_status=0
- echo "FB=NO" > ~/.configured
- fi
- if [ $ATTEMPT = 200 ]
- then
- fb_status=0
- fi
+ ((ATTEMPT=ATTEMPT+1))
+ WID=`xdotool search "mythfrontend" | head -1`
+ xdotool windowfocus $WID
+ status=$?
+ if [ $status = 0 ]
+ then
+ sleep 2
+ xdotool key "ctrl+alt+p"
+ xdotool key "ctrl+alt+p"
+ fb_status=0
+ echo "FB=NO" > ~/.configured
+ fi
+
+ if [ $ATTEMPT = 200 ]
+ then
+ fb_status=0
+ fi
+
}
+
if [ ! -e /tmp/debug ]
then
if [ ! -e /tmp/nomfe ]