summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-09-10 22:52:19 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-09-10 22:52:19 (GMT)
commit15f2d77dce9976b0ae864fdaef9c719c9983f2a0 (patch)
treeb051f442438f1d06b828c48b90afea1827afa50a /abs/core/LinHES-system
parent29864d1a0d4d8981a9f011e8768143daf3e6d72b (diff)
downloadlinhes_pkgbuild-15f2d77dce9976b0ae864fdaef9c719c9983f2a0.zip
linhes_pkgbuild-15f2d77dce9976b0ae864fdaef9c719c9983f2a0.tar.gz
linhes_pkgbuild-15f2d77dce9976b0ae864fdaef9c719c9983f2a0.tar.bz2
Merge remote-tracking branch 'origin/testing' into testing
# By Britney Fransen (16) and others # Via Britney Fransen * origin/testing: (23 commits) LinHES-system: misc_which_recorder.pl: add search for analog mpeg recordings LinHES-system: mythfrontend-start: revert fork of startcmd LinHES-system: misc_status_config.py: add SystemType check and only update db for Standalone and masterbackend LinHES-system: mythfrontend-start: fork start command so that mythfrontend-start will exit. closes #847 mythtv: fixed and cleaned some menus. Closes #846 v4l-dvb: fix conflicting kernel modules. refs #844 mythdb-initial: add MiscStatusScript value to initial db. refs #845. LinHES-system: remove dup .install keylaunch: update .keylaunchrc to run mythtv-setup as user rsyslog: increase log retention to 2 weeks runit-scripts: enable cron logging to syslog premake:initial inclusion. closes #801 libaacs-git:initial inclusion. closes #801 aacskeys:initial inclusion. closes #801 LinHES-system: Add scripts for misc status in MythWeb. closes #845. linhes-scripts: tweak myth2mkv. Update version to 0.25-004 dvb-firmware: add xc5000c firmware. change xc5000 modprobe options. closes #844 v4l-dvb: update to snapshot from 20120828. refs #844 LinHES-system: update myth_status.py to work with tuners in error. closes #843 curlftpfs: Initial Inclusion. ... Conflicts: abs/core/LinHES-config/LinHES-release abs/core/LinHES-config/PKGBUILD abs/core/LinHES-system/PKGBUILD abs/core/LinHES-system/misc_which_recorder.pl abs/core/keylaunch/PKGBUILD abs/core/linhes-scripts/PKGBUILD abs/core/mythdb-initial/PKGBUILD abs/core/mythdb-initial/mc.sql abs/core/mythtv/stable-0.25/mythtv/PKGBUILD abs/core/rsyslog/PKGBUILD abs/core/runit-scripts/PKGBUILD
Diffstat (limited to 'abs/core/LinHES-system')
-rwxr-xr-xabs/core/LinHES-system/misc_which_recorder.pl6
1 files changed, 4 insertions, 2 deletions
diff --git a/abs/core/LinHES-system/misc_which_recorder.pl b/abs/core/LinHES-system/misc_which_recorder.pl
index f8a1022..56d076c 100755
--- a/abs/core/LinHES-system/misc_which_recorder.pl
+++ b/abs/core/LinHES-system/misc_which_recorder.pl
@@ -60,7 +60,8 @@ while (<$fh>)
{
# Myth .24 regex to find start of recording
# if (/^(.*)(?:\d(?: I )?|I.* -) (?:Started|Tuning) recording: (.*): channel (\d+) on cardid (\d+), sourceid (\d+)/)
- if (/^(\d+-\d+-\d+T\d+\:\d+\:\d+)(?:.*) (?:Started|Tuning) recording: (.*): channel (\d+) on cardid (\d+), sourceid (\d+)/)
+# Myth .25 regex to find start of recording for digital and analog MPEG
+ if (/^(\d+-\d+-\d+T\d+\:\d+\:\d+)(?:.*) (?:Started|Tuning) recording: (.*): channel (\d+) on cardid (\d+), sourceid (\d+)/ || /^(\d+-\d+-\d+T\d+\:\d+\:\d+)(?:.*) \(UpdateRecStatus\) Updating status for (.*)() on cardid (\d+) \(Will Record => Recording\)()/)
{
if ($mode eq "--noheader")
{
@@ -75,7 +76,8 @@ while (<$fh>)
$index++;
($time, $title, $chanid, $cardid, $sourceid) = ($1, $2, $3, $4, $5);
- $time = `date -d $time +%a' '%m/%d' '%H:%M' '%p`;
+ $time =~ s/T/ /;
+ $time = `date -d $time +%a' '%m/%d' '%l:%M' '%p`;
chomp ($time);
if (($title =~ /"?(.+)"?:"?(.*)"?/) || ($title =~ /(.+) "(.*)"/))
{