summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-09-26 15:25:36 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-09-26 15:25:36 (GMT)
commit38859c2f1949b928c648f5f4e1ad709e96a7a503 (patch)
tree26b28436a7d6863ad135ba3109fd8f9165a6fea3 /abs/core/LinHES-system
parentf98cf065b38a39d4a0262a74a5715d24ae880c3a (diff)
downloadlinhes_pkgbuild-38859c2f1949b928c648f5f4e1ad709e96a7a503.zip
linhes_pkgbuild-38859c2f1949b928c648f5f4e1ad709e96a7a503.tar.gz
linhes_pkgbuild-38859c2f1949b928c648f5f4e1ad709e96a7a503.tar.bz2
LinHES-system: Change default OSD font to Overlock.
Diffstat (limited to 'abs/core/LinHES-system')
-rwxr-xr-xabs/core/LinHES-system/PKGBUILD10
-rwxr-xr-xabs/core/LinHES-system/install_canter_font.sh23
-rwxr-xr-xabs/core/LinHES-system/msg_daemon.py2
3 files changed, 5 insertions, 30 deletions
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index f47284f..33a47d8 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-system
pkgver=8.0
-pkgrel=22
+pkgrel=23
arch=('i686' 'x86_64')
install=system.install
pkgdesc="Everything that makes LinHES an automated system"
@@ -8,7 +8,7 @@ license=('GPL2')
depends=('linhes-sounds' 'xdotool' 'tilda' 'keylaunch'
'python_aosd' 'udisks' 'LinHES-config>=2.3-59' 'sudo'
'python2-dbus' 'unclutter' 'wmctrl' 'archlinux-xdg-menu'
- 'ethtool' 'gnu-netcat' 'normalize'
+ 'ethtool' 'gnu-netcat' 'normalize' 'ttf-overlock'
'handbrake-cli' 'mkvtoolnix' 'mplayer')
backup=('etc/modprobe.d/alsa-base.conf')
binfiles="LinHES-start optimize_mythdb.py myth_mtc.py myth_mtc.sh
@@ -25,8 +25,7 @@ binfiles="LinHES-start optimize_mythdb.py myth_mtc.py myth_mtc.sh
change_channel.sh change_channel_wrapper.sh stop_xss.sh
be_check.py checkXFSfrag.sh find_orphans.py idle.sh xwin_find.sh
linhes_update.sh linhes_update2.sh myth2mkv myth2mp3 ripD_eject.sh
- mythwelcome-config.py mythwelcome-set-alarm.sh mythwelcome-test-wakeup.sh
- install_canter_font.sh"
+ mythwelcome-config.py mythwelcome-set-alarm.sh mythwelcome-test-wakeup.sh"
source=(LinHES-session LinHES-profile.sh $binfiles
alsa-base diskspace.cron cacheclean.cron xfs_defrag.cron
@@ -102,7 +101,7 @@ md5sums=('5ee78704cab0e88ec58d1aab821fc1aa'
'4a3cd8f9b33b2b86fdba47a8f1fa2859'
'16f079dab35dde6efd55bf6cf4e2fb2f'
'4abc4780fa78ed40c07401b3cd25209b'
- 'e5cdcfe0192670338b01bc48559e7a8d'
+ '78375aead3402bccbfbf26aa11f94ad4'
'ea315f41dcd6c978e546c95fc05546cf'
'ac61cc460d9e97ba1f5ef69e92cdfbe5'
'f3502bb7c665750da0ecdf6918f7c838'
@@ -128,7 +127,6 @@ md5sums=('5ee78704cab0e88ec58d1aab821fc1aa'
'92950f0ffb1faf1ed64c6be2b8fbc3f6'
'95c092f67036a361ef7a57436f44332e'
'410795ef9039e4c6c0484e706ecfd567'
- '2f130013e9d699d93aed4bfa1935a6ee'
'eb879fee9603a05d5420d4ce8ed9e450'
'84492954db16740f949d795b74383189'
'02c810c2f47b7c4495fdacaf54189473'
diff --git a/abs/core/LinHES-system/install_canter_font.sh b/abs/core/LinHES-system/install_canter_font.sh
deleted file mode 100755
index 33cba54..0000000
--- a/abs/core/LinHES-system/install_canter_font.sh
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/bash
-
-if [ -e '/usr/share/fonts/TTF/Canter Bold.otf' ]
-then
- echo "Canter is already installed."
-else
- cd /tmp
- mkdir canter/
- cd ./canter
- echo "Downloading Canter to /tmp/canter ..."
- wget "http://fontfabric.com/downfont/canter.zip"
- echo "Unzipping Canter..."
- unzip -o ./canter.zip
- echo "Copying Canter to fonts..."
- cp Canter*.otf /usr/share/fonts/TTF/
- echo "Updating font cache... "
- fc-cache -f > /dev/null
- mkfontscale /usr/share/fonts/TTF
- mkfontdir /usr/share/fonts/TTF
- echo "Removing /tmp/canter"
- cd /tmp
- rm -r ./canter
-fi
diff --git a/abs/core/LinHES-system/msg_daemon.py b/abs/core/LinHES-system/msg_daemon.py
index 3eb5e33..ba611a3 100755
--- a/abs/core/LinHES-system/msg_daemon.py
+++ b/abs/core/LinHES-system/msg_daemon.py
@@ -72,7 +72,7 @@ class msg_aosd():
osd.set_transparency(aosd.TRANSPARENCY_NONE)
osd.geom_x_offset = 10
- osd.geom_y_offset = 3
+ osd.geom_y_offset = 0
osd.back_color = "white"
osd.back_opacity = 25