summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-11-25 18:39:03 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-11-25 18:39:03 (GMT)
commit4b2977c4685b18bed19cea1070a2ff8deb1a753a (patch)
tree28831b350e877c1f404d75a8c143a33d12db451b /abs/core/LinHES-system
parent620c13ec6d5379ed4aa270f2ced3a19946f4b91c (diff)
downloadlinhes_pkgbuild-4b2977c4685b18bed19cea1070a2ff8deb1a753a.zip
linhes_pkgbuild-4b2977c4685b18bed19cea1070a2ff8deb1a753a.tar.gz
linhes_pkgbuild-4b2977c4685b18bed19cea1070a2ff8deb1a753a.tar.bz2
LinHES-system: gen_game_xml.py & gen_lib_xml.py: add all .conf snippets not just the last
Diffstat (limited to 'abs/core/LinHES-system')
-rwxr-xr-xabs/core/LinHES-system/PKGBUILD6
-rw-r--r--abs/core/LinHES-system/gen_game_xml.py6
-rw-r--r--abs/core/LinHES-system/gen_lib_xml.py6
3 files changed, 11 insertions, 7 deletions
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 1d596b1..79c572e 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-system
pkgver=8.2
-pkgrel=5
+pkgrel=6
arch=('i686' 'x86_64')
install=system.install
pkgdesc="Everything that makes LinHES an automated system"
@@ -104,9 +104,9 @@ md5sums=('a10cb96850951ae835c46f41f92463b2'
'57ec994cc3964a10c00580e89ebcae35'
'1da933fd2f4436c1ecaf3d6d0c7c0d68'
'0c3509b48f11af0dc1bf989721fe9ca7'
- 'ac61cc460d9e97ba1f5ef69e92cdfbe5'
+ '9249313ae171abd5405f60625020da63'
'f3502bb7c665750da0ecdf6918f7c838'
- 'b7febd04f64fe21e8cfbb888219b0b31'
+ 'fd3b08fc13b273f0ee3a5de775d63eb6'
'06a628469051237943b7c874f2e29b8a'
'8fe86aa9109a285aedce3c8658952bbb'
'3300ea8b02e4fb8bd3409df348de6e16'
diff --git a/abs/core/LinHES-system/gen_game_xml.py b/abs/core/LinHES-system/gen_game_xml.py
index e5d9afe..611bed5 100644
--- a/abs/core/LinHES-system/gen_game_xml.py
+++ b/abs/core/LinHES-system/gen_game_xml.py
@@ -24,6 +24,7 @@ class Gen_lib_xml:
def read_snippets(self):
xml_snippets=""
+ lines=[]
try:
os.chdir(self.snippit_dir)
except:
@@ -35,12 +36,13 @@ class Gen_lib_xml:
try:
print " gen_game_xml: reading in %s" %conf_file
f=open(conf_file,'r')
- lines=f.readlines()
+ line=f.readlines()
f.close()
except:
print " gen_game_xml: Couldn't open %s for reading" %conf_file
print " Exiting"
sys.exit(0)
+ lines.extend(line)
if len(file_list) == 0:
print " gen_game_xml: no conf files found"
@@ -114,4 +116,4 @@ def main():
write_xml(new_xml,filename)
if __name__ == "__main__":
- main() \ No newline at end of file
+ main()
diff --git a/abs/core/LinHES-system/gen_lib_xml.py b/abs/core/LinHES-system/gen_lib_xml.py
index 320a84d..1cc4516 100644
--- a/abs/core/LinHES-system/gen_lib_xml.py
+++ b/abs/core/LinHES-system/gen_lib_xml.py
@@ -24,6 +24,7 @@ class Gen_lib_xml:
def read_snippets(self):
xml_snippets=""
+ lines=[]
try:
os.chdir(self.snippit_dir)
except:
@@ -35,12 +36,13 @@ class Gen_lib_xml:
try:
print " gen_lib_xml: reading in %s" %conf_file
f=open(conf_file,'r')
- lines=f.readlines()
+ line=f.readlines()
f.close()
except:
print " gen_lib_xml: Couldn't open %s for reading" %conf_file
print " Exiting"
sys.exit(0)
+ lines.extend(line)
if len(file_list) == 0:
print " gen_lib_xml: no conf files found"
@@ -114,4 +116,4 @@ def main():
write_xml(new_xml,filename)
if __name__ == "__main__":
- main() \ No newline at end of file
+ main()