summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-09-25 00:59:20 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-09-25 00:59:20 (GMT)
commit5b40bd4b5ba9fb5b7b79c4009a245bb2b63d4229 (patch)
tree077da448b27ed73f772b2ba71096887c62089484 /abs/core/LinHES-system
parentb7629260f19f5cc7f40cf1337cbfd268c2fc9a02 (diff)
downloadlinhes_pkgbuild-5b40bd4b5ba9fb5b7b79c4009a245bb2b63d4229.zip
linhes_pkgbuild-5b40bd4b5ba9fb5b7b79c4009a245bb2b63d4229.tar.gz
linhes_pkgbuild-5b40bd4b5ba9fb5b7b79c4009a245bb2b63d4229.tar.bz2
LinHES-system & func: change msg_client.py font to Canter
LinHES-system: install_canter_font.sh: added to install Canter font
Diffstat (limited to 'abs/core/LinHES-system')
-rw-r--r--abs/core/LinHES-system/LinHES-system.install3
-rwxr-xr-xabs/core/LinHES-system/PKGBUILD8
-rwxr-xr-xabs/core/LinHES-system/install_canter_font.sh23
-rwxr-xr-xabs/core/LinHES-system/msg_daemon.py4
4 files changed, 32 insertions, 6 deletions
diff --git a/abs/core/LinHES-system/LinHES-system.install b/abs/core/LinHES-system/LinHES-system.install
index f2185cd..87ee8a9 100644
--- a/abs/core/LinHES-system/LinHES-system.install
+++ b/abs/core/LinHES-system/LinHES-system.install
@@ -1,12 +1,13 @@
## arg 1: the new package version
post_install() {
/usr/LH/bin/misc_status_config.py
+ /usr/LH/bin/install_canter_font.sh
}
## arg 1: the new package version
## arg 2: the old package version
post_upgrade() {
- /usr/LH/bin/misc_status_config.py
+ post_install
}
# vim:set ts=2 sw=2 et:
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 3d52185..92ff85e 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-system
pkgver=8.0
-pkgrel=20
+pkgrel=21
arch=('i686' 'x86_64')
install=system.install
pkgdesc="Everything that makes LinHES an automated system"
@@ -25,7 +25,8 @@ binfiles="LinHES-start optimize_mythdb.py myth_mtc.py myth_mtc.sh
change_channel.sh change_channel_wrapper.sh stop_xss.sh
be_check.py checkXFSfrag.sh find_orphans.py idle.sh xwin_find.sh
linhes_update.sh linhes_update2.sh myth2mkv myth2mp3 ripD_eject.sh
- mythwelcome-config.py mythwelcome-set-alarm.sh mythwelcome-test-wakeup.sh"
+ mythwelcome-config.py mythwelcome-set-alarm.sh mythwelcome-test-wakeup.sh
+ install_canter_font.sh"
source=(LinHES-session LinHES-profile.sh $binfiles
alsa-base diskspace.cron cacheclean.cron xfs_defrag.cron
@@ -101,7 +102,7 @@ md5sums=('5ee78704cab0e88ec58d1aab821fc1aa'
'4a3cd8f9b33b2b86fdba47a8f1fa2859'
'16f079dab35dde6efd55bf6cf4e2fb2f'
'4abc4780fa78ed40c07401b3cd25209b'
- '1d275246216ba1b22d5f09eb1c775a73'
+ 'e5cdcfe0192670338b01bc48559e7a8d'
'ea315f41dcd6c978e546c95fc05546cf'
'ac61cc460d9e97ba1f5ef69e92cdfbe5'
'f3502bb7c665750da0ecdf6918f7c838'
@@ -127,6 +128,7 @@ md5sums=('5ee78704cab0e88ec58d1aab821fc1aa'
'92950f0ffb1faf1ed64c6be2b8fbc3f6'
'95c092f67036a361ef7a57436f44332e'
'410795ef9039e4c6c0484e706ecfd567'
+ '2f130013e9d699d93aed4bfa1935a6ee'
'eb879fee9603a05d5420d4ce8ed9e450'
'84492954db16740f949d795b74383189'
'02c810c2f47b7c4495fdacaf54189473'
diff --git a/abs/core/LinHES-system/install_canter_font.sh b/abs/core/LinHES-system/install_canter_font.sh
new file mode 100755
index 0000000..33cba54
--- /dev/null
+++ b/abs/core/LinHES-system/install_canter_font.sh
@@ -0,0 +1,23 @@
+#!/bin/bash
+
+if [ -e '/usr/share/fonts/TTF/Canter Bold.otf' ]
+then
+ echo "Canter is already installed."
+else
+ cd /tmp
+ mkdir canter/
+ cd ./canter
+ echo "Downloading Canter to /tmp/canter ..."
+ wget "http://fontfabric.com/downfont/canter.zip"
+ echo "Unzipping Canter..."
+ unzip -o ./canter.zip
+ echo "Copying Canter to fonts..."
+ cp Canter*.otf /usr/share/fonts/TTF/
+ echo "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "Removing /tmp/canter"
+ cd /tmp
+ rm -r ./canter
+fi
diff --git a/abs/core/LinHES-system/msg_daemon.py b/abs/core/LinHES-system/msg_daemon.py
index fe47263..3eb5e33 100755
--- a/abs/core/LinHES-system/msg_daemon.py
+++ b/abs/core/LinHES-system/msg_daemon.py
@@ -72,10 +72,10 @@ class msg_aosd():
osd.set_transparency(aosd.TRANSPARENCY_NONE)
osd.geom_x_offset = 10
- osd.geom_y_offset = 0
+ osd.geom_y_offset = 3
osd.back_color = "white"
- osd.back_opacity = 50
+ osd.back_opacity = 25
osd.shadow_color = "black"
osd.shadow_opacity = 127