summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-09-17 18:19:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-09-17 18:19:27 (GMT)
commit68d5862f26515b2ec6b3d41d9ea97953284bf44e (patch)
treeabb767482c41b5d2359ade926aedeb6e2fed140b /abs/core/LinHES-system
parent2c5a67ec9f7176f022449415a48f48d89cf0afad (diff)
downloadlinhes_pkgbuild-68d5862f26515b2ec6b3d41d9ea97953284bf44e.zip
linhes_pkgbuild-68d5862f26515b2ec6b3d41d9ea97953284bf44e.tar.gz
linhes_pkgbuild-68d5862f26515b2ec6b3d41d9ea97953284bf44e.tar.bz2
LinHES-system: msg_daemon.py: fix osd flash to the right before it scrolls into place by moving osd off screen before showing
Diffstat (limited to 'abs/core/LinHES-system')
-rwxr-xr-xabs/core/LinHES-system/PKGBUILD6
-rwxr-xr-xabs/core/LinHES-system/importfiles.sh15
-rwxr-xr-xabs/core/LinHES-system/msg_daemon.py1
3 files changed, 8 insertions, 14 deletions
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index ee79c88..ab8ef52 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-system
pkgver=8.0
-pkgrel=14
+pkgrel=15
arch=('i686' 'x86_64')
install=system.install
pkgdesc="Everything that makes LinHES an automated system"
@@ -88,7 +88,7 @@ md5sums=('8fc4b7c1ddf8f3c4d2266ce55086b4d4'
'962a3e9eaba2d1466251b7ab0956705d'
'1758aed160de64abfafb28a3a8f3390e'
'33fbebbd546672cedd3c5e7350ab414e'
- '6b6e7d34a4bda6d608d150039adefd07'
+ 'ea2eef75dceeea631085928c94e3191a'
'3edef50a49a47694bf8add39cc160add'
'5e17e0786afd891550a660f646076308'
'bc69a520add58ede9b060c73e67ace13'
@@ -101,7 +101,7 @@ md5sums=('8fc4b7c1ddf8f3c4d2266ce55086b4d4'
'4a3cd8f9b33b2b86fdba47a8f1fa2859'
'16f079dab35dde6efd55bf6cf4e2fb2f'
'4abc4780fa78ed40c07401b3cd25209b'
- '645297f5905e87eb99999d5a0f3f069a'
+ 'cf5d14fdb45991d07ab9db7726cf1322'
'ea315f41dcd6c978e546c95fc05546cf'
'ac61cc460d9e97ba1f5ef69e92cdfbe5'
'f3502bb7c665750da0ecdf6918f7c838'
diff --git a/abs/core/LinHES-system/importfiles.sh b/abs/core/LinHES-system/importfiles.sh
index 84f1ab5..61ad324 100755
--- a/abs/core/LinHES-system/importfiles.sh
+++ b/abs/core/LinHES-system/importfiles.sh
@@ -1,18 +1,11 @@
#!/bin/bash
-export FONT="-adobe-helvetica-bold-*-*-*-34-*-*-*-*-*-*-*"
DVD_or_CD=`cat /proc/mounts |grep iso9660|awk '{print $2}'|tail -1`
if [ "$DVD_or_CD" != "" ]; then
- echo "Copying files from $DVD_or_CD to /myth/video." > /tmp/screens
- echo "This could take several minutes, depending on the" >> /tmp/screens
- echo "speed and size of your optical media." >> /tmp/screens
- cat /tmp/screens | osd_cat --font=$FONT --shadow=3 --pos=middle --align=centre --color=yellow --delay=0 &
+ msg_client.py --msg "Copying files from $DVD_or_CD to /myth/video. Please wait..." --timeout 900
/bin/cp -R $DVD_or_CD/* /myth/video/
- killall osd_cat
- echo "Copied videos from $DVD_or_CD to /myth/video" > /tmp/screens
- cat /tmp/screens | osd_cat --font=$FONT --shadow=3 --pos=middle --align=centre --color=yellow --delay=2 &
+ msg_client.py --kill
+ msg_client.py --msg "Copied videos from $DVD_or_CD to /myth/video"
else
- echo "No optical media found. If you just inserted" > /tmp/screens
- echo "your media, please wait a moment and try again." >> /tmp/screens
- cat /tmp/screens | osd_cat --font=$FONT --shadow=3 --pos=middle --align=centre --color=yellow --delay=5 &
+ msg_client.py --msg "No optical media found. If you just inserted media please wait a moment and try again.|middle"
fi
diff --git a/abs/core/LinHES-system/msg_daemon.py b/abs/core/LinHES-system/msg_daemon.py
index cd0465b..4c37171 100755
--- a/abs/core/LinHES-system/msg_daemon.py
+++ b/abs/core/LinHES-system/msg_daemon.py
@@ -24,6 +24,7 @@ class msg_aosd():
osd.set_position(pos, width, height)
(x, y, _, _) = osd.get_geometry()
osd.set_position_offset(width, height)
+ osd.set_geometry(2000, y, width, height)
osd.show()
x -= 1