summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-01-22 22:06:28 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-01-22 22:06:28 (GMT)
commit8f9b5c2f840849607e2a737f84c9cbad66286338 (patch)
treef7d91e1047adc647deb8540b47f0d886f2c025aa /abs/core/LinHES-system
parent28f520da7edd5e40c254c8db73a8ffe7accfda05 (diff)
downloadlinhes_pkgbuild-8f9b5c2f840849607e2a737f84c9cbad66286338.zip
linhes_pkgbuild-8f9b5c2f840849607e2a737f84c9cbad66286338.tar.gz
linhes_pkgbuild-8f9b5c2f840849607e2a737f84c9cbad66286338.tar.bz2
LinHES-system: system.install pre_upgrade stop msg_daemon so it doesn't hang around
add_storage.py: add to help msg
Diffstat (limited to 'abs/core/LinHES-system')
-rwxr-xr-xabs/core/LinHES-system/PKGBUILD6
-rwxr-xr-xabs/core/LinHES-system/add_storage.py4
-rw-r--r--abs/core/LinHES-system/add_storage.readme2
-rw-r--r--abs/core/LinHES-system/system.install3
4 files changed, 9 insertions, 6 deletions
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 94b1604..1edffb8 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-system
pkgver=8.1
-pkgrel=12
+pkgrel=13
arch=('i686' 'x86_64')
install=system.install
pkgdesc="Everything that makes LinHES an automated system"
@@ -95,7 +95,7 @@ md5sums=('7ab2a2c643d2b286811d8303d08982ad'
'bc69a520add58ede9b060c73e67ace13'
'2e5e1b3187f75154366bffe806ff8ae9'
'47e093e8cfe4b5b96602358e1f540832'
- '4d6a6e88b519caf917ebe6c85c32c45b'
+ '63bbc62240f46a9997eaae4a84b09b76'
'2c005d95312018bef80092136f80f254'
'6519d209e151cdc39ae7e1091d189c3e'
'ca63946920ba33de1f15abda83e74e40'
@@ -133,6 +133,6 @@ md5sums=('7ab2a2c643d2b286811d8303d08982ad'
'474d5c6883fcfffae4f199aceb3b1356'
'36bdfa8d877cea20ca3870faf08e08d5'
'59d0602bac7e06f11abba1894acc8bb0'
- 'da432d68962e109e09beb2b71c8c8571'
+ 'b12bbf3e028f51b08acef2799a5708bc'
'366ccb097d1c221389709485c3b2d159'
'bdd37627c9effd745a051fd2d279975b')
diff --git a/abs/core/LinHES-system/add_storage.py b/abs/core/LinHES-system/add_storage.py
index 61ce0ea..2518927 100755
--- a/abs/core/LinHES-system/add_storage.py
+++ b/abs/core/LinHES-system/add_storage.py
@@ -960,7 +960,9 @@ def usage():
--new_init: Erase the list of known disks and rescan.
--no_destruction: Will not partition or format the disk.
All other normal operations will be performed.
- Can be used to import disks from other systems.
+ Can be used to import disks from other systems
+ however, add_storage.py only works with the first
+ partition on a disk and ignores all others.
--no_mount: Do not mount the disk.
All other normal operations will be performed.
--reconstruct: Recreate mount point, /myth symlink, fstab entry,
diff --git a/abs/core/LinHES-system/add_storage.readme b/abs/core/LinHES-system/add_storage.readme
index 226b14d..d4435d5 100644
--- a/abs/core/LinHES-system/add_storage.readme
+++ b/abs/core/LinHES-system/add_storage.readme
@@ -1,3 +1,3 @@
Files here are autogenerated by add_storage.py.
-They will be used by systemconfig to generate nfs,smb and mountpoint recovery.
+They will be used by systemconfig to generate nfs, smb and mountpoint recovery.
diff --git a/abs/core/LinHES-system/system.install b/abs/core/LinHES-system/system.install
index 880ea02..9f8aa45 100644
--- a/abs/core/LinHES-system/system.install
+++ b/abs/core/LinHES-system/system.install
@@ -19,7 +19,8 @@ post_install() {
# arg 1: the new package version
# arg 2: the old package version
pre_upgrade() {
- /bin/true
+ msg_client.py --kill
+ sv stop msg_daemon
}
# arg 1: the new package version