summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-11-27 19:20:19 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-11-27 19:20:19 (GMT)
commitcbcd770129c3f298c07515e504dafc6c766429c5 (patch)
tree4bd6efbf12878dbe8a386b0aec0039b89e3ea38d /abs/core/LinHES-system
parent214fa024f53003b4ce5aa0a7888f12f80684703f (diff)
downloadlinhes_pkgbuild-cbcd770129c3f298c07515e504dafc6c766429c5.zip
linhes_pkgbuild-cbcd770129c3f298c07515e504dafc6c766429c5.tar.gz
linhes_pkgbuild-cbcd770129c3f298c07515e504dafc6c766429c5.tar.bz2
LinHES-system: mythvidexport.py to create subdirs for Television, Movies and Videos.
without the leading / these end up as videoTelevision, videoMovies, etc, since the default LH dirs are in media/video
Diffstat (limited to 'abs/core/LinHES-system')
-rwxr-xr-xabs/core/LinHES-system/PKGBUILD4
-rwxr-xr-xabs/core/LinHES-system/mythvidexport.py20
2 files changed, 12 insertions, 12 deletions
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index e8f220d..18f1559 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-system
pkgver=8.3
-pkgrel=20
+pkgrel=21
arch=('i686' 'x86_64')
install=system.install
pkgdesc="Everything that makes LinHES an automated system"
@@ -105,7 +105,7 @@ md5sums=('76842f8cff548d2c1289e0992a8b84dd'
'84c0ea62550b0bf9d84ab48eddc08276'
'3e60b17892e5b8214d47dcfddf5215a4'
'57ec994cc3964a10c00580e89ebcae35'
- '1da933fd2f4436c1ecaf3d6d0c7c0d68'
+ '00330dab3979f34b07b23b20ea06d37e'
'0c3509b48f11af0dc1bf989721fe9ca7'
'9249313ae171abd5405f60625020da63'
'f3502bb7c665750da0ecdf6918f7c838'
diff --git a/abs/core/LinHES-system/mythvidexport.py b/abs/core/LinHES-system/mythvidexport.py
index 9160f1d..ff2cb35 100755
--- a/abs/core/LinHES-system/mythvidexport.py
+++ b/abs/core/LinHES-system/mythvidexport.py
@@ -97,7 +97,7 @@ class VIDEO:
elif self.db.settings[host]['mythvideo.TVexportfmt']:
self.tfmt = self.db.settings[host]['mythvideo.TVexportfmt']
else:
- self.tfmt = 'Television/%TITLE%/Season %SEASON%/'+\
+ self.tfmt = '/Television/%TITLE%/Season %SEASON%/'+\
'%TITLE% - S%SEASON%E%EPISODEPAD% - %SUBTITLE%'
# Movie Format
@@ -106,7 +106,7 @@ class VIDEO:
elif self.db.settings[host]['mythvideo.MOVIEexportfmt']:
self.mfmt = self.db.settings[host]['mythvideo.MOVIEexportfmt']
else:
- self.mfmt = 'Movies/%TITLE%'
+ self.mfmt = '/Movies/%TITLE%'
# Generic Format
if self.opts.gformat:
@@ -114,7 +114,7 @@ class VIDEO:
elif self.db.settings[host]['mythvideo.GENERICexportfmt']:
self.gfmt = self.db.settings[host]['mythvideo.GENERICexportfmt']
else:
- self.gfmt = 'Videos/%TITLE%'
+ self.gfmt = '/Videos/%TITLE%'
def get_meta(self):
self.vid.hostname = self.db.gethostname()
@@ -230,7 +230,7 @@ class VIDEO:
self.log(MythLog.GENERAL|MythLog.FILE, MythLog.INFO, "Copying myth://%s@%s/%s"\
% (self.rec.storagegroup, self.rec.hostname, self.rec.basename)\
- +" to myth://Videos@%s/%s"\
+ +" to myth://Videos@%s%s"\
% (self.vid.host, self.vid.filename))
srcfp = self.rec.open('r')
dstfp = self.vid.open('w', nooverwrite=True)
@@ -293,9 +293,9 @@ class VIDEO:
def usage_format():
usagestr = """The default strings are:
-Television: Television/%TITLE%/Season %SEASON%/%TITLE% - S%SEASON%E%EPISODEPAD% - %SUBTITLE%
-Movie: Movies/%TITLE%
-Generic: Videos/%TITLE%
+Television: /Television/%TITLE%/Season %SEASON%/%TITLE% - S%SEASON%E%EPISODEPAD% - %SUBTITLE%
+Movie: /Movies/%TITLE%
+Generic: /Videos/%TITLE%
Available strings:
%TITLE%: series title
@@ -324,13 +324,13 @@ def print_format():
host = gethostname()
tfmt = db.settings[host]['mythvideo.TVexportfmt']
if not tfmt:
- tfmt = 'Television/%TITLE%/Season %SEASON%/%TITLE% - S%SEASON%E%EPISODEPAD% - %SUBTITLE%'
+ tfmt = '/Television/%TITLE%/Season %SEASON%/%TITLE% - S%SEASON%E%EPISODEPAD% - %SUBTITLE%'
mfmt = db.settings[host]['mythvideo.MOVIEexportfmt']
if not mfmt:
- mfmt = 'Movies/%TITLE%'
+ mfmt = '/Movies/%TITLE%'
gfmt = db.settings[host]['mythvideo.GENERICexportfmt']
if not gfmt:
- gfmt = 'Videos/%TITLE%'
+ gfmt = '/Videos/%TITLE%'
print "Current output formats:"
print " TV: "+tfmt
print " Movies: "+mfmt