summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-11-24 20:47:59 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-11-24 20:47:59 (GMT)
commitdb7dcf4f7bf11e1923df097711aaf9ad6147077c (patch)
tree455a066175129d6f36cb5cfc4ee56b5a1c54ebbb /abs/core/LinHES-system
parent5097ada4a8f48fcaadf132a1043b7ab74adca0be (diff)
downloadlinhes_pkgbuild-db7dcf4f7bf11e1923df097711aaf9ad6147077c.zip
linhes_pkgbuild-db7dcf4f7bf11e1923df097711aaf9ad6147077c.tar.gz
linhes_pkgbuild-db7dcf4f7bf11e1923df097711aaf9ad6147077c.tar.bz2
LinHES-system: lh_system_backup_job: update sed to only change first match for status description
linhes_update: add some description texts and update some osd msgs
Diffstat (limited to 'abs/core/LinHES-system')
-rwxr-xr-xabs/core/LinHES-system/PKGBUILD8
-rw-r--r--abs/core/LinHES-system/lh_system_backup_job6
-rw-r--r--abs/core/LinHES-system/linhes_update.sh6
-rw-r--r--abs/core/LinHES-system/linhes_update2.sh1
4 files changed, 12 insertions, 9 deletions
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index c55ce7e..f7e3a55 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-system
pkgver=8.1
-pkgrel=2
+pkgrel=3
arch=('i686' 'x86_64')
install=system.install
pkgdesc="Everything that makes LinHES an automated system"
@@ -89,7 +89,7 @@ md5sums=('95720bd676d0b05e89e1f6ae6e0b4e2d'
'33fbebbd546672cedd3c5e7350ab414e'
'c773d8caacba8fbd4968e8afe5137bc6'
'3edef50a49a47694bf8add39cc160add'
- 'e8f178a913862e09dfd422a182f41f9e'
+ '95e586cdbf0bef7ec2d99463b47a9096'
'bc69a520add58ede9b060c73e67ace13'
'26fdd26e945f0c187f9fdcf98a7a5bef'
'47e093e8cfe4b5b96602358e1f540832'
@@ -117,8 +117,8 @@ md5sums=('95720bd676d0b05e89e1f6ae6e0b4e2d'
'34fc1f58ad1eabf4eff4979d420760c0'
'c3ada01d3a739abe3f920b02d4ea3f6e'
'a94fe6d980f4b810f2e2ae5352084b39'
- 'e1011e0df090372cccc03ecf9d6805c7'
- '5727da2f13541b0cde2aea0ab94d4960'
+ '1c71ff372978159f09342b18954500b3'
+ '3fc3d584fadd47f82c5cfe8ac0f4322a'
'503df99218373dfc75e7e7f5e449a44e'
'4a1fda884dcd7d65fb2690fbdbd92a83'
'2b7fe3b57592823a4c7e3ec132dcb7f4'
diff --git a/abs/core/LinHES-system/lh_system_backup_job b/abs/core/LinHES-system/lh_system_backup_job
index c3f4e72..9b878bd 100644
--- a/abs/core/LinHES-system/lh_system_backup_job
+++ b/abs/core/LinHES-system/lh_system_backup_job
@@ -121,9 +121,9 @@ function update_backup_status(){
#if description not in the backup xml file, add it
if [ $rc=0 ]
then
- COMPLETE_MSG="Last backup completed on `date '+%D @ %-I:%M %p'`"
+ COMPLETE_MSG="Last backup completed `date '+%D %-I:%M %p'`"
else
- COMPLETE_MSG="Last backup FAILED on `date '+%D @ %-I:%M %p'`"
+ COMPLETE_MSG="Last backup FAILED `date '+%D %-I:%M %p'`"
fi
xmlfile="/usr/share/mythtv/themes/defaultmenu/mythbackup.xml"
@@ -133,7 +133,7 @@ function update_backup_status(){
if [ $desc_check = 0 ]
then
- sed -i "s_\<description\>.*\<description\>_description\>$COMPLETE_MSG\<\/description_" $xmlfile
+ sed -i "0,/\<description\>.*\<description\>/s//\<description\>$COMPLETE_MSG\<\/description/" $xmlfile
else
sed -i " /NONE/ i\ \<description\>$COMPLETE_MSG\<\/description\>" $xmlfile
fi
diff --git a/abs/core/LinHES-system/linhes_update.sh b/abs/core/LinHES-system/linhes_update.sh
index 87ac8a1..aa80d41 100644
--- a/abs/core/LinHES-system/linhes_update.sh
+++ b/abs/core/LinHES-system/linhes_update.sh
@@ -6,7 +6,7 @@ dsply () {
then
msg_client.py --clear --tag "checkUpdates"
msg_client.py --kill
- msg_client.py --msg "Updates available!\nExit and re-enter Service Menu\nto install the updates.|middle"
+ msg_client.py --msg "Updates available!\nGo to the Service Menu to install the updates.|middle"
exit
else
msg_client.py --msg "Checking for updates...|middle" --timeout 600 --tag "checkUpdates"
@@ -20,7 +20,7 @@ chck () {
then
msg_client.py --clear --tag "checkUpdates"
msg_client.py --kill
- msg_client.py --msg "No updates available.|middle"
+ msg_client.py --msg "No updates available.\nReturning to Main Menu.|middle"
else
mv /usr/share/mythtv/themes/defaultmenu/linhes.xml /tmp/linhes.xml.tmp
sed -e '/\#Check/,/\#Check/d' < /tmp/linhes.xml.tmp > /usr/share/mythtv/themes/defaultmenu/linhes.xml
@@ -30,6 +30,7 @@ chck () {
echo " <button>" >> /tmp/linhes.xml.tmp
echo " <type>UPGRADE</type>" >> /tmp/linhes.xml.tmp
echo " <text>Updates Available</text>" >> /tmp/linhes.xml.tmp
+ echo " <description>Updates for the LinHES system</description>" >> /tmp/linhes.xml.tmp
echo " <action>MENU update2.xml</action>" >> /tmp/linhes.xml.tmp
echo " </button>" >> /tmp/linhes.xml.tmp
echo "<!--#UpdatesAvailable-->" >> /tmp/linhes.xml.tmp
@@ -45,6 +46,7 @@ chck () {
echo " <button>" >> /tmp/update3.xml.tmp
echo " <type>UPGRADE</type>" >> /tmp/update3.xml.tmp
echo " <text>REBOOT REQUIRED</text>" >> /tmp/update3.xml.tmp
+ echo " <description>Some packages require a reboot</description>" >> /tmp/update3.xml.tmp
echo " <action>NONE</action>" >> /tmp/update3.xml.tmp
echo " </button>" >> /tmp/update3.xml.tmp
fi
diff --git a/abs/core/LinHES-system/linhes_update2.sh b/abs/core/LinHES-system/linhes_update2.sh
index fbdd36b..b26e762 100644
--- a/abs/core/LinHES-system/linhes_update2.sh
+++ b/abs/core/LinHES-system/linhes_update2.sh
@@ -28,6 +28,7 @@ then
echo " <button>" >> /tmp/linhes.xml.tmp
echo " <type>UPGRADE</type>" >> /tmp/linhes.xml.tmp
echo " <text>Update LinHES</text>" >> /tmp/linhes.xml.tmp
+ echo " <description>Update the LinHES System</description>" >> /tmp/linhes.xml.tmp
echo " <action>MENU update.xml</action>" >> /tmp/linhes.xml.tmp
echo " </button>" >> /tmp/linhes.xml.tmp
echo "<!--#Check for updates-->" >> /tmp/linhes.xml.tmp