summaryrefslogtreecommitdiffstats
path: root/abs/core/alsa-lib
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2011-02-26 03:24:02 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2011-02-26 03:24:02 (GMT)
commit33a843bf14c52c52663c719a3c83222186f477d3 (patch)
treeb0d28bcabf33165503318e9aade374fcfc46164d /abs/core/alsa-lib
parent07b41fbbe5a9510f0f1b663eb35063cbd65ff8b0 (diff)
downloadlinhes_pkgbuild-33a843bf14c52c52663c719a3c83222186f477d3.zip
linhes_pkgbuild-33a843bf14c52c52663c719a3c83222186f477d3.tar.gz
linhes_pkgbuild-33a843bf14c52c52663c719a3c83222186f477d3.tar.bz2
alsa-lib: upgrade to 1.0.24.1
Diffstat (limited to 'abs/core/alsa-lib')
-rw-r--r--abs/core/alsa-lib/PKGBUILD12
-rw-r--r--abs/core/alsa-lib/__changelog1
2 files changed, 6 insertions, 7 deletions
diff --git a/abs/core/alsa-lib/PKGBUILD b/abs/core/alsa-lib/PKGBUILD
index f3550a9..c0009d0 100644
--- a/abs/core/alsa-lib/PKGBUILD
+++ b/abs/core/alsa-lib/PKGBUILD
@@ -2,23 +2,21 @@
# Maintainer: judd <jvinet@zeroflux.org>
pkgname=alsa-lib
-pkgver=1.0.23
-pkgrel=2
+pkgver=1.0.24.1
+pkgrel=1
pkgdesc="An alternative implementation of Linux sound support"
arch=('i686' 'x86_64')
url="http://www.alsa-project.org"
depends=('glibc')
-optdepends=('python2')
+optdepends=('python2: for python smixer plugin')
makedepends=('python2')
license=('GPL')
options=(!libtool)
source=(ftp://ftp.alsa-project.org/pub/lib/$pkgname-$pkgver.tar.bz2)
-md5sums=('f48b50421d8a69d2d806d9c47e534f0d')
-sha1sums=('8abcd773f1686a182c08fd53f0d7b353cfcf9f56')
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --with-pythonlibs="-lpthread -lm -ldl -lpython2.7" --with-pythonincludes=-I/usr/include/python2.7
+ ./configure --prefix=/usr --with-pythonlibs="-lpthread -lm -ldl -lpython2.6" --with-pythonincludes=-I/usr/include/python2.6
make || return 1
}
@@ -26,4 +24,4 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install || return 1
}
-
+md5sums=('7cc05f25e1d5b65da8fb3fdcd540f226')
diff --git a/abs/core/alsa-lib/__changelog b/abs/core/alsa-lib/__changelog
new file mode 100644
index 0000000..c02f65c
--- /dev/null
+++ b/abs/core/alsa-lib/__changelog
@@ -0,0 +1 @@
+--withpythonlibs="...python2.6..." -mh