summaryrefslogtreecommitdiffstats
path: root/abs/core/alsa-utils/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-21 19:13:29 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-21 19:13:29 (GMT)
commite6a003f00a9e2555f19b30717186d942e6f18056 (patch)
tree864d0ee1f8946a14b94ea41daf68dacef9fb1628 /abs/core/alsa-utils/PKGBUILD
parent70ccf2020802a6fee96815b553aea2ea4f9a99be (diff)
downloadlinhes_pkgbuild-e6a003f00a9e2555f19b30717186d942e6f18056.zip
linhes_pkgbuild-e6a003f00a9e2555f19b30717186d942e6f18056.tar.gz
linhes_pkgbuild-e6a003f00a9e2555f19b30717186d942e6f18056.tar.bz2
alsa-utils: 1.0.25
Diffstat (limited to 'abs/core/alsa-utils/PKGBUILD')
-rw-r--r--abs/core/alsa-utils/PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/abs/core/alsa-utils/PKGBUILD b/abs/core/alsa-utils/PKGBUILD
index 2486b03..918a84d 100644
--- a/abs/core/alsa-utils/PKGBUILD
+++ b/abs/core/alsa-utils/PKGBUILD
@@ -1,28 +1,28 @@
-# $Id$
+# $Id: PKGBUILD 157726 2012-04-29 04:09:24Z allan $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=alsa-utils
-pkgver=1.0.24.2
-pkgrel=1
+pkgver=1.0.25
+pkgrel=3
pkgdesc="An alternative implementation of Linux sound support"
arch=('i686' 'x86_64')
url="http://www.alsa-project.org"
#can not use >=$pkgver due to use of letters in alsa-lib update versioning
-depends=("alsa-lib>1.0.24" 'dialog' 'pciutils' 'ncurses' 'psmisc')
+depends=("alsa-lib>1.0.24" 'dialog' 'pciutils' 'ncurses' 'psmisc' 'libsamplerate')
makedepends=('xmlto' 'docbook-xsl')
license=('GPL')
source=(ftp://ftp.alsa-project.org/pub/utils/$pkgname-${pkgver}.tar.bz2
alsa
- alsaconf.patch
alsa.conf.d
90alsa)
backup=(etc/conf.d/alsa)
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- patch -Np1 -i ../alsaconf.patch
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --disable-alsaconf \
+ --with-udev-rules-dir=/usr/lib/udev/rules.d \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system
make
}
@@ -32,11 +32,11 @@ package() {
install -D -m755 ../alsa ${pkgdir}/etc/rc.d/alsa
install -D -m644 ../alsa.conf.d ${pkgdir}/etc/conf.d/alsa
install -D -m755 ../90alsa ${pkgdir}/etc/pm/sleep.d/90alsa
+
# dir where to save ALSA state
install -d ${pkgdir}/var/lib/alsa
}
-md5sums=('8238cd57cb301d1c36bcf0ecb59ce6b2'
- '3ef812cae83053d01cd560284efad71f'
- '62ebef77d5617d0036012cc541dcf23c'
- '93089f0d8872078939f76dd2acaebc2b'
- '71b67e9578512e071253966f9403e01d')
+md5sums=('f81f9dcb9a014fd32cb3a70066a5b9a9'
+ '2ba1a1cbf653bf1a69f8a720fd6549da'
+ '4c8ae9f976c7df5e271a4cb91ccc7767'
+ '529216f6a46e61a546640e08ea7a0879')