summaryrefslogtreecommitdiffstats
path: root/abs/core/alsa-utils
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/alsa-utils
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/alsa-utils')
-rw-r--r--abs/core/alsa-utils/PKGBUILD20
-rwxr-xr-xabs/core/alsa-utils/alsa28
-rw-r--r--abs/core/alsa-utils/alsa.conf.d11
3 files changed, 40 insertions, 19 deletions
diff --git a/abs/core/alsa-utils/PKGBUILD b/abs/core/alsa-utils/PKGBUILD
index a14e0ad..caa636c 100644
--- a/abs/core/alsa-utils/PKGBUILD
+++ b/abs/core/alsa-utils/PKGBUILD
@@ -1,27 +1,29 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 18682 2008-11-08 16:46:01Z tpowa $
# Maintainer: judd <jvinet@zeroflux.org>
pkgname=alsa-utils
-pkgver=1.0.16
+pkgver=1.0.18
pkgrel=1
pkgdesc="An alternative implementation of Linux sound support"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="http://www.alsa-project.org"
-depends=('alsa-lib>=1.0.16' 'dialog' 'pciutils' 'ncurses')
+#can not use >=$pkgver due to use of letters in alsa-lib update versioning
+depends=("alsa-lib>1.0.17.999" 'dialog' 'pciutils' 'ncurses')
+makedepends=('xmlto' 'docbook-xsl')
license=('GPL')
source=(ftp://ftp.alsa-project.org/pub/utils/$pkgname-${pkgver}.tar.bz2 \
alsa alsaconf.patch alsa.conf.d)
backup=(etc/conf.d/alsa)
-md5sums=('b9f803f45e6988bb27a6bed521a949fc'
- 'cce0969b0203a2bb35540fdf4f7e96ae'
- '538f82650d08e901efea86c5395520df'
- '366d370f874a45e67b63ce4a8b048202')
build() {
cd $startdir/src/$pkgname-${pkgver}
patch -Np1 -i ../alsaconf.patch || return 1
- ./configure --prefix=/usr --with-curses=ncursesw
+ ./configure --prefix=/usr
make || return 1
make DESTDIR=$startdir/pkg install
install -D -m755 ../alsa $startdir/pkg/etc/rc.d/alsa
install -D -m644 ../alsa.conf.d $startdir/pkg/etc/conf.d/alsa
}
+md5sums=('0a6b26d27cc2adfd591d91d8c155fdb7'
+ '9dff78913b13b10e67c4195e90395ed2'
+ '538f82650d08e901efea86c5395520df'
+ '93089f0d8872078939f76dd2acaebc2b')
diff --git a/abs/core/alsa-utils/alsa b/abs/core/alsa-utils/alsa
index 2581a9a..e1d6f28 100755
--- a/abs/core/alsa-utils/alsa
+++ b/abs/core/alsa-utils/alsa
@@ -7,7 +7,7 @@
case "$1" in
start)
stat_busy "Restoring ALSA Levels"
- /usr/sbin/alsactl restore
+ /usr/sbin/alsactl $ALSA_ARGS restore
if [ $? -gt 0 ]; then
stat_fail
else
@@ -17,20 +17,28 @@ case "$1" in
POWERSAVE=${POWERSAVE:-0}
if [ -e /sys/module/snd_ac97_codec/parameters/power_save \
- -a $POWERSAVE -ne 0 ]; then
- echo $POWERSAVE > /sys/module/snd_ac97_codec/parameters/power_save
- echo 1 > /dev/dsp
+ -a $POWERSAVE -ne 0 ]; then
+ echo $POWERSAVE > /sys/module/snd_ac97_codec/parameters/power_save
+ echo 1 > /dev/dsp
fi
if [ -e /sys/module/snd_hda_intel/parameters/power_save \
- -a $POWERSAVE -ne 0 ]; then
- echo $POWERSAVE > /sys/module/snd_hda_intel/parameters/power_save
- echo 1 > /dev/dsp
+ -a $POWERSAVE -ne 0 ]; then
+ echo $POWERSAVE > /sys/module/snd_hda_intel/parameters/power_save
+ echo 1 > /dev/dsp
fi
;;
stop)
- stat_busy "Saving ALSA Levels"
- /usr/sbin/alsactl store
+ SAVE_VOLUME=${SAVE_VOLUME:-yes}
+ if [ "$SAVE_VOLUME" == "yes" ]; then
+ stat_busy "Saving ALSA Levels"
+ /usr/sbin/alsactl $ALSA_ARGS store
+ else
+ stat_busy "Stopping ALSA"
+ fi
+ if [ "$MUTE_VOLUME" == "yes" ]; then
+ /usr/bin/amixer -q set Master 0 mute
+ fi
if [ $? -gt 0 ]; then
stat_fail
else
@@ -44,5 +52,5 @@ case "$1" in
$0 start
;;
*)
- echo "usage: $0 {start|stop|restart}"
+ echo "usage: $0 {start|stop|restart}"
esac
diff --git a/abs/core/alsa-utils/alsa.conf.d b/abs/core/alsa-utils/alsa.conf.d
index 1fa3d38..2c4a92e 100644
--- a/abs/core/alsa-utils/alsa.conf.d
+++ b/abs/core/alsa-utils/alsa.conf.d
@@ -1,4 +1,15 @@
+# Arguments for alsactl
+# example: ALSA_ARGS="--file /var/run/alsa-state"
+ALSA_ARGS=""
+
# Enables powersaving mode for AC97 and hda_intel audio chips.
# Set to 1 to enable powersaving.
# Set to 0 to disable powersaving (default).
POWERSAVE=0
+
+# Whether to save volume levels when stopped ("yes" or "no").
+SAVE_VOLUME="yes"
+
+# Whether to mute the master volume when stopped ("yes" or "no").
+# Useful for bad audio cards which make a noise on system poweroff.
+MUTE_VOLUME="no"