summaryrefslogtreecommitdiffstats
path: root/abs/core/alsa-utils
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/alsa-utils
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/alsa-utils')
-rw-r--r--abs/core/alsa-utils/PKGBUILD20
-rwxr-xr-xabs/core/alsa-utils/alsa4
-rw-r--r--abs/core/alsa-utils/alsaconf.patch15
3 files changed, 26 insertions, 13 deletions
diff --git a/abs/core/alsa-utils/PKGBUILD b/abs/core/alsa-utils/PKGBUILD
index caa636c..2f6e163 100644
--- a/abs/core/alsa-utils/PKGBUILD
+++ b/abs/core/alsa-utils/PKGBUILD
@@ -1,17 +1,19 @@
-# $Id: PKGBUILD 18682 2008-11-08 16:46:01Z tpowa $
+# $Id: PKGBUILD 79271 2010-05-02 14:42:00Z tpowa $
# Maintainer: judd <jvinet@zeroflux.org>
pkgname=alsa-utils
-pkgver=1.0.18
-pkgrel=1
+pkgver=1.0.23
+pkgrel=2
pkgdesc="An alternative implementation of Linux sound support"
arch=('i686' 'x86_64')
url="http://www.alsa-project.org"
#can not use >=$pkgver due to use of letters in alsa-lib update versioning
-depends=("alsa-lib>1.0.17.999" 'dialog' 'pciutils' 'ncurses')
+depends=("alsa-lib>1.0.22.99" 'dialog' 'pciutils' 'ncurses')
makedepends=('xmlto' 'docbook-xsl')
license=('GPL')
-source=(ftp://ftp.alsa-project.org/pub/utils/$pkgname-${pkgver}.tar.bz2 \
- alsa alsaconf.patch alsa.conf.d)
+source=(ftp://ftp.alsa-project.org/pub/utils/$pkgname-${pkgver}.tar.bz2
+ alsa
+ alsaconf.patch
+ alsa.conf.d)
backup=(etc/conf.d/alsa)
build() {
@@ -23,7 +25,7 @@ build() {
install -D -m755 ../alsa $startdir/pkg/etc/rc.d/alsa
install -D -m644 ../alsa.conf.d $startdir/pkg/etc/conf.d/alsa
}
-md5sums=('0a6b26d27cc2adfd591d91d8c155fdb7'
- '9dff78913b13b10e67c4195e90395ed2'
- '538f82650d08e901efea86c5395520df'
+md5sums=('cb0cf46029ac9549cf3a31bff6a4f4e1'
+ '3ef812cae83053d01cd560284efad71f'
+ '62ebef77d5617d0036012cc541dcf23c'
'93089f0d8872078939f76dd2acaebc2b')
diff --git a/abs/core/alsa-utils/alsa b/abs/core/alsa-utils/alsa
index e1d6f28..08f76af 100755
--- a/abs/core/alsa-utils/alsa
+++ b/abs/core/alsa-utils/alsa
@@ -19,13 +19,13 @@ case "$1" in
if [ -e /sys/module/snd_ac97_codec/parameters/power_save \
-a $POWERSAVE -ne 0 ]; then
echo $POWERSAVE > /sys/module/snd_ac97_codec/parameters/power_save
- echo 1 > /dev/dsp
+ [ -c /dev/dsp ] && echo 1 > /dev/dsp
fi
if [ -e /sys/module/snd_hda_intel/parameters/power_save \
-a $POWERSAVE -ne 0 ]; then
echo $POWERSAVE > /sys/module/snd_hda_intel/parameters/power_save
- echo 1 > /dev/dsp
+ [ -c /dev/dsp ] && echo 1 > /dev/dsp
fi
;;
stop)
diff --git a/abs/core/alsa-utils/alsaconf.patch b/abs/core/alsa-utils/alsaconf.patch
index c1d2eb2..ec79fe9 100644
--- a/abs/core/alsa-utils/alsaconf.patch
+++ b/abs/core/alsa-utils/alsaconf.patch
@@ -7,9 +7,9 @@ diff -Naur alsa-utils-1.0.9a-orig/alsaconf/alsaconf.in alsa-utils-1.0.9a/alsacon
distribution="fedora"
+elif test -f /etc/arch-release && grep -q "Arch" /etc/arch-release; then
+ distribution="arch"
+ elif [ -f /etc/slackware-version -o -f /etc/slamd64-version ]; then
+ distribution="slackware"
else
- distribution="unknown"
- fi
@@ -382,6 +384,8 @@
rcalsasound=/etc/rc.d/init.d/alsasound
elif [ -x /etc/init.d/alsa ]; then
@@ -19,3 +19,14 @@ diff -Naur alsa-utils-1.0.9a-orig/alsaconf/alsaconf.in alsa-utils-1.0.9a/alsacon
else
rcalsasound=rcalsasound
fi
+--- alsa-utils-1.0.9a-orig/alsaconf/alsaconf.in 2010-01-03 19:44:08.000000000 +0100
++++ alsa-utils-1.0.9a-orig/alsaconf/alsaconf.in 2010-01-03 19:44:08.000000000 +0100
+@@ -315,7 +315,7 @@
+ 3.[789]*)
+ ;;
+ *)
+- cfgout="/etc/modprobe.d/sound"
++ cfgout="/etc/modprobe.d/sound.conf"
+ cfgoldout=""
+ ;;
+ esac