summaryrefslogtreecommitdiffstats
path: root/abs/core/apache
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-06 22:24:33 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-06 22:24:33 (GMT)
commit401ad9311566b025a4544b4cf1622fdd93e05b9d (patch)
tree2cbf6e1780fe02815b58fdb146d276dbe4385175 /abs/core/apache
parenta9836c708d7c835f1caf63a56c45daef98bdb277 (diff)
downloadlinhes_pkgbuild-401ad9311566b025a4544b4cf1622fdd93e05b9d.zip
linhes_pkgbuild-401ad9311566b025a4544b4cf1622fdd93e05b9d.tar.gz
linhes_pkgbuild-401ad9311566b025a4544b4cf1622fdd93e05b9d.tar.bz2
apache 2.2.22
Diffstat (limited to 'abs/core/apache')
-rw-r--r--abs/core/apache/PKGBUILD51
-rw-r--r--abs/core/apache/__changelog1
-rw-r--r--abs/core/apache/apache.install3
-rw-r--r--abs/core/apache/apache.tmpfiles.conf1
-rw-r--r--abs/core/apache/httpd.logrotate6
-rw-r--r--abs/core/apache/pcre_info.patch22
6 files changed, 59 insertions, 25 deletions
diff --git a/abs/core/apache/PKGBUILD b/abs/core/apache/PKGBUILD
index 4ba626c..fd13bdd 100644
--- a/abs/core/apache/PKGBUILD
+++ b/abs/core/apache/PKGBUILD
@@ -1,11 +1,11 @@
-# $Id: PKGBUILD 96448 2010-10-21 09:16:04Z jgc $
+# $Id: PKGBUILD 161295 2012-06-08 23:50:11Z heftig $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
pkgname=apache
-pkgver=2.2.17
-pkgrel=1
+pkgver=2.2.22
+pkgrel=4
pkgdesc='A high performance Unix-based HTTP server'
arch=('i686' 'x86_64')
options=('!libtool')
@@ -18,8 +18,10 @@ backup=(etc/conf.d/apache etc/httpd/conf/httpd.conf
etc/logrotate.d/httpd)
depends=('openssl' 'zlib' 'apr-util' 'pcre')
optdepends=('lynx: apachectl status')
-_itkurl=http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.11-02
+install=apache.install
+_itkurl=http://mpm-itk.sesse.net/apache2.2-mpm-itk-2.2.17-01
source=(http://www.apache.org/dist/httpd/httpd-${pkgver}.tar.bz2
+ http://www.apache.org/dist/httpd/httpd-${pkgver}.tar.bz2.asc
${_itkurl}/02-rename-prefork-to-itk.patch
${_itkurl}/03-add-mpm-to-build-system.patch
${_itkurl}/04-correct-output-makefile-location.patch
@@ -29,30 +31,38 @@ source=(http://www.apache.org/dist/httpd/httpd-${pkgver}.tar.bz2
${_itkurl}/08-max-clients-per-vhost.patch
${_itkurl}/09-capabilities.patch
${_itkurl}/10-nice.patch
+ ${_itkurl}/11-fix-htaccess-reads-for-persistent-connections.patch
apachectl-confd.patch
apache.conf.d
+ apache.tmpfiles.conf
httpd.logrotate
httpd
- arch.layout)
-md5sums=('16eadc59ea6b38af33874d300973202e'
- 'db42cfcc18ae1c32aaaff2347e35b79d'
- '131408ad4dc7b18547b4e062e7e495ab'
- 'ee488f391054d528547c3a372faa2aa7'
- 'b202944761b2f0516196488b12504236'
- '78fa15f8ca3a284b7d71f942e24e47fb'
- 'd33e39350e987721d50e6fb8e164ab6b'
- '9f7a8935f9cabc7b46d0052906634cef'
- '1b28e3363e1b0d05b738a21e7ddd264f'
- 'd9667fcd2ffecc63e446edd4d6666731'
+ arch.layout
+ pcre_info.patch)
+md5sums=('9fe3093194c8a57f085ff7c3fc43715f'
+ '41b3a6e4948679cab70b9caf490877c4'
+ 'f1d9d41360908ceb2374da55ae99197a'
+ 'cdfa04985a0efa850976aef01c2a0c40'
+ '0930d2d0612eb0a53a0d00aea7e8687f'
+ '3a0c29bb91442c33ea73ebbe072af922'
+ '0ef4729a6f1ffc848ad0e9b440a66f66'
+ '940944caa948340b11ddae56adaef89b'
+ 'ce09a987523884de8838f73dc8ec0d19'
+ 'e75b7dd8d8afcd299ba4ab2ab81c11e4'
+ 'ce1ccc21f3ad8625169c8f62913450ac'
+ '1e5b222edcfbf99a3edc56fcb2074fbe'
'4ac64df6e019edbe137017cba1ff2f51'
'08b3c875f6260644f2f52b4056d656b0'
+ '82068753dab92fe86312b1010a2904d7'
'6382331e9700ed9e8cc78ea51887b537'
'c7e300a287ef7e2e066ac7639536f87e'
- '3d659d41276ba3bfcb20c231eb254e0c')
+ '3d659d41276ba3bfcb20c231eb254e0c'
+ 'fde5121e32b5aeef5a7eedb5a97009ff')
build() {
cd "${srcdir}/httpd-${pkgver}"
+ patch -p1 -i "${srcdir}/pcre_info.patch"
patch -Np0 -i "${srcdir}/apachectl-confd.patch"
# set default user
@@ -64,6 +74,9 @@ build() {
for mpm in prefork worker itk; do
if [ "${mpm}" = "itk" ]; then
+ # Fix patch to apply with latest Apache version
+ sed -i -e 's/mpmt_os2}/mpmt_os2|winnt}/g' "${srcdir}/03-add-mpm-to-build-system.patch"
+
mkdir -p server/mpm/experimental/itk
cp -r server/mpm/prefork/* server/mpm/experimental/itk/
mv server/mpm/experimental/itk/prefork.c server/mpm/experimental/itk/itk.c
@@ -77,6 +90,7 @@ build() {
patch -Np1 -i "${srcdir}/08-max-clients-per-vhost.patch"
patch -Np1 -i "${srcdir}/09-capabilities.patch"
patch -Np1 -i "${srcdir}/10-nice.patch"
+ patch -Np1 -i "${srcdir}/11-fix-htaccess-reads-for-persistent-connections.patch"
autoconf
fi
@@ -103,8 +117,7 @@ build() {
--with-apr-util=/usr/bin/apu-1-config \
--with-pcre=/usr \
--with-mpm=${mpm}
- make || return 1
-
+ make
if [ "${mpm}" = "prefork" ]; then
make DESTDIR="${pkgdir}" install
else
@@ -116,6 +129,7 @@ build() {
install -D -m755 "${srcdir}/httpd" "${pkgdir}/etc/rc.d/httpd"
install -D -m644 "${srcdir}/httpd.logrotate" "${pkgdir}/etc/logrotate.d/httpd"
install -D -m644 "${srcdir}/apache.conf.d" "${pkgdir}/etc/conf.d/apache"
+ install -D -m644 "${srcdir}/apache.tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/apache.conf"
# symlinks for /etc/httpd
ln -fs /var/log/httpd "${pkgdir}/etc/httpd/logs"
@@ -137,4 +151,5 @@ build() {
rm -rf "${pkgdir}/etc/httpd/conf/original"
rm -rf "${pkgdir}/srv/"
rm -rf "${pkgdir}/usr/bin"
+ rm -rf "${pkgdir}/var/run"
}
diff --git a/abs/core/apache/__changelog b/abs/core/apache/__changelog
deleted file mode 100644
index bbcbdac..0000000
--- a/abs/core/apache/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-update to 2.2.17
diff --git a/abs/core/apache/apache.install b/abs/core/apache/apache.install
new file mode 100644
index 0000000..9b74e60
--- /dev/null
+++ b/abs/core/apache/apache.install
@@ -0,0 +1,3 @@
+post_install() {
+ systemd-tmpfiles --create usr/lib/tmpfiles.d/apache.conf
+}
diff --git a/abs/core/apache/apache.tmpfiles.conf b/abs/core/apache/apache.tmpfiles.conf
new file mode 100644
index 0000000..7447752
--- /dev/null
+++ b/abs/core/apache/apache.tmpfiles.conf
@@ -0,0 +1 @@
+d /run/httpd 0755 root root -
diff --git a/abs/core/apache/httpd.logrotate b/abs/core/apache/httpd.logrotate
deleted file mode 100644
index a723d20..0000000
--- a/abs/core/apache/httpd.logrotate
+++ /dev/null
@@ -1,6 +0,0 @@
-/var/log/httpd/*log {
- missingok
- postrotate
- /bin/kill -HUP `cat /var/run/httpd/httpd.pid 2>/dev/null` 2> /dev/null || true
- endscript
-}
diff --git a/abs/core/apache/pcre_info.patch b/abs/core/apache/pcre_info.patch
new file mode 100644
index 0000000..906a315
--- /dev/null
+++ b/abs/core/apache/pcre_info.patch
@@ -0,0 +1,22 @@
+--- httpd-2.2.22/server/util_pcre.c 2005-11-10 16:20:05.000000000 +0100
++++ httpd-2.2.22/server/util_pcre.c 2012-02-08 11:23:56.273855663 +0100
+@@ -128,6 +128,7 @@
+ const char *errorptr;
+ int erroffset;
+ int options = 0;
++int nsub;
+
+ if ((cflags & AP_REG_ICASE) != 0) options |= PCRE_CASELESS;
+ if ((cflags & AP_REG_NEWLINE) != 0) options |= PCRE_MULTILINE;
+@@ -136,8 +137,9 @@
+ preg->re_erroffset = erroffset;
+
+ if (preg->re_pcre == NULL) return AP_REG_INVARG;
+-
+-preg->re_nsub = pcre_info((const pcre *)preg->re_pcre, NULL, NULL);
++pcre_fullinfo((const pcre *)preg->re_pcre, NULL,
++ PCRE_INFO_CAPTURECOUNT, &nsub);
++preg->re_nsub = nsub;
+ return 0;
+ }
+