summaryrefslogtreecommitdiffstats
path: root/abs/core/apr
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-26 16:37:24 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-26 16:37:24 (GMT)
commit8214664932567081a777b202c0ea4a41dd9fd48e (patch)
tree6b8869a8d8299e8dd81a0ae5428ae13b61c9228d /abs/core/apr
parent00b8ce4cf699c6825757c077e2c58469b5b30f8d (diff)
downloadlinhes_pkgbuild-8214664932567081a777b202c0ea4a41dd9fd48e.zip
linhes_pkgbuild-8214664932567081a777b202c0ea4a41dd9fd48e.tar.gz
linhes_pkgbuild-8214664932567081a777b202c0ea4a41dd9fd48e.tar.bz2
apr: update to 1.6.3
Diffstat (limited to 'abs/core/apr')
-rw-r--r--abs/core/apr/PKGBUILD52
-rw-r--r--abs/core/apr/dont_override_external_buildflags21
-rw-r--r--abs/core/apr/fix-apr.pc.patch20
-rw-r--r--abs/core/apr/fix_apr-config.patch33
-rw-r--r--abs/core/apr/omit_extra_libs.patch20
-rw-r--r--abs/core/apr/ship_find_apr.m4.patch25
6 files changed, 158 insertions, 13 deletions
diff --git a/abs/core/apr/PKGBUILD b/abs/core/apr/PKGBUILD
index a1e496a..6a88a5a 100644
--- a/abs/core/apr/PKGBUILD
+++ b/abs/core/apr/PKGBUILD
@@ -1,35 +1,61 @@
-# $Id: PKGBUILD 158966 2012-05-13 20:20:53Z jgc $
+# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
pkgname=apr
-pkgver=1.4.6
+pkgver=1.6.3
pkgrel=1
-pkgdesc="The Apache Portable Runtime"
-arch=('i686' 'x86_64')
-url="http://apr.apache.org/"
+pkgdesc='The Apache Portable Runtime'
+arch=('x86_64')
+url='http://apr.apache.org/'
depends=('util-linux')
-options=('!libtool')
+makedepends=('python2')
license=('APACHE')
-source=(http://www.apache.org/dist/apr/apr-${pkgver}.tar.bz2)
-md5sums=('ffee70a111fd07372982b0550bbb14b7')
+source=(https://www.apache.org/dist/apr/apr-$pkgver.tar.bz2{,.asc}
+ fix_apr-config.patch
+ ship_find_apr.m4.patch
+ fix-apr.pc.patch
+ omit_extra_libs.patch
+ dont_override_external_buildflags)
+sha256sums=('131f06d16d7aabd097fa992a33eec2b6af3962f93e6d570a9bd4d85e95993172'
+ 'SKIP'
+ '91490ffee726f851edad9fc733ac6632aaf434a87920e706eeb132a97ee5f402'
+ '315932ef6536fc0644c1efe770ceb3bb675c3c7103a7cbb2f02efd8be03eb752'
+ '12595d331b48be9e44bd843635eb4f0f500bd213e197a551a9d383a28a24641f'
+ '3d491d3af8fb5a75db4e085a17e5d8dcbe058bd256ef893ee779dc97fc9f8ad6'
+ '5ac0bdc532479f6082d29115ac9d3ca24524fd8b97a556568755b88e5a68e3df')
+validpgpkeys=('5B5181C2C0AB13E59DA3F7A3EC582EB639FF092C' # Jeff Trawick
+ 'B1B96F45DFBDCCF974019235193F180AB55D9977') # Nick Kew <niq@apache.org>
+
+prepare() {
+ cd apr-$pkgver
+ patch -Np1 -i ../fix_apr-config.patch
+ patch -Np1 -i ../ship_find_apr.m4.patch
+ patch -Np1 -i ../fix-apr.pc.patch
+ patch -Np1 -i ../omit_extra_libs.patch
+ patch -Np1 -i ../dont_override_external_buildflags
+ sed -e 's/env python/env python2/' -i build/gen-build.py
+ sed -e 's/python/python2/g' -i build/buildcheck.sh
+ ./buildconf
+}
build() {
- cd "${srcdir}/apr-${pkgver}"
+ cd apr-$pkgver
./configure --prefix=/usr --includedir=/usr/include/apr-1 \
--with-installbuilddir=/usr/share/apr-1/build \
--enable-nonportable-atomics \
- --with-devrandom=/dev/urandom
+ --with-devrandom=/dev/urandom --disable-static
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
check() {
- cd "${srcdir}/apr-${pkgver}"
+ cd apr-$pkgver
make -j1 check
}
package() {
- cd "${srcdir}/apr-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd apr-$pkgver
+ make DESTDIR="$pkgdir" install
}
diff --git a/abs/core/apr/dont_override_external_buildflags b/abs/core/apr/dont_override_external_buildflags
new file mode 100644
index 0000000..db30a81
--- /dev/null
+++ b/abs/core/apr/dont_override_external_buildflags
@@ -0,0 +1,21 @@
+# Don't force apr-using projects to use the compile flags used during
+# apr's compilation.
+Index: apr/build/apr_rules.mk.in
+===================================================================
+--- apr.orig/build/apr_rules.mk.in 2010-04-21 17:20:26.000000000 +0200
++++ apr/build/apr_rules.mk.in 2013-11-01 21:22:19.655108671 +0100
+@@ -41,10 +41,10 @@
+ # compilation and linking flags that are supposed to be set only by the user.
+ # configure adds to them for tests, but we restore them at the end.
+ #
+-CFLAGS=@CFLAGS@
+-CPPFLAGS=@CPPFLAGS@
+-LDFLAGS=@LDFLAGS@
+-LIBS=@LIBS@
++CFLAGS?=@CFLAGS@
++CPPFLAGS?=@CPPFLAGS@
++LDFLAGS?=@LDFLAGS@
++LIBS?=@LIBS@
+ DEFS=@DEFS@
+
+ # anything added to the standard flags by configure is moved to EXTRA_*
diff --git a/abs/core/apr/fix-apr.pc.patch b/abs/core/apr/fix-apr.pc.patch
new file mode 100644
index 0000000..890b514
--- /dev/null
+++ b/abs/core/apr/fix-apr.pc.patch
@@ -0,0 +1,20 @@
+From: <tfheen@debian.org>
+Subject: No description.
+
+---
+ apr.pc.in | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+Index: apr/apr.pc.in
+===================================================================
+--- apr.orig/apr.pc.in
++++ apr/apr.pc.in
+@@ -7,5 +7,6 @@
+ Name: APR
+ Description: The Apache Portable Runtime library
+ Version: @APR_DOTTED_VERSION@
+-Libs: -L${libdir} -l@APR_LIBNAME@ @EXTRA_LIBS@
+-Cflags: @EXTRA_CPPFLAGS@ @EXTRA_CFLAGS@ -I${includedir}
++Libs: -L${libdir} -l@APR_LIBNAME@
++Libs.private: @EXTRA_LIBS@
++Cflags: @EXTRA_CPPFLAGS@ -I${includedir}
diff --git a/abs/core/apr/fix_apr-config.patch b/abs/core/apr/fix_apr-config.patch
new file mode 100644
index 0000000..51b4aa3
--- /dev/null
+++ b/abs/core/apr/fix_apr-config.patch
@@ -0,0 +1,33 @@
+From: <tfheen@debian.org>
+Subject: No description.
+
+---
+ apr-config.in | 8 ++------
+ 1 file changed, 2 insertions(+), 6 deletions(-)
+
+Index: apr/apr-config.in
+===================================================================
+--- apr.orig/apr-config.in
++++ apr/apr-config.in
+@@ -39,7 +39,7 @@
+ LIBS="@EXTRA_LIBS@"
+ EXTRA_INCLUDES="@EXTRA_INCLUDES@"
+ SHLIBPATH_VAR="@shlibpath_var@"
+-APR_SOURCE_DIR="@apr_srcdir@"
++APR_SOURCE_DIR="$(cd @installbuilddir@/.. ; pwd)"
+ APR_BUILD_DIR="@apr_builddir@"
+ APR_SO_EXT="@so_ext@"
+ APR_LIB_TARGET="@export_lib_target@"
+@@ -223,11 +223,7 @@
+ exit 0
+ ;;
+ --apr-libtool)
+- if test "$location" = "installed"; then
+- echo "${installbuilddir}/libtool"
+- else
+- echo "$APR_BUILD_DIR/libtool"
+- fi
++ echo "$installbuilddir/libtool"
+ exit 0
+ ;;
+ --help)
diff --git a/abs/core/apr/omit_extra_libs.patch b/abs/core/apr/omit_extra_libs.patch
new file mode 100644
index 0000000..524602e
--- /dev/null
+++ b/abs/core/apr/omit_extra_libs.patch
@@ -0,0 +1,20 @@
+From: Stefan Fritsch <sf@debian.org>
+Subject: #463399
+
+---
+ apr-config.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: apr/apr-config.in
+===================================================================
+--- apr.orig/apr-config.in
++++ apr/apr-config.in
+@@ -36,7 +36,7 @@
+ CPPFLAGS="@EXTRA_CPPFLAGS@"
+ CFLAGS="@EXTRA_CFLAGS@"
+ LDFLAGS="@EXTRA_LDFLAGS@"
+-LIBS="@EXTRA_LIBS@"
++LIBS=""
+ EXTRA_INCLUDES="@EXTRA_INCLUDES@"
+ SHLIBPATH_VAR="@shlibpath_var@"
+ APR_SOURCE_DIR="$(cd @installbuilddir@/.. ; pwd)"
diff --git a/abs/core/apr/ship_find_apr.m4.patch b/abs/core/apr/ship_find_apr.m4.patch
new file mode 100644
index 0000000..0393970
--- /dev/null
+++ b/abs/core/apr/ship_find_apr.m4.patch
@@ -0,0 +1,25 @@
+From: Tollef Fog Heen <tfheen@err.no>
+Subject: Install a set of random build files too
+
+---
+ Makefile.in | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+--- apr.orig/Makefile.in
++++ apr/Makefile.in
+@@ -92,6 +92,15 @@ install: $(TARGETS)
+ done
+ $(INSTALL_DATA) build/apr_rules.out $(DESTDIR)$(installbuilddir)/apr_rules.mk
+ $(INSTALL) -m 755 apr-config.out $(DESTDIR)$(bindir)/$(APR_CONFIG)
++
++ if [ ! -d $(DESTDIR)$(installbuilddir) ]; then \
++ $(top_srcdir)/build/mkdir.sh $(DESTDIR)$(installbuilddir); \
++ fi
++ for file in find_apr.m4 apr_common.m4 install.sh gen-build.py get-version.sh ; do \
++ $(LIBTOOL) --mode=install cp $(top_srcdir)/build/$$file \
++ $(DESTDIR)$(installbuilddir)/$$file ; \
++ done
++
+ @if [ $(INSTALL_SUBDIRS) != "none" ]; then \
+ for i in $(INSTALL_SUBDIRS); do \
+ ( cd $$i ; $(MAKE) DESTDIR=$(DESTDIR) install ); \