summaryrefslogtreecommitdiffstats
path: root/abs/core/aspell
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/aspell
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/aspell')
-rw-r--r--abs/core/aspell/PKGBUILD24
-rw-r--r--abs/core/aspell/aspell.install8
2 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/aspell/PKGBUILD b/abs/core/aspell/PKGBUILD
new file mode 100644
index 0000000..0b8a590
--- /dev/null
+++ b/abs/core/aspell/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 521 2008-04-20 13:00:37Z andyrtr $
+# Maintainer: dorphell <dorphell@archlinux.org>
+# Contributor: Jochem Kossen <j.kossen@home.nl>
+pkgname=aspell
+pkgver=0.60.6
+_pkgmajorver=0.60
+pkgrel=1
+pkgdesc="A Free and Open Source spell checker designed to eventually replace Ispell"
+arch=(i686 x86_64)
+license=('LGPL')
+depends=('gcc-libs' 'ncurses')
+options=(!libtool)
+source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+install=aspell.install
+url="http://aspell.net/"
+md5sums=('bc80f0198773d5c05086522be67334eb')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+ ln -s ${pkgname}-${_pkgmajorver} ${startdir}/pkg/usr/lib/${pkgname}
+}
diff --git a/abs/core/aspell/aspell.install b/abs/core/aspell/aspell.install
new file mode 100644
index 0000000..b635a4a
--- /dev/null
+++ b/abs/core/aspell/aspell.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo "NOTE: aspell comes with no default dictionary"
+}
+
+op=$1
+shift
+
+[ "$(type -t "$op")" = "function" ] && $op "$@"