summaryrefslogtreecommitdiffstats
path: root/abs/core/audiofile
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/audiofile
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/audiofile')
-rw-r--r--abs/core/audiofile/PKGBUILD21
-rw-r--r--abs/core/audiofile/aclocal-fixes.patch11
2 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/audiofile/PKGBUILD b/abs/core/audiofile/PKGBUILD
new file mode 100644
index 0000000..ca3fd82
--- /dev/null
+++ b/abs/core/audiofile/PKGBUILD
@@ -0,0 +1,21 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: dorphell <dorphell@archlinux.org>
+pkgname=audiofile
+pkgver=0.2.6
+pkgrel=3
+pkgdesc="Silicon Graphics Audio File Library"
+url="http://www.68k.org/~michael/audiofile/"
+arch=('i686')
+depends=(glibc)
+source=( http://altruistic.lbl.gov/mirrors/gnome/platform/2.7/2.7.2/sources/audiofile-0.2.6.tar.gz
+ aclocal-fixes.patch)
+md5sums=(9c1049876cd51c0f1b12c2886cce4d42 a4c04c757d6b0a049c6fce6b64e9a17b)
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ patch -Np0 -i ${startdir}/src/aclocal-fixes.patch || return 1
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ find $startdir/pkg -name '*.la' -exec rm {} \;
+}
diff --git a/abs/core/audiofile/aclocal-fixes.patch b/abs/core/audiofile/aclocal-fixes.patch
new file mode 100644
index 0000000..ef4d258
--- /dev/null
+++ b/abs/core/audiofile/aclocal-fixes.patch
@@ -0,0 +1,11 @@
+--- audiofile.m4.orig 2006-03-05 13:06:01.000000000 +0000
++++ audiofile.m4 2006-03-05 13:06:17.000000000 +0000
+@@ -9,7 +9,7 @@
+ dnl AM_PATH_AUDIOFILE([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
+ dnl Test for Audio File Library, and define AUDIOFILE_CFLAGS and AUDIOFILE_LIBS.
+ dnl
+-AC_DEFUN(AM_PATH_AUDIOFILE,
++AC_DEFUN([AM_PATH_AUDIOFILE],
+ [dnl
+ dnl Get compiler flags and libraries from the audiofile-config script.
+ dnl