summaryrefslogtreecommitdiffstats
path: root/abs/core/aufs2/PKGBUILD
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-07-17 20:48:57 (GMT)
committerCecil <knoppmyth@gmail.com>2011-07-17 20:48:57 (GMT)
commit13e7dfcaf9aa5d46abd43fc0bfcc8c2167e99645 (patch)
tree6c8e8794f117d9966817f22422579963c40d5595 /abs/core/aufs2/PKGBUILD
parent06f2b22d74a98b88b09fdd927c6038f4b8fbe6fe (diff)
downloadlinhes_pkgbuild-13e7dfcaf9aa5d46abd43fc0bfcc8c2167e99645.zip
linhes_pkgbuild-13e7dfcaf9aa5d46abd43fc0bfcc8c2167e99645.tar.gz
linhes_pkgbuild-13e7dfcaf9aa5d46abd43fc0bfcc8c2167e99645.tar.bz2
aufs:Bumped to latest
Diffstat (limited to 'abs/core/aufs2/PKGBUILD')
-rw-r--r--abs/core/aufs2/PKGBUILD39
1 files changed, 23 insertions, 16 deletions
diff --git a/abs/core/aufs2/PKGBUILD b/abs/core/aufs2/PKGBUILD
index a05c666..12203af 100644
--- a/abs/core/aufs2/PKGBUILD
+++ b/abs/core/aufs2/PKGBUILD
@@ -1,26 +1,30 @@
-# $Id: PKGBUILD 105327 2011-01-07 20:08:57Z tpowa $
-# Maintainer: Paul Mattal <pjmattal@elys.com>
+# Contributor: Paul Mattal <pjmattal@elys.com>
+# Maintainer: Calimero <calimeroteknik@free.fr>
pkgname=aufs2
-pkgver=2.6.37_20110105
+pkgver=2.6.39_20110711
pkgrel=1
#_kernver=${pkgver%_*}-ARCH
-_kernver=2.6.37-LinHES
+
+# Set to whatever the tree of your aufs-friendly kernel is, and set the right dependency.
+#_kernver=2.6.39-ARCH
+#depends=('aufs_friendly')
+
+_kernver=2.6.39-LinHES
+depends=('kernel26>=2.6.39')
+
pkgdesc="Another Unionfs Implementation"
arch=('i686' 'x86_64')
url="http://aufs.sourceforge.net/"
license=('GPL2')
-depends=('kernel26>=2.6.37' 'kernel26<2.6.38')
-makedepends=('kernel26-headers>=2.6.37' 'kernel26-headers<2.6.38')
replaces=('aufs')
install=${pkgname}.install
-source=("ftp://ftp.archlinux.org/other/aufs2/${pkgname}-${pkgver}.tar.gz")
- #aufs2-module-2.6.36.patch)
-options=('!makeflags')
+source=("http://calimeroteknik.free.fr/src/${pkgname}-${pkgver}.tar.gz")
+options=('!makeflags' '!strip')
+md5sums=('74bde9670759201f07025adf70bbaf43')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- #patch -Np1 -i ../aufs2-module-2.6.36.patch
sed -i 's|CONFIG_AUFS_HNOTIFY =.*|CONFIG_AUFS_HNOTIFY = y|' \
config.mk || return 1
sed -i 's|CONFIG_AUFS_HFSNOTIFY =.*|CONFIG_AUFS_HFSNOTIFY = y|' \
@@ -42,8 +46,10 @@ build() {
fi
sed -i "s|CONFIG_AUFS_INO_T_64 =.*|CONFIG_AUFS_INO_T_64 =${inot64}|" \
config.mk
- # build
- make aufs.ko KDIR=/usr/src/linux-${_kernver}
+ # build, sed fixes are from gentoo portage build
+ sed -i "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" Makefile
+ sed -i "s:__user::g" include/linux/aufs_type.h
+ make KDIR=/usr/src/linux-${_kernver}
}
package() {
@@ -52,8 +58,9 @@ package() {
$pkgdir/lib/modules/${_kernver}/kernel/fs/aufs/aufs.ko
# tweak the install script for the right kernel version
sed -i -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" \
- $startdir/$pkgname.install
- # install include files
- install -D -m 644 include/linux/aufs_type.h $pkgdir/usr/src/linux-$_kernver/include/linux/aufs_type.h
+ $startdir/$pkgname.install
+ # install include file
+ install -D -m 644 include/linux/aufs_type.h $pkgdir/usr/include/linux/aufs_type.h
+ # gzip -9 all modules to safe 100MB
+ find "$pkgdir" -name '*.ko' -exec gzip -9 {} \;
}
-md5sums=('630c9c36bd4c0aa75a12b9bfa01ef8ee')