summaryrefslogtreecommitdiffstats
path: root/abs/core/automake
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/automake
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/automake')
-rw-r--r--abs/core/automake/PKGBUILD25
-rw-r--r--abs/core/automake/automake.install20
2 files changed, 45 insertions, 0 deletions
diff --git a/abs/core/automake/PKGBUILD b/abs/core/automake/PKGBUILD
new file mode 100644
index 0000000..2943f44
--- /dev/null
+++ b/abs/core/automake/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 19545 2008-11-26 18:00:03Z andyrtr $
+# Contributor: judd <jvinet@zeroflux.org>
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=automake
+pkgver=1.10.2
+pkgrel=1
+pkgdesc="A GNU tool for automatically creating Makefiles"
+arch=(i686 x86_64)
+license=('GPL')
+url="http://www.gnu.org/software/automake"
+groups=('base-devel')
+depends=('perl' 'bash' 'texinfo')
+install=automake.install
+source=(ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('ede3e08c696861a01f4d2c6a2e822053')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+
+ rm -f ${pkgdir}/usr/share/info/dir
+}
diff --git a/abs/core/automake/automake.install b/abs/core/automake/automake.install
new file mode 100644
index 0000000..a1030e5
--- /dev/null
+++ b/abs/core/automake/automake.install
@@ -0,0 +1,20 @@
+infodir=/usr/share/info
+filelist=(automake.info automake.info-1 automake.info-2)
+
+post_install() {
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+# vim:set ts=2 sw=2 et: