summaryrefslogtreecommitdiffstats
path: root/abs/core/automake
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-06 22:28:43 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-06 22:28:43 (GMT)
commitbed9218f521cfd8631017f995aa5bdb4f2bd67aa (patch)
treee88eb47cce9fb2d8d212d2969c63ea8ab6229424 /abs/core/automake
parent199b067c0b36f2f460c547481858c29e3c7fda81 (diff)
downloadlinhes_pkgbuild-bed9218f521cfd8631017f995aa5bdb4f2bd67aa.zip
linhes_pkgbuild-bed9218f521cfd8631017f995aa5bdb4f2bd67aa.tar.gz
linhes_pkgbuild-bed9218f521cfd8631017f995aa5bdb4f2bd67aa.tar.bz2
automake 1.12.2
Diffstat (limited to 'abs/core/automake')
-rw-r--r--abs/core/automake/PKGBUILD32
-rw-r--r--abs/core/automake/automake-1.12.2-aclocal7-test-fix.diff18
-rw-r--r--abs/core/automake/automake.install6
3 files changed, 44 insertions, 12 deletions
diff --git a/abs/core/automake/PKGBUILD b/abs/core/automake/PKGBUILD
index 0b3a6f2..c9bbe1c 100644
--- a/abs/core/automake/PKGBUILD
+++ b/abs/core/automake/PKGBUILD
@@ -1,25 +1,37 @@
-# $Id: PKGBUILD 19545 2008-11-26 18:00:03Z andyrtr $
+# $Id: PKGBUILD 163495 2012-07-13 12:31:30Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
-# Maintainer: Andreas Radke <andyrtr@archlinux.org>
pkgname=automake
-pkgver=1.11.1
+pkgver=1.12.2
pkgrel=1
pkgdesc="A GNU tool for automatically creating Makefiles"
-arch=(i686 x86_64)
+arch=('any')
license=('GPL')
url="http://www.gnu.org/software/automake"
groups=('base-devel')
-depends=('perl' 'bash' 'texinfo' 'autoconf>=2.60')
+depends=('perl' 'bash')
+makedepends=('autoconf')
install=automake.install
-source=(ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz)
+source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz{,.sig}
+ automake-1.12.2-aclocal7-test-fix.diff)
+md5sums=('56c3ab38a5ed8f2b825341b4e007372a'
+ '09e754ad7198853dc6abe22cc5e6ba4b'
+ '12280109fc55cfb6197feecfbe7ab513')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
+ patch -p2 -i $srcdir/automake-1.12.2-aclocal7-test-fix.diff
./configure --prefix=/usr
- make || return 1
- make DESTDIR=${pkgdir} install || return 1
+ make
+}
- rm -f ${pkgdir}/usr/share/info/dir
+check() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make check
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
}
-md5sums=('4ee7f0ff5f0e467d58b6bd5da96b1c74')
diff --git a/abs/core/automake/automake-1.12.2-aclocal7-test-fix.diff b/abs/core/automake/automake-1.12.2-aclocal7-test-fix.diff
new file mode 100644
index 0000000..e1fd4ba
--- /dev/null
+++ b/abs/core/automake/automake-1.12.2-aclocal7-test-fix.diff
@@ -0,0 +1,18 @@
+Fix a race condition that causes aclocal7 to fail on fast machines (see the
+comment below).
+
+diff -x config.log -x config.status -ru tmp/automake-1.12.2/t/aclocal7.sh work/automake-1.12.2/t/aclocal7.sh
+--- tmp/automake-1.12.2/t/aclocal7.sh 2012-07-08 11:48:25.000000000 +0100
++++ work/automake-1.12.2/t/aclocal7.sh 2012-07-10 11:58:50.325999591 +0100
+@@ -45,6 +45,11 @@
+ $AUTOMAKE --no-force
+ }
+
++# aclocal will rewrite aclocal.m4 unless the input files are all older than the
++# existing aclocal.m4 -- sleep to ensure somedefs.m4 has an older timestamp
++# than the aclocal.m4 that the next aclocal call will generate.
++$sleep
++
+ $ACLOCAL -I m4
+ AUTOMAKE_after_aclocal
+
diff --git a/abs/core/automake/automake.install b/abs/core/automake/automake.install
index a1030e5..10c2f2d 100644
--- a/abs/core/automake/automake.install
+++ b/abs/core/automake/automake.install
@@ -2,8 +2,9 @@ infodir=/usr/share/info
filelist=(automake.info automake.info-1 automake.info-2)
post_install() {
+ [ -x usr/bin/install-info ] || return 0
for file in ${filelist[@]}; do
- install-info $infodir/$file $infodir/dir 2> /dev/null
+ install-info $infodir/$file.gz $infodir/dir 2> /dev/null
done
}
@@ -12,8 +13,9 @@ post_upgrade() {
}
pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
for file in ${filelist[@]}; do
- install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
done
}