summaryrefslogtreecommitdiffstats
path: root/abs/core/avahi
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/avahi
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/avahi')
-rw-r--r--abs/core/avahi/ChangeLog9
-rw-r--r--abs/core/avahi/PKGBUILD64
-rw-r--r--abs/core/avahi/avahi.install42
-rw-r--r--abs/core/avahi/gnome-nettool.pngbin0 -> 4509 bytes
4 files changed, 115 insertions, 0 deletions
diff --git a/abs/core/avahi/ChangeLog b/abs/core/avahi/ChangeLog
new file mode 100644
index 0000000..e298fb4
--- /dev/null
+++ b/abs/core/avahi/ChangeLog
@@ -0,0 +1,9 @@
+
+2009-01-04 Douglas Soares de Andrade <douglas@archlinux.org>
+
+ * Updated for i686: 0.6.24
+
+2008-07-22 Douglas Soares de Andrade <douglas@archlinux.org>
+
+ * Updated for i686: 0.6.23
+
diff --git a/abs/core/avahi/PKGBUILD b/abs/core/avahi/PKGBUILD
new file mode 100644
index 0000000..c448d16
--- /dev/null
+++ b/abs/core/avahi/PKGBUILD
@@ -0,0 +1,64 @@
+# $Id: PKGBUILD 23159 2009-01-04 04:58:11Z douglas $
+# Maintainer: Douglas Soares de Andrade <douglas@archlinux.org>
+
+pkgname=avahi
+pkgver=0.6.24
+pkgrel=2
+pkgdesc="A multicast/unicast DNS-SD framework"
+arch=('i686' 'x86_64')
+url="http://www.avahi.org/"
+license=('LGPL')
+depends=('dbus>=1.1.20-1' 'libcap' 'libdaemon>=0.11' 'gdbm' 'glib2' 'expat')
+optdepends=('qt3:Qt3 UI support' 'libglade:Avahi-discover-standalone'
+ 'nss-mdns:NSS support for mDNS')
+makedepends=('mono' 'pygtk' 'gtk-sharp-2' 'dbus-python' 'qt3' 'libglade' 'intltool')
+backup=(etc/avahi/avahi-daemon.conf)
+install=avahi.install
+conflicts=('howl' 'mdnsresponder')
+provides=('howl' 'mdnsresponder')
+replaces=('howl' 'mdnsresponder')
+options=('!libtool')
+source=(http://www.avahi.org/download/avahi-${pkgver}.tar.gz gnome-nettool.png)
+
+build() {
+ [ -z "${QTDIR}" ] && . /etc/profile.d/qt3.sh
+ export MONO_SHARED_DIR=${startdir}/src/.wabi
+ mkdir -p ${MONO_SHARED_DIR}
+
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-qt4 \
+ --disable-monodoc \
+ --disable-doxygen-doc \
+ --disable-xmltoman \
+ --enable-compat-libdns_sd \
+ --enable-compat-howl \
+ --with-distro=archlinux \
+ --with-avahi-priv-access-group=network \
+ --enable-autoipd \
+ --with-autoipd-user=avahi \
+ --with-autoipd-group=avahi
+
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+
+ rm -rf ${MONO_SHARED_DIR}
+
+ #fix capability
+ sed -i -e 's|$DAEMON -D |modprobe capability > /dev/null 2>\&1 ; $DAEMON -D |' ${startdir}/pkg/etc/rc.d/avahi-daemon
+
+ sed -i -e 's/netdev/network/g' ${startdir}/pkg/etc/dbus-1/system.d/avahi-dbus.conf
+
+ # howl and mdnsresponder compatability
+ cd ${startdir}/pkg/usr/include
+ ln -s avahi-compat-libdns_sd/dns_sd.h dns_sd.h
+ ln -s avahi-compat-howl howl
+ cd ${startdir}/pkg/usr/lib/pkgconfig
+ ln -s avahi-compat-howl.pc howl.pc
+ mkdir -p ${startdir}/pkg/usr/share/pixmaps
+ install -m 644 ${startdir}/src/gnome-nettool.png ${startdir}/pkg/usr/share/pixmaps/gnome-nettool.png
+}
+md5sums=('068c1d220b07037e64caf87d4a7a0504'
+ '42c2905307c7a5dc6ac4b75f4c3d65a3')
diff --git a/abs/core/avahi/avahi.install b/abs/core/avahi/avahi.install
new file mode 100644
index 0000000..f0beca8
--- /dev/null
+++ b/abs/core/avahi/avahi.install
@@ -0,0 +1,42 @@
+post_install() {
+ echo -n "adding avahi system group... "
+ groupadd -g 84 avahi && echo "done."
+ echo -n "adding avahi system user... "
+ useradd -c "Avahi daemon" -u 84 -d / -g avahi -s /bin/false avahi \
+ && echo "done."
+ passwd -l avahi &>/dev/null
+
+ post_upgrade
+ cat << 'EOM'
+==> The following daemons may be added to DAEMONS in /etc/rc.conf:
+ -> avahi-daemon - the mdns responder, you probably want this.
+ dbus needs to be running when you start it.
+ -> avahi-dnsconfd - daemon used for peer-to-peer automatic dns
+ configuration on dhcp-less networks.
+
+==> To use some of the client applications you will have to install python.
+ -> In addition, pygtk is required for the graphical ones and
+ twisted-web for avahi-bookmarks.
+
+EOM
+}
+
+post_upgrade() {
+ true
+}
+
+pre_remove() {
+ # pre_remove gets called whenever post_remove is defined.
+ true
+}
+
+post_remove() {
+ # post_remove doesn't start at a newline like the other post_* functions,
+ # so we'll have to make one for ourselves.
+ echo -n -e "\nremoving avahi system user... "
+ userdel avahi && echo "done."
+}
+
+op=$1
+shift
+$op $*
diff --git a/abs/core/avahi/gnome-nettool.png b/abs/core/avahi/gnome-nettool.png
new file mode 100644
index 0000000..227d067
--- /dev/null
+++ b/abs/core/avahi/gnome-nettool.png
Binary files differ