summaryrefslogtreecommitdiffstats
path: root/abs/core/avahi
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-20 03:52:05 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-20 03:52:05 (GMT)
commitff5993f9531cd8a92743f36cf88a2c90f0b0b553 (patch)
tree8e8243c6f784ce09e16f3ac8404e6172e0c3e132 /abs/core/avahi
parent4cf461353e50a84f985b6204dc891e12072a2698 (diff)
downloadlinhes_pkgbuild-ff5993f9531cd8a92743f36cf88a2c90f0b0b553.zip
linhes_pkgbuild-ff5993f9531cd8a92743f36cf88a2c90f0b0b553.tar.gz
linhes_pkgbuild-ff5993f9531cd8a92743f36cf88a2c90f0b0b553.tar.bz2
avahi: upgrade
Diffstat (limited to 'abs/core/avahi')
-rw-r--r--abs/core/avahi/PKGBUILD82
-rw-r--r--abs/core/avahi/avahi-daemon-dbus.patch19
-rw-r--r--abs/core/avahi/avahi.install45
-rw-r--r--abs/core/avahi/introspection.patch18
4 files changed, 81 insertions, 83 deletions
diff --git a/abs/core/avahi/PKGBUILD b/abs/core/avahi/PKGBUILD
index f3d15bf..690762e 100644
--- a/abs/core/avahi/PKGBUILD
+++ b/abs/core/avahi/PKGBUILD
@@ -1,41 +1,50 @@
-# $Id: PKGBUILD 70504 2010-02-27 03:24:54Z dgriffiths $
+# $Id: PKGBUILD 94183 2010-10-05 07:08:54Z bisson $
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
pkgname=avahi
-pkgver=0.6.25
-pkgrel=3
-pkgdesc="A multicast/unicast DNS-SD framework"
+pkgver=0.6.27
+pkgrel=7
+pkgdesc='A multicast/unicast DNS-SD framework'
arch=('i686' 'x86_64')
-url="http://www.avahi.org/"
+url='http://www.avahi.org/'
license=('LGPL')
-depends=('dbus>=1.1.20-1' 'libcap>=2.16' 'libdaemon>=0.11' 'gdbm' 'glib2' 'expat')
-optdepends=('qt3: Qt3 UI support'
- 'libglade: avahi-discover-standalone'
- 'nss-mdns: NSS support for mDNS'
- 'pygtk: avahi-discover'
- 'dbus-python: avahi-discover')
-makedepends=('mono' 'pygtk' 'gtk-sharp-2' 'dbus-python' 'qt3' 'libglade' 'intltool')
+depends=('expat' 'libdaemon' 'glib2' 'dbus' 'libcap' 'gdbm')
+optdepends=('gtk2: avahi-discover-standalone'
+ 'qt3: qt3 bindings'
+ 'qt: qt bindings'
+ 'pygtk: avahi-bookmarks, avahi-discover'
+ 'twisted: avahi-bookmarks'
+ 'mono: mono bindings'
+ 'dbus-python: avahi-discover'
+ 'nss-mdns: NSS support for mDNS')
+makedepends=('qt' 'qt3' 'pygtk' 'mono' 'intltool' 'dbus-python' 'gtk-sharp-2' 'gobject-introspection>=0.9.10')
backup=(etc/avahi/avahi-daemon.conf etc/avahi/services/{sftp-,}ssh.service)
install=avahi.install
conflicts=('howl' 'mdnsresponder')
provides=('howl' 'mdnsresponder')
replaces=('howl' 'mdnsresponder')
options=('!libtool')
-source=(http://www.avahi.org/download/avahi-${pkgver}.tar.gz gnome-nettool.png avahi-daemon-dbus.patch)
+source=(http://www.avahi.org/download/avahi-${pkgver}.tar.gz
+ avahi-daemon-dbus.patch
+ gnome-nettool.png
+ introspection.patch)
+sha1sums=('e763bbeba92fd5b3ba3e2af5fc85aaf99b406c8b'
+ '41e9f23efa0b5a5f7b0f14a86cfb0677ece84c61'
+ 'cf56387c88aed246b9f435efc182ef44de4d52f3'
+ '999d71add829ab9bb55262855dfe04126ac7975c')
build() {
- [ -z "${QTDIR}" ] && . /etc/profile.d/qt3.sh
- export MONO_SHARED_DIR=${srcdir}/.wabi
- mkdir -p ${MONO_SHARED_DIR}
+ cd "${srcdir}/${pkgname}-${pkgver}"
- cd ${srcdir}/${pkgname}-${pkgver}
+ sed -i 's/netdev/network/g' avahi-daemon/avahi-dbus.conf
+ patch -Np0 -i "${srcdir}/avahi-daemon-dbus.patch"
+ patch -Np1 -i "${srcdir}/introspection.patch"
- sed -i 's|Requires.private|Requires|' avahi-qt3.pc.in
-
- ./configure --prefix=/usr \
+ ./configure \
+ --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
- --disable-qt4 \
+ --disable-gtk3 \
--disable-monodoc \
--disable-doxygen-doc \
--disable-xmltoman \
@@ -43,29 +52,26 @@ build() {
--enable-compat-howl \
--with-distro=archlinux \
--with-avahi-priv-access-group=network \
- --enable-autoipd \
--with-autoipd-user=avahi \
- --with-autoipd-group=avahi
+ --with-autoipd-group=avahi \
+ --with-systemdsystemunitdir=/lib/systemd/system # See FS#20999
+
+ make
+}
- make || return 1
- make DESTDIR=${pkgdir} install
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
- rm -rf ${MONO_SHARED_DIR}
-
- sed -i -e 's/netdev/network/g' ${pkgdir}/etc/dbus-1/system.d/avahi-dbus.conf
-
# howl and mdnsresponder compatability
- cd ${pkgdir}/usr/include
+ cd "${pkgdir}"/usr/include
ln -s avahi-compat-libdns_sd/dns_sd.h dns_sd.h
ln -s avahi-compat-howl howl
- cd ${pkgdir}/usr/lib/pkgconfig
+ cd "${pkgdir}"/usr/lib/pkgconfig
ln -s avahi-compat-howl.pc howl.pc
- mkdir -p ${pkgdir}/usr/share/pixmaps
- install -m 644 ${srcdir}/gnome-nettool.png ${pkgdir}/usr/share/pixmaps/gnome-nettool.png
- cd ${pkgdir}
- patch -p0 < ${srcdir}/avahi-daemon-dbus.patch || return 1
+ sed -i '1c #!/usr/bin/python2' "$pkgdir"/usr/bin/avahi-{bookmarks,discover}
+
+ install -D -m 644 "${srcdir}"/gnome-nettool.png "${pkgdir}"/usr/share/pixmaps/gnome-nettool.png
}
-md5sums=('a83155a6e29e3988f07e5eea3287b21e'
- '42c2905307c7a5dc6ac4b75f4c3d65a3'
- '0e1f5900b56fcfa1bffddb4f233f539f')
diff --git a/abs/core/avahi/avahi-daemon-dbus.patch b/abs/core/avahi/avahi-daemon-dbus.patch
index fe82f41..a168f03 100644
--- a/abs/core/avahi/avahi-daemon-dbus.patch
+++ b/abs/core/avahi/avahi-daemon-dbus.patch
@@ -1,16 +1,11 @@
---- etc/rc.d/avahi-daemon 2010-02-26 21:10:30.000000000 -0600
-+++ etc/rc.d/avahi-daemon 2010-02-26 21:09:44.000000000 -0600
-@@ -35,8 +35,11 @@
+--- initscript/archlinux/avahi-daemon.in 2010-08-17 22:23:46.510293144 +0200
++++ initscript/archlinux/avahi-daemon.in 2010-08-17 22:46:58.110163026 +0200
+@@ -33,6 +35,8 @@
case "$1" in
start)
-- stat_busy "Starting $DESC"
-- $DAEMON -D > /dev/null 2>&1
-+ if ck_daemon dbus; then
-+ /etc/rc.d/dbus start
-+ fi
-+ stat_busy "Starting $DESC"
-+ modprobe capability > /dev/null 2>&1 ; $DAEMON -D > /dev/null 2>&1
++ ck_daemon dbus && /etc/rc.d/dbus start
++ modprobe capability &> /dev/null
+ stat_busy "Starting $DESC"
+ $DAEMON -D > /dev/null 2>&1
if [ $? -gt 0 ]; then
- stat_fail
- else
diff --git a/abs/core/avahi/avahi.install b/abs/core/avahi/avahi.install
index f0beca8..7c75c3d 100644
--- a/abs/core/avahi/avahi.install
+++ b/abs/core/avahi/avahi.install
@@ -1,42 +1,21 @@
post_install() {
- echo -n "adding avahi system group... "
- groupadd -g 84 avahi && echo "done."
- echo -n "adding avahi system user... "
- useradd -c "Avahi daemon" -u 84 -d / -g avahi -s /bin/false avahi \
- && echo "done."
- passwd -l avahi &>/dev/null
+ getent group avahi &>/dev/null || groupadd -r -g 84 avahi >/dev/null
+ getent passwd avahi &>/dev/null || useradd -r -u 84 -g avahi -d / -s /bin/false -c avahi avahi >/dev/null
- post_upgrade
- cat << 'EOM'
+ cat <<EOF
==> The following daemons may be added to DAEMONS in /etc/rc.conf:
- -> avahi-daemon - the mdns responder, you probably want this.
- dbus needs to be running when you start it.
- -> avahi-dnsconfd - daemon used for peer-to-peer automatic dns
- configuration on dhcp-less networks.
+==> avahi-daemon: the mdns responder, you probably want this.
+==> dbus needs to be running when you start it.
+==> avahi-dnsconfd: daemon used for peer-to-peer automatic dns
+==> configuration on dhcp-less networks.
==> To use some of the client applications you will have to install python.
- -> In addition, pygtk is required for the graphical ones and
- twisted-web for avahi-bookmarks.
-
-EOM
-}
-
-post_upgrade() {
- true
-}
-
-pre_remove() {
- # pre_remove gets called whenever post_remove is defined.
- true
+==> In addition, pygtk is required for the graphical ones and
+==> twisted for avahi-bookmarks.
+EOF
}
post_remove() {
- # post_remove doesn't start at a newline like the other post_* functions,
- # so we'll have to make one for ourselves.
- echo -n -e "\nremoving avahi system user... "
- userdel avahi && echo "done."
+ getent passwd avahi &>/dev/null && userdel avahi >/dev/null
+ getent group avahi &>/dev/null && groupdel avahi >/dev/null
}
-
-op=$1
-shift
-$op $*
diff --git a/abs/core/avahi/introspection.patch b/abs/core/avahi/introspection.patch
new file mode 100644
index 0000000..88a7a73
--- /dev/null
+++ b/abs/core/avahi/introspection.patch
@@ -0,0 +1,18 @@
+diff -aur avahi-0.6.27/avahi-gobject/AvahiCore-0.6.gir avahi-0.6.27-introspection/avahi-gobject/AvahiCore-0.6.gir
+--- avahi-0.6.27/avahi-gobject/AvahiCore-0.6.gir 2010-06-27 02:38:43.018291433 +0200
++++ avahi-0.6.27-introspection/avahi-gobject/AvahiCore-0.6.gir 2010-09-30 16:16:41.260000339 +0200
+@@ -1,10 +1,12 @@
+ <?xml version="1.0"?>
+-<repository version="1.0"
++<repository version="1.2"
+ xmlns="http://www.gtk.org/introspection/core/1.0"
+ xmlns:c="http://www.gtk.org/introspection/c/1.0"
+ xmlns:glib="http://www.gtk.org/introspection/glib/1.0">
+ <namespace name="AvahiCore" version="0.6" shared-library="avahi-core">
+- <alias name="IfIndex" target="int" c:type="AvahiIfIndex"/>
++ <alias name="IfIndex" target="int">
++ <type name="AvahiIfIndex" c:type="AvahiIfIndex"/>
++ </alias>
+ <enumeration name="Protocol" c:type="AvahiProtocol">
+ <member name="inet"
+ value="0"