summaryrefslogtreecommitdiffstats
path: root/abs/core/bash
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/bash
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/bash')
-rw-r--r--abs/core/bash/PKGBUILD76
-rw-r--r--abs/core/bash/bash.install21
-rw-r--r--abs/core/bash/bashrc5
3 files changed, 70 insertions, 32 deletions
diff --git a/abs/core/bash/PKGBUILD b/abs/core/bash/PKGBUILD
index 24f80ef..ae1eaba 100644
--- a/abs/core/bash/PKGBUILD
+++ b/abs/core/bash/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 5542 2008-07-18 15:21:56Z aaron $
+# $Id: PKGBUILD 25772 2009-01-28 20:03:08Z aaron $
# Maintainer: Aaron Griffin <aaron@archlinux.org>
pkgname=bash
-_patchlevel=039
+_patchlevel=048
pkgver=3.2.$_patchlevel
-pkgrel=11
+pkgrel=3
pkgdesc="The GNU Bourne Again shell"
arch=(i686 x86_64)
license=('GPL')
@@ -12,16 +12,45 @@ url="http://www.gnu.org/software/bash/bash.html"
groups=('base')
backup=(etc/profile.bash etc/skel/.bashrc etc/skel/.bash_profile)
depends=('readline>=5.2' 'glibc')
+makedepends=(gzip bison)
provides=('sh')
+install=bash.install
source=(http://ftp.gnu.org/gnu/bash/bash-3.2.tar.gz
- bash-noinfo.patch profile.bash bashrc)
+ profile.bash bashrc)
for p in $(seq -w 001 $_patchlevel); do
source=(${source[@]} http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-$p)
done
+
+build() {
+ cd ${startdir}/src/${pkgname}-3.2
+ for p in ../bash32-*; do
+ msg "applying patch ${p}"
+ patch -Np0 -i ${p} || return 1
+ done
+
+ ./configure --prefix=/usr --with-curses --enable-readline \
+ --without-bash-malloc --with-installed-readline \
+ --bindir=/bin --mandir=/usr/share/man --infodir=/usr/share/info
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+
+ install -D -m644 ${startdir}/src/profile.bash ${startdir}/pkg/etc/profile.bash
+
+ # for now, bash is our default /bin/sh
+ cd ${startdir}/pkg/bin
+ ln -s bash sh
+
+ mkdir -p $startdir/pkg/etc/skel/
+ install -D -m644 $startdir/src/bashrc $startdir/pkg/etc/skel/.bashrc
+ echo ". \$HOME/.bashrc" >$startdir/pkg/etc/skel/.bash_profile
+
+ rm -f ${pkgdir}/usr/share/info/dir
+ gzip -9 ${pkgdir}/usr/share/info/bash.info
+}
+# wow, that's a lot of md5sums!
md5sums=('00bfa16d58e034e3c2aa27f390390d30'
- 'f2a3cf51e58f9b82af50b861191d96fd'
'c2fae355facefcac8a732cce877da194'
- '9451109f3fe09d6381cbf36de9fbf06f'
+ '3d2837e84645eac9bde399b58014bafa'
'd8e10c754f477e3f3a581af566b89301'
'd38a5288b2f0ea6c9ac76b66cc74ef7d'
'0b90d37911827d8cb95f3b4353cc225e'
@@ -60,28 +89,13 @@ md5sums=('00bfa16d58e034e3c2aa27f390390d30'
'95c70c7ae9de5bd3659c86284be7fb76'
'62b876a3d7cd192cc8db2476fbb6b7b9'
'aca3afc341bd3e5a0d8a3b4ca40dbb3f'
- 'e240c34f979b64bcb83c5f6567110bb1')
-
-build() {
- cd ${startdir}/src/${pkgname}-3.2
- for p in ../bash32-*; do
- msg "applying patch ${p}"
- patch -Np0 -i ${p} || return 1
- done
- patch -Np1 -i ../bash-noinfo.patch || return 1
- ./configure --prefix=/usr --with-curses --enable-readline \
- --without-bash-malloc --with-installed-readline \
- --bindir=/bin --mandir=/usr/share/man
- make || return 1
- make DESTDIR=${startdir}/pkg install
-
- install -D -m644 ${startdir}/src/profile.bash ${startdir}/pkg/etc/profile.bash
-
- # for now, bash is our default /bin/sh
- cd ${startdir}/pkg/bin
- ln -s bash sh
-
- mkdir -p $startdir/pkg/etc/skel/
- install -D -m644 $startdir/src/bashrc $startdir/pkg/etc/skel/.bashrc
- echo ". \$HOME/.bashrc" >$startdir/pkg/etc/skel/.bash_profile
-}
+ 'e240c34f979b64bcb83c5f6567110bb1'
+ '06e6df263398807fa032707fb7b77b5f'
+ '373ae081d658dc85bc1058c4759d6669'
+ '9c9ebc6bfc33a0215277ee17a276eb5a'
+ 'b87fb9ea16a64ca41b6676e9a7eb7a33'
+ '07e0229ce5879bfbd26a8146070fd366'
+ '1ad07965a8a93f3556ee1ab18b97cde2'
+ 'f7b1e19fcad54c2286bc0ed614aad9bf'
+ '550690766de770116c34dbdf74e59184'
+ '4cc593e7b789b23b37a5397e092d3954')
diff --git a/abs/core/bash/bash.install b/abs/core/bash/bash.install
new file mode 100644
index 0000000..5c3c435
--- /dev/null
+++ b/abs/core/bash/bash.install
@@ -0,0 +1,21 @@
+info_dir=/usr/share/info
+info_files=(bash.info)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for f in ${info_files[@]}; do
+ usr/bin/install-info ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for f in ${info_files[@]}; do
+ usr/bin/install-info --delete ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
+ done
+}
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core/bash/bashrc b/abs/core/bash/bashrc
index fcabce0..0963431 100644
--- a/abs/core/bash/bashrc
+++ b/abs/core/bash/bashrc
@@ -1,3 +1,6 @@
+
+# Check for an interactive session
+[ -z "$PS1" ] && return
+
alias ls='ls --color=auto'
PS1='[\u@\h \W]\$ '
-