summaryrefslogtreecommitdiffstats
path: root/abs/core/bash
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/bash
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/bash')
-rw-r--r--abs/core/bash/PKGBUILD116
-rw-r--r--abs/core/bash/bash-noinfo.patch12
-rw-r--r--abs/core/bash/enable-system-config-files.patch15
-rw-r--r--abs/core/bash/profile35
-rw-r--r--abs/core/bash/profile.bash18
-rw-r--r--abs/core/bash/system.bashrc31
6 files changed, 90 insertions, 137 deletions
diff --git a/abs/core/bash/PKGBUILD b/abs/core/bash/PKGBUILD
index ae1eaba..96c24a1 100644
--- a/abs/core/bash/PKGBUILD
+++ b/abs/core/bash/PKGBUILD
@@ -1,101 +1,69 @@
-# $Id: PKGBUILD 25772 2009-01-28 20:03:08Z aaron $
+# $Id: PKGBUILD 82719 2010-06-16 04:44:35Z allan $
# Maintainer: Aaron Griffin <aaron@archlinux.org>
pkgname=bash
-_patchlevel=048
-pkgver=3.2.$_patchlevel
-pkgrel=3
+_patchlevel=007 #prepare for some patches
+pkgver=4.1.$_patchlevel
+pkgrel=1
pkgdesc="The GNU Bourne Again shell"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
license=('GPL')
url="http://www.gnu.org/software/bash/bash.html"
groups=('base')
backup=(etc/profile.bash etc/skel/.bashrc etc/skel/.bash_profile)
-depends=('readline>=5.2' 'glibc')
-makedepends=(gzip bison)
+depends=('readline>=6.1' 'glibc')
+makedepends=(gzip)
provides=('sh')
install=bash.install
-source=(http://ftp.gnu.org/gnu/bash/bash-3.2.tar.gz
- profile.bash bashrc)
-for p in $(seq -w 001 $_patchlevel); do
- source=(${source[@]} http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-$p)
-done
+source=(http://ftp.gnu.org/gnu/bash/bash-4.1.tar.gz
+ profile.bash
+ bashrc
+ enable-system-config-files.patch
+ system.bashrc)
+if [ $_patchlevel -gt 000 ]; then
+ for (( p=1; p<=$_patchlevel; p++ )); do
+ source=(${source[@]} http://ftp.gnu.org/gnu/bash/bash-4.1-patches/bash41-$(printf "%03d" $p))
+ done
+fi
build() {
- cd ${startdir}/src/${pkgname}-3.2
- for p in ../bash32-*; do
+ cd ${srcdir}/${pkgname}-4.1
+ for p in ../bash41-*; do
+ [ -e "$p" ] || continue
msg "applying patch ${p}"
patch -Np0 -i ${p} || return 1
done
+ patch -Np0 -i $srcdir/enable-system-config-files.patch || return 1
+
./configure --prefix=/usr --with-curses --enable-readline \
--without-bash-malloc --with-installed-readline \
--bindir=/bin --mandir=/usr/share/man --infodir=/usr/share/info
make || return 1
- make DESTDIR=${startdir}/pkg install
+ make DESTDIR=${pkgdir} install
- install -D -m644 ${startdir}/src/profile.bash ${startdir}/pkg/etc/profile.bash
+ install -D -m644 ${srcdir}/profile.bash ${pkgdir}/etc/profile.bash || return 1
+ install -D -m644 ${srcdir}/system.bashrc ${pkgdir}/etc/bash.bashrc || return 1
# for now, bash is our default /bin/sh
- cd ${startdir}/pkg/bin
+ cd ${pkgdir}/bin
ln -s bash sh
- mkdir -p $startdir/pkg/etc/skel/
- install -D -m644 $startdir/src/bashrc $startdir/pkg/etc/skel/.bashrc
- echo ". \$HOME/.bashrc" >$startdir/pkg/etc/skel/.bash_profile
-
- rm -f ${pkgdir}/usr/share/info/dir
- gzip -9 ${pkgdir}/usr/share/info/bash.info
+ mkdir -p ${pkgdir}/etc/skel/
+ install -D -m644 ${srcdir}/bashrc ${pkgdir}/etc/skel/.bashrc
+ echo ". \$HOME/.bashrc" >${pkgdir}/etc/skel/.bash_profile
}
-# wow, that's a lot of md5sums!
-md5sums=('00bfa16d58e034e3c2aa27f390390d30'
- 'c2fae355facefcac8a732cce877da194'
+
+md5sums=('9800d8724815fd84994d9be65ab5e7b8'
+ '17f20ec69535a2f50f2112a8c700630d'
'3d2837e84645eac9bde399b58014bafa'
- 'd8e10c754f477e3f3a581af566b89301'
- 'd38a5288b2f0ea6c9ac76b66cc74ef7d'
- '0b90d37911827d8cb95f3b4353cc225e'
- '8062f3a59631f58d78b180d83759b68a'
- '585b5943fadf0875ced243b245adde58'
- '1d5732e01ea938aeed42f3def131fa4d'
- 'dcd0cc5d801607827f7c851e72b0eabc'
- 'bb3c7dd11198c0ab93d0e960bebf6256'
- '434a6f29b0ca5f1ab784b2437ae8eaed'
- '2efff04dd246fcf63bd4b99f77c9a081'
- '1dd104342f6920dfaf5efb3131e922e0'
- '4f24b696ab78bdfae4f9cb7eb59b835d'
- '7c40addbf1187a26ae1c8373ed383442'
- '28e88c9f8679e99ac590d4a4a8227c56'
- '7c17d29675bd0d49470f162774385f80'
- 'a1edaa98b4449fe2205fa75448b7b105'
- '889ed119bbf9d363660b9a0127f35efa'
- 'a7d3f85fa687d2c1b5a134839f6d395d'
- 'f0399da4007e46fc5820ce25d07425b9'
- 'b76602281c3104d904fd064510fe0c21'
- '923374ae4403c92820f711e62e1d01a5'
- 'c82d3bd14e373878b2a680dce18d1596'
- '987c949a77b4b0ffe4a2597141e77635'
- '5a2b976e761ab83f0fc7daae11451b86'
- '08668dc2825f65eced9cac6b09ce1b45'
- 'f35b2b217f088ff009f956894550d41d'
- 'b5ff2b9610c61290f773c4b02cc1a37d'
- '016f5b56c93404d32aea09385f0fc13e'
- 'a81420626d4d88d0dce2ffac0ac56341'
- '11f91baf970c132949f9072ee93f2ea6'
- 'f6bbc1e8ec0246740731c728ef476191'
- '8180ec936770579bce69f0816c2dd878'
- '3cec33c3711860c4c6b7614afeec7870'
- '7bc6c5b5f38b7027152f8db0458a2e14'
- 'a2db61fe90e39371d0e6cd2285ec9208'
- '95c70c7ae9de5bd3659c86284be7fb76'
- '62b876a3d7cd192cc8db2476fbb6b7b9'
- 'aca3afc341bd3e5a0d8a3b4ca40dbb3f'
- 'e240c34f979b64bcb83c5f6567110bb1'
- '06e6df263398807fa032707fb7b77b5f'
- '373ae081d658dc85bc1058c4759d6669'
- '9c9ebc6bfc33a0215277ee17a276eb5a'
- 'b87fb9ea16a64ca41b6676e9a7eb7a33'
- '07e0229ce5879bfbd26a8146070fd366'
- '1ad07965a8a93f3556ee1ab18b97cde2'
- 'f7b1e19fcad54c2286bc0ed614aad9bf'
- '550690766de770116c34dbdf74e59184'
- '4cc593e7b789b23b37a5397e092d3954')
+ '51725defa4c2dec49c1bc15883e0bee2'
+ '196697769f1667a8a1aed608811129c6'
+ '582dea5671b557f783e18629c2f77b68'
+ '118d465095d4a4706eb1d34696a2666a'
+ '120f7cf039a40d35fe375e59d6f17adc'
+ '336ee037fc2cc1e2350b05097fbdc87c'
+ '9471e666797f0b03eb2175ed752a9550'
+ 'fb80ccd58cb1e34940f3adf4ce6e4a1e'
+ '192a8b161d419a1d0d211169f1d1046e')
+
diff --git a/abs/core/bash/bash-noinfo.patch b/abs/core/bash/bash-noinfo.patch
deleted file mode 100644
index 856ec80..0000000
--- a/abs/core/bash/bash-noinfo.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur bash-3.0-orig/doc/Makefile.in bash-3.0/doc/Makefile.in
---- bash-3.0-orig/doc/Makefile.in 2004-07-27 05:57:48.000000000 -0700
-+++ bash-3.0/doc/Makefile.in 2005-02-11 22:44:49.000000000 -0800
-@@ -220,7 +220,7 @@
- $(SHELL) $(SUPPORT_SRCDIR)/mkinstalldirs $(DESTDIR)$(htmldir) ; \
- fi
-
--install: info installdirs bash.info
-+install: installdirs
- -$(INSTALL_DATA) $(srcdir)/bash.1 $(DESTDIR)$(man1dir)/bash${man1ext}
- -$(INSTALL_DATA) $(srcdir)/bashbug.1 $(DESTDIR)$(man1dir)/bashbug${man1ext}
- # uncomment the next line to install the builtins man page
diff --git a/abs/core/bash/enable-system-config-files.patch b/abs/core/bash/enable-system-config-files.patch
new file mode 100644
index 0000000..5295355
--- /dev/null
+++ b/abs/core/bash/enable-system-config-files.patch
@@ -0,0 +1,15 @@
+--- src/bash-4.0/config-top.h 2009-01-04 11:32:23.000000000 -0800
++++ config-top.h 2009-08-25 08:41:08.000000000 -0700
+@@ -75,10 +75,10 @@
+ #define KSH_COMPATIBLE_SELECT
+
+ /* System-wide .bashrc file for interactive shells. */
+-/* #define SYS_BASHRC "/etc/bash.bashrc" */
++#define SYS_BASHRC "/etc/bash.bashrc"
+
+ /* System-wide .bash_logout for login shells. */
+-/* #define SYS_BASH_LOGOUT "/etc/bash.bash_logout" */
++#define SYS_BASH_LOGOUT "/etc/bash.bash_logout"
+
+ /* Define this to make non-interactive shells begun with argv[0][0] == '-'
+ run the startup files when not in posix mode. */
diff --git a/abs/core/bash/profile b/abs/core/bash/profile
deleted file mode 100644
index ca1d402..0000000
--- a/abs/core/bash/profile
+++ /dev/null
@@ -1,35 +0,0 @@
-#
-# /etc/profile
-#
-
-export PATH="/bin:/usr/bin:/sbin:/usr/sbin:/usr/X11R6/bin:/opt/bin"
-
-export MANPATH="/usr/man:/usr/X11R6/man"
-export LESSCHARSET="latin1"
-export INPUTRC="/etc/inputrc"
-export LESS="-R"
-
-export LC_COLLATE="C"
-
-export COLUMNS LINES
-
-export PS1='[\u@\h \W]\$ '
-export PS2='> '
-
-umask 022
-
-if [ "$TERM" = "xterm" -o "$TERM" = "xterm-color" -o "$TERM" = "rxvt" -o "$TERM" = "xterm-xfree86" ]; then
- PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/$HOME/~}\007"'
-fi
-
-# load profiles from /etc/profile.d
-# (to disable a profile, just remove execute permission on it)
-if [ `ls -A1 /etc/profile.d/ | wc -l` -gt 0 ]; then
- for profile in /etc/profile.d/*.sh; do
- if [ -x $profile ]; then
- . $profile
- fi
- done
- unset profile
-fi
-# End of file
diff --git a/abs/core/bash/profile.bash b/abs/core/bash/profile.bash
index 8a7e1aa..d28f069 100644
--- a/abs/core/bash/profile.bash
+++ b/abs/core/bash/profile.bash
@@ -3,23 +3,9 @@
# Global settings for bash shells
#
-PS1='[\u@\h \W]\$ '
-PS2='> '
-PS3='> '
-PS4='+ '
-
-export PS1 PS2 PS3 PS4
-
#In the future we may want to add more ulimit entries here,
# in the offchance that /etc/security/limits.conf is skipped
ulimit -Sc 0 #Don't create core files
-if test "$TERM" = "xterm" -o \
- "$TERM" = "xterm-color" -o \
- "$TERM" = "xterm-256color" -o \
- "$TERM" = "rxvt" -o \
- "$TERM" = "rxvt-unicode" -o \
- "$TERM" = "xterm-xfree86"; then
- PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/$HOME/~}\007"'
- export PROMPT_COMMAND
-fi
+# Source our global bashrc file, to remove duplication of effort
+[ -r /etc/bash.bashrc ] && . /etc/bash.bashrc
diff --git a/abs/core/bash/system.bashrc b/abs/core/bash/system.bashrc
new file mode 100644
index 0000000..5430d6b
--- /dev/null
+++ b/abs/core/bash/system.bashrc
@@ -0,0 +1,31 @@
+#
+# /etc/bash.bashrc
+#
+# This file is the systemwide bashrc file. While most of the
+# environment is preserved when running an interactive shell
+# the PS[1-4] variables, aliases and functions are reset.
+#
+# When running a non-login shell, apply the following settings:
+# - Prompt defaults (PS[1-4], PROMPT_COMMAND)
+# - bash_completion if it exists
+# - source /etc/bash.bashrc.local
+
+PS1='[\u@\h \W]\$ '
+PS2='> '
+PS3='> '
+PS4='+ '
+
+export PS1 PS2 PS3 PS4
+
+if test "$TERM" = "xterm" -o \
+ "$TERM" = "xterm-color" -o \
+ "$TERM" = "xterm-256color" -o \
+ "$TERM" = "rxvt" -o \
+ "$TERM" = "rxvt-unicode" -o \
+ "$TERM" = "xterm-xfree86"; then
+ PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/$HOME/~}\007"'
+ export PROMPT_COMMAND
+fi
+
+[ -r /etc/bash_completion ] && . /etc/bash_completion
+[ -r /etc/bash.bashrc.local ] && . /etc/bash.bashrc.local