summaryrefslogtreecommitdiffstats
path: root/abs/core/bc
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-02-14 14:32:56 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-02-14 14:32:56 (GMT)
commit019de58d68566c27a1b487fef85e1d2982d2a691 (patch)
tree15ef0a2577f20cc227606d2c1bf755dd8ec0b74c /abs/core/bc
parent7b82ca0dae353b4c7fd51080946c08fed358ea8d (diff)
downloadlinhes_pkgbuild-019de58d68566c27a1b487fef85e1d2982d2a691.zip
linhes_pkgbuild-019de58d68566c27a1b487fef85e1d2982d2a691.tar.gz
linhes_pkgbuild-019de58d68566c27a1b487fef85e1d2982d2a691.tar.bz2
bc: update to 1.07.1
Diffstat (limited to 'abs/core/bc')
-rw-r--r--abs/core/bc/PKGBUILD28
-rw-r--r--abs/core/bc/bc-1.06.95-void_uninitialized.patch14
-rw-r--r--abs/core/bc/bc.install20
3 files changed, 10 insertions, 52 deletions
diff --git a/abs/core/bc/PKGBUILD b/abs/core/bc/PKGBUILD
index faf854f..3b40624 100644
--- a/abs/core/bc/PKGBUILD
+++ b/abs/core/bc/PKGBUILD
@@ -2,39 +2,31 @@
# Maintainer: dorphell <dorphell@archlinux.org>
pkgname=bc
-pkgver=1.06.95
+pkgver=1.07.1
pkgrel=1
pkgdesc="An arbitrary precision calculator language"
-arch=('i686' 'x86_64')
-url="http://www.gnu.org/software/bc/"
+arch=('x86_64')
+url="https://www.gnu.org/software/bc/"
license=('GPL')
depends=('readline')
+makedepends=('ed')
replaces=('bc-readline')
conflicts=('bc-readline')
-install=bc.install
-source=(ftp://alpha.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.bz2{,.sig}
- bc-1.06.95-void_uninitialized.patch)
-md5sums=('5126a721b73f97d715bb72c13c889035'
- 'SKIP'
- 'fe85d42dd4151801e9b8c2d2c4d990bf')
-
-prepare() {
- cd "${pkgname}-${pkgver}"
-
- # https://bugs.gentoo.org/show_bug.cgi?id=349339
- patch -Np0 -i ${srcdir}/bc-1.06.95-void_uninitialized.patch
-}
+source=(https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz{,.sig})
+sha256sums=('62adfca89b0a1c0164c2cdca59ca210c1d44c3ffc46daf9931cf4942664cb02a'
+ 'SKIP')
+validpgpkeys=('00E426232F384BF6D32D8B1881C24FF12FB7B14B') # Phil Nelson <philnelson@acm.org>
build() {
cd "${pkgname}-${pkgver}"
./configure --prefix=/usr --mandir=/usr/share/man \
--infodir=/usr/share/info --with-readline
- make
+ make -j1
}
check () {
cd "${pkgname}-${pkgver}"
- echo "quit" | ./bc/bc -l Test/checklib.b # 10 failures
+ echo "quit" | ./bc/bc -l Test/checklib.b
}
package() {
diff --git a/abs/core/bc/bc-1.06.95-void_uninitialized.patch b/abs/core/bc/bc-1.06.95-void_uninitialized.patch
deleted file mode 100644
index c60290c..0000000
--- a/abs/core/bc/bc-1.06.95-void_uninitialized.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-http://www.pixelbeat.org/programming/oss_bug_flow.html
-https://bugs.gentoo.org/349339
-
---- bc/storage.c
-+++ bc/storage.c
-@@ -99,6 +99,7 @@
- {
- f = &functions[indx];
- f->f_defined = FALSE;
-+ f->f_void = FALSE;
- f->f_body = (char *) bc_malloc (BC_START_SIZE);
- f->f_body_size = BC_START_SIZE;
- f->f_code_size = 0;
-
diff --git a/abs/core/bc/bc.install b/abs/core/bc/bc.install
deleted file mode 100644
index e1e2eaa..0000000
--- a/abs/core/bc/bc.install
+++ /dev/null
@@ -1,20 +0,0 @@
-infodir=/usr/share/info
-filelist=(bc.info.gz dc.info.gz)
-
-post_install() {
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- install-info $infodir/$file $infodir/dir 2> /dev/null
- done
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- install-info --delete $infodir/$file $infodir/dir 2> /dev/null
- done
-}