summaryrefslogtreecommitdiffstats
path: root/abs/core/binutils/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-01-19 16:33:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-01-19 16:33:12 (GMT)
commite4edea99d9ef9737e5e257dcec09c7f9e6cbeba7 (patch)
tree07040de086abef4be222e6d9d7151e69837aea5b /abs/core/binutils/PKGBUILD
parent4c44c66c79cc7ca470244a65afceb593ee46dfab (diff)
downloadlinhes_pkgbuild-e4edea99d9ef9737e5e257dcec09c7f9e6cbeba7.zip
linhes_pkgbuild-e4edea99d9ef9737e5e257dcec09c7f9e6cbeba7.tar.gz
linhes_pkgbuild-e4edea99d9ef9737e5e257dcec09c7f9e6cbeba7.tar.bz2
binutils: update to 2.25.1
Diffstat (limited to 'abs/core/binutils/PKGBUILD')
-rw-r--r--abs/core/binutils/PKGBUILD44
1 files changed, 18 insertions, 26 deletions
diff --git a/abs/core/binutils/PKGBUILD b/abs/core/binutils/PKGBUILD
index 26ba4f9..ad4a71e 100644
--- a/abs/core/binutils/PKGBUILD
+++ b/abs/core/binutils/PKGBUILD
@@ -3,58 +3,51 @@
# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
+# build from head of release branch as bug fix releases are rare
+
pkgname=binutils
-pkgver=2.24
-pkgrel=7
+pkgver=2.25.1
+pkgrel=3
+_commit=2bd25930
pkgdesc="A set of programs to assemble and manipulate binary and object files"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/binutils/"
license=('GPL')
groups=('base-devel')
-depends=('glibc>=2.20' 'zlib')
+depends=('glibc>=2.22' 'zlib')
+makedepends=('git')
checkdepends=('dejagnu' 'bc')
conflicts=('binutils-multilib')
replaces=('binutils-multilib')
options=('staticlibs' '!distcc' '!ccache')
install=binutils.install
-source=(ftp://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2{,.sig}
- binutils-2.24-lto-testsuite.patch
- binutils-2.24-gold-testsuite-plugin.patch
- binutils-2.24-shared-pie.patch)
-md5sums=('e0f71a7b2ddab0f8612336ac81d9636b'
- 'SKIP'
- 'e68a1f221545f082baa5bd417cd077af'
- 'e46bbb03abaa5db58c12247644dc4857'
- 'ec59461c4febab9cfe1c1ef33326bc50')
-validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93')
+source=(git://sourceware.org/git/binutils-gdb.git#commit=${_commit}
+ binutils-e9c1bdad.patch)
+md5sums=('SKIP'
+ 'eb3aceaab8ed26e06d505f82beb30f8f')
prepare() {
- cd ${srcdir}/binutils-${pkgver}
+ cd ${srcdir}/binutils-gdb
+
+ # https://sourceware.org/bugzilla/show_bug.cgi?id=16992
+ patch -p1 -i ${srcdir}/binutils-e9c1bdad.patch
# hack! - libiberty configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
- # fix lto testsuite with gcc-4.9 - commits b35d44f1 and 37a6ac44
- patch -p1 -i $srcdir/binutils-2.24-lto-testsuite.patch
-
- # fix gold testsuite with gcc-4.9 - commit ae447ddd
- patch -p1 -i $srcdir/binutils-2.24-gold-testsuite-plugin.patch
-
- # fix issues with -static -fPIE -pie - commit 4199e3b8
- patch -p1 -i $srcdir/binutils-2.24-shared-pie.patch
-
mkdir ${srcdir}/binutils-build
}
build() {
cd ${srcdir}/binutils-build
- ${srcdir}/binutils-${pkgver}/configure --prefix=/usr \
+ ${srcdir}/binutils-gdb/configure --prefix=/usr \
--with-lib-path=/usr/lib:/usr/local/lib \
--with-bugurl=https://bugs.archlinux.org/ \
--enable-threads --enable-shared --with-pic \
--enable-ld=default --enable-gold --enable-plugins \
- --disable-werror
+ --enable-deterministic-archives \
+ --disable-werror --disable-gdb
# check the host environment and makes sure all the necessary tools are available
make configure-host
@@ -76,7 +69,6 @@ package() {
# Remove unwanted files
rm ${pkgdir}/usr/share/man/man1/{dlltool,nlmconv,windres,windmc}*
- rm ${pkgdir}/usr/share/info/{configure,standards}.info
# No shared linking to these files outside binutils
rm ${pkgdir}/usr/lib/lib{bfd,opcodes}.so