summaryrefslogtreecommitdiffstats
path: root/abs/core/binutils/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-10-30 20:22:39 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-10-30 20:22:39 (GMT)
commitf86e6ee15bc2032f3f181e0cd6f1f1b2f8d460d8 (patch)
tree9a71cebf9aa8c45acc2a4c19c79d3d0080dc927d /abs/core/binutils/PKGBUILD
parent31e6320f048f7b41c47fe093bea5cb528d30b2a6 (diff)
downloadlinhes_pkgbuild-f86e6ee15bc2032f3f181e0cd6f1f1b2f8d460d8.zip
linhes_pkgbuild-f86e6ee15bc2032f3f181e0cd6f1f1b2f8d460d8.tar.gz
linhes_pkgbuild-f86e6ee15bc2032f3f181e0cd6f1f1b2f8d460d8.tar.bz2
binutils: update to 2.24
Diffstat (limited to 'abs/core/binutils/PKGBUILD')
-rw-r--r--abs/core/binutils/PKGBUILD92
1 files changed, 44 insertions, 48 deletions
diff --git a/abs/core/binutils/PKGBUILD b/abs/core/binutils/PKGBUILD
index a4d2839..26ba4f9 100644
--- a/abs/core/binutils/PKGBUILD
+++ b/abs/core/binutils/PKGBUILD
@@ -1,87 +1,83 @@
-# $Id: PKGBUILD 171025 2012-11-15 12:26:41Z allan $
+# $Id$
# Maintainer: Allan McRae <allan@archlinux.org>
# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
pkgname=binutils
-pkgver=2.23.1
-pkgrel=1
+pkgver=2.24
+pkgrel=7
pkgdesc="A set of programs to assemble and manipulate binary and object files"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/binutils/"
license=('GPL')
groups=('base-devel')
-depends=('glibc>=2.16' 'zlib')
+depends=('glibc>=2.20' 'zlib')
checkdepends=('dejagnu' 'bc')
-options=('!libtool' '!distcc' '!ccache')
+conflicts=('binutils-multilib')
+replaces=('binutils-multilib')
+options=('staticlibs' '!distcc' '!ccache')
install=binutils.install
-source=(ftp://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2{,.sig})
-md5sums=('33adb18c3048d057ac58d07a3f1adb38'
- '1869b37216e7d7eff7e335a69e0882fd')
+source=(ftp://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2{,.sig}
+ binutils-2.24-lto-testsuite.patch
+ binutils-2.24-gold-testsuite-plugin.patch
+ binutils-2.24-shared-pie.patch)
+md5sums=('e0f71a7b2ddab0f8612336ac81d9636b'
+ 'SKIP'
+ 'e68a1f221545f082baa5bd417cd077af'
+ 'e46bbb03abaa5db58c12247644dc4857'
+ 'ec59461c4febab9cfe1c1ef33326bc50')
+validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93')
+
+prepare() {
+ cd ${srcdir}/binutils-${pkgver}
+
+ # hack! - libiberty configure tests for header files using "$CPP $CPPFLAGS"
+ sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
+
+ # fix lto testsuite with gcc-4.9 - commits b35d44f1 and 37a6ac44
+ patch -p1 -i $srcdir/binutils-2.24-lto-testsuite.patch
+
+ # fix gold testsuite with gcc-4.9 - commit ae447ddd
+ patch -p1 -i $srcdir/binutils-2.24-gold-testsuite-plugin.patch
+
+ # fix issues with -static -fPIE -pie - commit 4199e3b8
+ patch -p1 -i $srcdir/binutils-2.24-shared-pie.patch
+
+ mkdir ${srcdir}/binutils-build
+}
build() {
- cd ${srcdir}
- mkdir binutils-build && cd binutils-build
+ cd ${srcdir}/binutils-build
${srcdir}/binutils-${pkgver}/configure --prefix=/usr \
--with-lib-path=/usr/lib:/usr/local/lib \
--with-bugurl=https://bugs.archlinux.org/ \
- --enable-ld=default --enable-gold \
- --enable-plugins --enable-threads --enable-shared \
- --disable-werror --disable-multilib
+ --enable-threads --enable-shared --with-pic \
+ --enable-ld=default --enable-gold --enable-plugins \
+ --disable-werror
# check the host environment and makes sure all the necessary tools are available
make configure-host
- make tooldir=${pkgdir}/usr
-
- # Rebuild libiberty.a with -fPIC
- cp -a libiberty libiberty-pic
- make -C libiberty-pic clean
- make CFLAGS="$CFLAGS -fPIC" -C libiberty-pic
-
- # Rebuild libbfd.a with -fPIC
- # hidden visability prevent 3rd party shared libraries exporting bfd non-stable API
- cp -a bfd bfd-pic
- make -C bfd-pic clean
- make CFLAGS="$CFLAGS -fPIC -fvisibility=hidden" -C bfd-pic
-
- # Rebuild libopcodes.a with -fPIC
- cp -a opcodes opcodes-pic
- make -C opcodes-pic clean
- make CFLAGS="$CFLAGS -fPIC" -C opcodes-pic
+ make tooldir=/usr
}
check() {
cd ${srcdir}/binutils-build
# unset LDFLAGS as testsuite makes assumptions about which ones are active
- # do not abort on errors - manually check log files
- make LDFLAGS="" -k check || true
+ # ignore failures in gold testsuite...
+ make -k LDFLAGS="" check || true
}
package() {
cd ${srcdir}/binutils-build
make prefix=${pkgdir}/usr tooldir=${pkgdir}/usr install
-
- # Add some useful headers
- install -m644 ${srcdir}/binutils-${pkgver}/include/libiberty.h ${pkgdir}/usr/include
- install -m644 ${srcdir}/binutils-${pkgver}/include/demangle.h ${pkgdir}/usr/include
-
- # install libraries rebuilt with -fPIC
- install -m644 libiberty-pic/libiberty.a ${pkgdir}/usr/lib
- install -m644 bfd-pic/libbfd.a ${pkgdir}/usr/lib
- install -m644 opcodes/libopcodes.a ${pkgdir}/usr/lib
- # Remove Windows/Novell specific man pages
+ # Remove unwanted files
rm ${pkgdir}/usr/share/man/man1/{dlltool,nlmconv,windres,windmc}*
-
- # why are these distributed with binutils?
rm ${pkgdir}/usr/share/info/{configure,standards}.info
- # Remove these symlinks, they are not ABI stable.
- # Programs should compile static to the .a file.
+ # No shared linking to these files outside binutils
rm ${pkgdir}/usr/lib/lib{bfd,opcodes}.so
- echo "INPUT ( /usr/lib/libbfd.a -liberty -lz )" >${pkgdir}/usr/lib/libbfd.so
- echo "INPUT ( /usr/lib/libopcodes.a -lbfd )" >${pkgdir}/usr/lib/libopcodes.so
}