summaryrefslogtreecommitdiffstats
path: root/abs/core/bison/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-24 02:52:12 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-24 02:52:12 (GMT)
commit6242385a68ad78a27b72fd9ec50a8dcd41f77ef1 (patch)
treee3d61b9aba92dbd90c4ee6d386e30d8ad7399e48 /abs/core/bison/PKGBUILD
parent39d885a41216f774afad473d79227ec1c57e7fb5 (diff)
downloadlinhes_pkgbuild-6242385a68ad78a27b72fd9ec50a8dcd41f77ef1.zip
linhes_pkgbuild-6242385a68ad78a27b72fd9ec50a8dcd41f77ef1.tar.gz
linhes_pkgbuild-6242385a68ad78a27b72fd9ec50a8dcd41f77ef1.tar.bz2
bison: upgrade
Diffstat (limited to 'abs/core/bison/PKGBUILD')
-rw-r--r--abs/core/bison/PKGBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/abs/core/bison/PKGBUILD b/abs/core/bison/PKGBUILD
index 3172db7..91d9162 100644
--- a/abs/core/bison/PKGBUILD
+++ b/abs/core/bison/PKGBUILD
@@ -1,25 +1,28 @@
-# $Id: PKGBUILD 21374 2008-12-12 10:34:44Z eric $
-# Maintainer: Eric Belanger <eric@archlinux.org>
+# $Id: PKGBUILD 87221 2010-08-11 03:29:16Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Contributor: Eric Belanger <eric@archlinux.org>
pkgname=bison
-pkgver=2.4.1
+pkgver=2.4.3
pkgrel=1
pkgdesc="The GNU general-purpose parser generator"
arch=('i686' 'x86_64')
-license=('GPL')
+license=('GPL3')
url="http://www.gnu.org/software/bison/bison.html"
-depends=('glibc' 'm4' 'texinfo')
+depends=('glibc' 'm4' 'sh')
groups=('base-devel')
install=bison.install
-source=(ftp://ftp.gnu.org/gnu/bison/${pkgname}-${pkgver}.tar.gz)
-md5sums=('c58aa1da418dc9704070872489e89bf5')
-sha1sums=('ecc4139bbd45b73f42f2b04482d77c16534fea28')
+source=(ftp://ftp.gnu.org/gnu/bison/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('c1d3ea81bc370dbd43b6f0b2cd21287e')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr --datadir=/usr/share || return 1
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --datadir=/usr/share
make || return 1
- make DESTDIR=${pkgdir} install || return 1
- rm ${pkgdir}/usr/share/info/dir || return 1
- gzip ${pkgdir}/usr/share/info/* || return 1
+ make check
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}