summaryrefslogtreecommitdiffstats
path: root/abs/core/certmaster
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-01-02 21:32:55 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-01-02 21:32:55 (GMT)
commitb35e8f78a35eb49404b988562daec8d4ec2712e6 (patch)
tree48f795669bea45616a94925894e734a69740bfd7 /abs/core/certmaster
parent7e3fef96a2905ffc5afc2bcaf31c5d8384a10ad3 (diff)
downloadlinhes_pkgbuild-b35e8f78a35eb49404b988562daec8d4ec2712e6.zip
linhes_pkgbuild-b35e8f78a35eb49404b988562daec8d4ec2712e6.tar.gz
linhes_pkgbuild-b35e8f78a35eb49404b988562daec8d4ec2712e6.tar.bz2
move acl_fix_fstab.py to linhes-scripts:
modify packages to depend on linhes-scripts >=7-24 certmaster linhes-system wmaker-settings xymon e16-themes refs #805 res #806
Diffstat (limited to 'abs/core/certmaster')
-rw-r--r--abs/core/certmaster/PKGBUILD8
-rw-r--r--abs/core/certmaster/acl_fix_fstab.py64
-rw-r--r--abs/core/certmaster/certmaster.install2
3 files changed, 4 insertions, 70 deletions
diff --git a/abs/core/certmaster/PKGBUILD b/abs/core/certmaster/PKGBUILD
index 367ca78..e3b9df1 100644
--- a/abs/core/certmaster/PKGBUILD
+++ b/abs/core/certmaster/PKGBUILD
@@ -1,10 +1,10 @@
pkgname=certmaster
pkgver=0.28
-pkgrel=2
+pkgrel=3
pkgdesc="certmaster"
url="https://fedorahosted.org/certmaster/ "
license="gpl"
-depends=(pyopenssl)
+depends=('pyopenssl' 'linhes-scripts>=7-24' )
makedepends=()
conflicts=()
replaces=()
@@ -12,7 +12,7 @@ moddir="pkg/usr/lib/python2.6/site-packages/func/minion/modules/"
backup=('etc/certmaster/certmaster.conf' 'etc/certmaster/minion.conf')
install=certmaster.install
-source=($pkgname-$pkgver.tar.gz certmaster.conf minion.conf acl_fix_fstab.py logrotate-certmaster.conf)
+source=($pkgname-$pkgver.tar.gz certmaster.conf minion.conf logrotate-certmaster.conf)
arch=('i686')
build() {
@@ -23,7 +23,6 @@ build() {
install -m755 -D minion.conf $startdir/pkg/etc/certmaster/minion.conf
install -m755 -D certmaster.conf $startdir/pkg/etc/certmaster/certmaster.conf
install -m755 -D logrotate-certmaster.conf $startdir/pkg/etc/logrotate.d/certmaster.conf
- install -m755 -D acl_fix_fstab.py $startdir/pkg/usr/MythVantage/bin/acl_fix_fstab.py
mkdir -p $startdir/pkg/var/log/certmaster
cd $startdir/pkg
find ./ -name "*.pyc" -print | xargs rm -f
@@ -31,5 +30,4 @@ build() {
md5sums=('f5acc9ff1efa34971296e26d794c5b35'
'953ff601e5381b457383e7a3c4928192'
'be7bd532ae103ab3c0048980314b4fd9'
- 'cc9cdabcdfc969c2829b58c0e513488c'
'6bc28ccd331a6c4c05e0a9c9755a848f')
diff --git a/abs/core/certmaster/acl_fix_fstab.py b/abs/core/certmaster/acl_fix_fstab.py
deleted file mode 100644
index 187cab1..0000000
--- a/abs/core/certmaster/acl_fix_fstab.py
+++ /dev/null
@@ -1,64 +0,0 @@
-#!/usr/bin/python2
-import os
-import sys
-import subprocess as sub
-
-def should_add_acl(mount_point,fs_map):
- acl_fs_list=["ext3","ext4"]
- rc = False
- for i in fs_map:
- if i[0] == mount_point:
- if i[1] in acl_fs_list:
- rc = True
-
- return rc
-
-
-cmd="cp -f /etc/fstab /etc/fstab.backup.pre_acl"
-os.system(cmd)
-f = open('/etc/fstab', 'r')
-fstab=f.readlines()
-f.close()
-
-p = sub.Popen(['/sbin/fsck','-N' ],stdout=sub.PIPE,stderr=sub.PIPE)
-output, errors = p.communicate()
-output = output.split("\n")
-fs_map=[]
-for i in output:
- if i.startswith("["):
- split_line=i.split()
- #find mount_p and remove the last char
- mount_p = split_line[3][:-1]
- fstype = split_line[4].split(".")[1]
- append_tuple=(mount_p,fstype)
- fs_map.append(append_tuple)
-
-
-
-mp=['/' , '/myth', '/data']
-newfstab=[]
-for line in fstab:
- new_line=line
- split_line=line.split()
- try:
- if split_line[1] in mp and should_add_acl(split_line[1],fs_map):
- #print split_line[3]
- if "acl" in split_line[3]:
- pass
- else:
- print "Adding ACL"
- new_acl=split_line[3]+",acl"
- split_line[3]=new_acl
- new_line='\t'.join(split_line)
- except:
- pass
- newfstab.append(new_line)
-
-
-f = open('/etc/fstab', 'w')
-for i in newfstab:
- f.write(i)
- f.write("\n")
-
-f.close()
-
diff --git a/abs/core/certmaster/certmaster.install b/abs/core/certmaster/certmaster.install
index e0dac8c..b30f7ee 100644
--- a/abs/core/certmaster/certmaster.install
+++ b/abs/core/certmaster/certmaster.install
@@ -13,7 +13,7 @@ post_install() {
then
mkdir -p /var/log/certmaster
fi
- /usr/MythVantage/bin/acl_fix_fstab.py
+ /usr/LH/bin/acl_fix_fstab.py
mount -o remount /
if [ ! -e /etc/pki/certmaster/ca ]
then