summaryrefslogtreecommitdiffstats
path: root/abs/core/cmake
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
commit2648e999d277eac5c3d331a3609bcc73fafbea71 (patch)
tree40951fb8e7fdbe28a0baa324ae615055203f1e2e /abs/core/cmake
parentc759b5e0c4aa6fc37412b4dee2cf9ad993fd376d (diff)
parent7e6f7ca174e1af67178dc5293a312a4a733eb095 (diff)
downloadlinhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.zip
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.gz
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.bz2
Merge branch 'testing'
# By James Meyer (1091) and others # Via James Meyer (5) and others * testing: (1148 commits) LinHES-config: during install don't kill off lirc. This keeps the remote active all the way to the finish Change version numbers to 8.0 to match the release number. LinHES-conifg LinHES-system mythdb-initial runit-scripts supplemental-web LinHES-conifig: mv_install.py for the last partition don't go all the way to the end. Gotta leave room for gpt tables. xf86-video-ati: xorg ati driver. LinHES-config: timezip.py add syncing up of parental lvl passwords and starting level with MBE. LinHES-system: correct the logic for breaking out of the wmctrl loop. As written it would break out of the inner loop..but not the 60 iteration loop. e16_theme_settings: remove slide-in prop for new windows. For whatever reason this was preventing mplayer from being positioned correctly for appletrailers. LinHES-config, mythinstall: change case of hd_pvr and serial to all lower refs #902 zilog-firmware: firmware for TX support of the hdpvr and pvr-150 In general I can't recommend anybody using these transmitters but including the firmware just in case someone really wants to linhes-udev-rules: added hdprv_lirc rule. All of these lirc rules are limited to exactly one device. If more then one device is present then only the last device in init will get the symlink runit-scripts: fix logging for igdeamon, add support to remote init script so that the blaster is always the first device in the chain. added support specificly for hd_pvr LinHES-system: add lh_system_restore and lh_system_backup. These scripts are called from the mythmenu. refs #900 iguanair: rebuild with python 2.7 LinHES-system: msg_daemon.py fix init and nasty bug related to timeout. In a nutshell timeout wouldn't work unless a msg without a timeout was called first. linhes-udev-rules: add rules for mce,streamzap,serial lirc devices. mythinstall: recompile for matching libs mythtv: latest .25-fixes and change mythbackup/restore call lh_system_$op to replace mythbackup/mythrestore. mythbackup no longer works correctly with the new windowmanager linhes-scripts: myth2mp3, myth2x264, myth2xvid: use mythutil to get cutlist LinHES-config, supplimental-web: Fix proxy numbering for Ceton infiniTV linhes-system: add additional stuff to the system backup and also introduced an exclude file. The exclude/include files are locate in /home/mythtv/backup_config/ ...
Diffstat (limited to 'abs/core/cmake')
-rw-r--r--abs/core/cmake/PKGBUILD30
-rw-r--r--abs/core/cmake/cmake.install1
-rw-r--r--abs/core/cmake/fix-pkg-config.patch31
3 files changed, 49 insertions, 13 deletions
diff --git a/abs/core/cmake/PKGBUILD b/abs/core/cmake/PKGBUILD
index 2125fb9..5600a7a 100644
--- a/abs/core/cmake/PKGBUILD
+++ b/abs/core/cmake/PKGBUILD
@@ -1,42 +1,46 @@
-# $Id: PKGBUILD 98166 2010-11-04 07:38:49Z andrea $
+# $Id: PKGBUILD 157165 2012-04-25 06:58:42Z andrea $
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
-# Contributor: damir <damir@archlinux.org>
-# Contributor: Konstantinos Pachnis <kpachnis@mes-direct.com>
pkgname=cmake
-pkgver=2.8.3
-pkgrel=1
+pkgver=2.8.8
+pkgrel=2
pkgdesc="A cross-platform open-source make system"
arch=('i686' 'x86_64')
+url="http://www.cmake.org/"
license=('custom')
-url="http://www.cmake.org"
-depends=('expat' 'curl' 'gcc-libs' 'shared-mime-info')
+depends=('curl' 'libarchive' 'shared-mime-info')
makedepends=('qt')
optdepends=('qt: cmake-gui')
install="${pkgname}.install"
-source=("http://www.cmake.org/files/v2.8/${pkgname}-${pkgver}.tar.gz")
-md5sums=('a76a44b93acf5e3badda9de111385921')
+source=("http://www.cmake.org/files/v2.8/${pkgname}-${pkgver}.tar.gz"
+ 'fix-pkg-config.patch')
+md5sums=('ba74b22c788a0c8547976b880cd02b17'
+ '32c6a4360a2ba12dc77b6a840fa7672b')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}"/${pkgname}-${pkgver}
+
+ # FS#29545
+ patch -p1 -i "${srcdir}"/fix-pkg-config.patch
./bootstrap --prefix=/usr \
--mandir=/share/man \
--docdir=/share/doc/cmake \
--system-libs \
--qt-gui \
- --parallel=2
+ --parallel=$(/usr/bin/getconf _NPROCESSORS_ONLN)
make
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
vimpath="$pkgdir/usr/share/vim/vimfiles"
install -Dm644 Docs/cmake-indent.vim ${vimpath}/indent/cmake-indent.vim
install -Dm644 Docs/cmake-syntax.vim ${vimpath}/syntax/cmake-syntax.vim
install -Dm644 Docs/cmake-mode.el ${pkgdir}/usr/share/emacs/site-lisp/cmake-mode.el
+
install -Dm644 Copyright.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
diff --git a/abs/core/cmake/cmake.install b/abs/core/cmake/cmake.install
index 7c8a8bd..55f6c84 100644
--- a/abs/core/cmake/cmake.install
+++ b/abs/core/cmake/cmake.install
@@ -1,5 +1,6 @@
post_install() {
update-mime-database usr/share/mime &> /dev/null
+ [[ -x usr/bin/update-desktop-database ]] && update-desktop-database -q || true
}
post_upgrade() {
diff --git a/abs/core/cmake/fix-pkg-config.patch b/abs/core/cmake/fix-pkg-config.patch
new file mode 100644
index 0000000..c9390ae
--- /dev/null
+++ b/abs/core/cmake/fix-pkg-config.patch
@@ -0,0 +1,31 @@
+X-Git-Url: http://cmake.org/gitweb?p=cmake.git;a=blobdiff_plain;f=Modules%2FFindPkgConfig.cmake;h=39d3a76abd852df4a32eab5f8d5672fa24a7e4cf;hp=5d93ab151de792b4565cbef1927f372be633f4a6;hb=3ea850a5023060b84dcc0e6f0098c32c28b15807;hpb=ad3d2b450f1c2454cd1a3f416ef97631e2937eef
+
+diff --git a/Modules/FindPkgConfig.cmake b/Modules/FindPkgConfig.cmake
+index 5d93ab1..39d3a76 100644
+--- a/Modules/FindPkgConfig.cmake
++++ b/Modules/FindPkgConfig.cmake
+@@ -13,11 +13,10 @@
+ # When the 'QUIET' argument is set, no status messages will be printed.
+ #
+ # It sets the following variables:
+-# PKG_CONFIG_FOUND ... true if pkg-config works on the system
++# PKG_CONFIG_FOUND ... if pkg-config executable was found
+ # PKG_CONFIG_EXECUTABLE ... pathname of the pkg-config program
+ # PKG_CONFIG_VERSION_STRING ... the version of the pkg-config program found
+ # (since CMake 2.8.8)
+-# PKG_CONFIG_FOUND ... if pkg-config executable was found
+ #
+ # For the following variables two sets of values exist; first one is the
+ # common one and has the given PREFIX. The second set contains flags
+@@ -104,6 +103,11 @@ find_package_handle_standard_args(PkgConfig
+ REQUIRED_VARS PKG_CONFIG_EXECUTABLE
+ VERSION_VAR PKG_CONFIG_VERSION_STRING)
+
++# This is needed because the module name is "PkgConfig" but the name of
++# this variable has always been PKG_CONFIG_FOUND so this isn't automatically
++# handled by FPHSA.
++set(PKG_CONFIG_FOUND "${PKGCONFIG_FOUND}")
++
+ # Unsets the given variables
+ macro(_pkgconfig_unset var)
+ set(${var} "" CACHE INTERNAL "")