summaryrefslogtreecommitdiffstats
path: root/abs/core/cmake
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-06 22:33:26 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-06 22:33:26 (GMT)
commita636637b2cc2c3232112fd9c12fb9002068b9ddb (patch)
tree3ca70ff2c209403557a993168c53fe7175311870 /abs/core/cmake
parent760fe45316486bf525f49f6dccd9b22192720f0b (diff)
downloadlinhes_pkgbuild-a636637b2cc2c3232112fd9c12fb9002068b9ddb.zip
linhes_pkgbuild-a636637b2cc2c3232112fd9c12fb9002068b9ddb.tar.gz
linhes_pkgbuild-a636637b2cc2c3232112fd9c12fb9002068b9ddb.tar.bz2
cmake 2.8.8
Diffstat (limited to 'abs/core/cmake')
-rw-r--r--abs/core/cmake/PKGBUILD30
-rw-r--r--abs/core/cmake/cmake.install1
-rw-r--r--abs/core/cmake/fix-pkg-config.patch31
3 files changed, 49 insertions, 13 deletions
diff --git a/abs/core/cmake/PKGBUILD b/abs/core/cmake/PKGBUILD
index 2125fb9..5600a7a 100644
--- a/abs/core/cmake/PKGBUILD
+++ b/abs/core/cmake/PKGBUILD
@@ -1,42 +1,46 @@
-# $Id: PKGBUILD 98166 2010-11-04 07:38:49Z andrea $
+# $Id: PKGBUILD 157165 2012-04-25 06:58:42Z andrea $
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
-# Contributor: damir <damir@archlinux.org>
-# Contributor: Konstantinos Pachnis <kpachnis@mes-direct.com>
pkgname=cmake
-pkgver=2.8.3
-pkgrel=1
+pkgver=2.8.8
+pkgrel=2
pkgdesc="A cross-platform open-source make system"
arch=('i686' 'x86_64')
+url="http://www.cmake.org/"
license=('custom')
-url="http://www.cmake.org"
-depends=('expat' 'curl' 'gcc-libs' 'shared-mime-info')
+depends=('curl' 'libarchive' 'shared-mime-info')
makedepends=('qt')
optdepends=('qt: cmake-gui')
install="${pkgname}.install"
-source=("http://www.cmake.org/files/v2.8/${pkgname}-${pkgver}.tar.gz")
-md5sums=('a76a44b93acf5e3badda9de111385921')
+source=("http://www.cmake.org/files/v2.8/${pkgname}-${pkgver}.tar.gz"
+ 'fix-pkg-config.patch')
+md5sums=('ba74b22c788a0c8547976b880cd02b17'
+ '32c6a4360a2ba12dc77b6a840fa7672b')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}"/${pkgname}-${pkgver}
+
+ # FS#29545
+ patch -p1 -i "${srcdir}"/fix-pkg-config.patch
./bootstrap --prefix=/usr \
--mandir=/share/man \
--docdir=/share/doc/cmake \
--system-libs \
--qt-gui \
- --parallel=2
+ --parallel=$(/usr/bin/getconf _NPROCESSORS_ONLN)
make
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
vimpath="$pkgdir/usr/share/vim/vimfiles"
install -Dm644 Docs/cmake-indent.vim ${vimpath}/indent/cmake-indent.vim
install -Dm644 Docs/cmake-syntax.vim ${vimpath}/syntax/cmake-syntax.vim
install -Dm644 Docs/cmake-mode.el ${pkgdir}/usr/share/emacs/site-lisp/cmake-mode.el
+
install -Dm644 Copyright.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
diff --git a/abs/core/cmake/cmake.install b/abs/core/cmake/cmake.install
index 7c8a8bd..55f6c84 100644
--- a/abs/core/cmake/cmake.install
+++ b/abs/core/cmake/cmake.install
@@ -1,5 +1,6 @@
post_install() {
update-mime-database usr/share/mime &> /dev/null
+ [[ -x usr/bin/update-desktop-database ]] && update-desktop-database -q || true
}
post_upgrade() {
diff --git a/abs/core/cmake/fix-pkg-config.patch b/abs/core/cmake/fix-pkg-config.patch
new file mode 100644
index 0000000..c9390ae
--- /dev/null
+++ b/abs/core/cmake/fix-pkg-config.patch
@@ -0,0 +1,31 @@
+X-Git-Url: http://cmake.org/gitweb?p=cmake.git;a=blobdiff_plain;f=Modules%2FFindPkgConfig.cmake;h=39d3a76abd852df4a32eab5f8d5672fa24a7e4cf;hp=5d93ab151de792b4565cbef1927f372be633f4a6;hb=3ea850a5023060b84dcc0e6f0098c32c28b15807;hpb=ad3d2b450f1c2454cd1a3f416ef97631e2937eef
+
+diff --git a/Modules/FindPkgConfig.cmake b/Modules/FindPkgConfig.cmake
+index 5d93ab1..39d3a76 100644
+--- a/Modules/FindPkgConfig.cmake
++++ b/Modules/FindPkgConfig.cmake
+@@ -13,11 +13,10 @@
+ # When the 'QUIET' argument is set, no status messages will be printed.
+ #
+ # It sets the following variables:
+-# PKG_CONFIG_FOUND ... true if pkg-config works on the system
++# PKG_CONFIG_FOUND ... if pkg-config executable was found
+ # PKG_CONFIG_EXECUTABLE ... pathname of the pkg-config program
+ # PKG_CONFIG_VERSION_STRING ... the version of the pkg-config program found
+ # (since CMake 2.8.8)
+-# PKG_CONFIG_FOUND ... if pkg-config executable was found
+ #
+ # For the following variables two sets of values exist; first one is the
+ # common one and has the given PREFIX. The second set contains flags
+@@ -104,6 +103,11 @@ find_package_handle_standard_args(PkgConfig
+ REQUIRED_VARS PKG_CONFIG_EXECUTABLE
+ VERSION_VAR PKG_CONFIG_VERSION_STRING)
+
++# This is needed because the module name is "PkgConfig" but the name of
++# this variable has always been PKG_CONFIG_FOUND so this isn't automatically
++# handled by FPHSA.
++set(PKG_CONFIG_FOUND "${PKGCONFIG_FOUND}")
++
+ # Unsets the given variables
+ macro(_pkgconfig_unset var)
+ set(${var} "" CACHE INTERNAL "")