summaryrefslogtreecommitdiffstats
path: root/abs/core/cmake
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-02-16 23:42:26 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-02-19 19:03:02 (GMT)
commite2f0b8987788218b27e9434942d8d3a19afcea00 (patch)
tree8d7807212621dcf97a51505e6757cd46ab2ab627 /abs/core/cmake
parentaa69c60af899a4ffa7243216537c048ac0e2c2f0 (diff)
downloadlinhes_pkgbuild-e2f0b8987788218b27e9434942d8d3a19afcea00.zip
linhes_pkgbuild-e2f0b8987788218b27e9434942d8d3a19afcea00.tar.gz
linhes_pkgbuild-e2f0b8987788218b27e9434942d8d3a19afcea00.tar.bz2
cmake: 2.8.12
Diffstat (limited to 'abs/core/cmake')
-rw-r--r--abs/core/cmake/PKGBUILD35
-rw-r--r--abs/core/cmake/findfreetype.patch26
-rw-r--r--abs/core/cmake/fix-pkg-config.patch31
3 files changed, 45 insertions, 47 deletions
diff --git a/abs/core/cmake/PKGBUILD b/abs/core/cmake/PKGBUILD
index 5600a7a..eb20157 100644
--- a/abs/core/cmake/PKGBUILD
+++ b/abs/core/cmake/PKGBUILD
@@ -1,28 +1,27 @@
-# $Id: PKGBUILD 157165 2012-04-25 06:58:42Z andrea $
+# $Id: PKGBUILD 200685 2013-12-02 11:59:05Z svenstaro $
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
pkgname=cmake
-pkgver=2.8.8
-pkgrel=2
+pkgver=2.8.12.1
+pkgrel=3
pkgdesc="A cross-platform open-source make system"
arch=('i686' 'x86_64')
url="http://www.cmake.org/"
license=('custom')
depends=('curl' 'libarchive' 'shared-mime-info')
-makedepends=('qt')
+makedepends=('qt' 'emacs')
optdepends=('qt: cmake-gui')
install="${pkgname}.install"
source=("http://www.cmake.org/files/v2.8/${pkgname}-${pkgver}.tar.gz"
- 'fix-pkg-config.patch')
-md5sums=('ba74b22c788a0c8547976b880cd02b17'
- '32c6a4360a2ba12dc77b6a840fa7672b')
+ "findfreetype.patch")
+md5sums=('9d38cd4e2c94c3cea97d0e2924814acc'
+ '90321de1d9d46cd8d6609d0509dbd7b0')
build() {
- cd "${srcdir}"/${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
- # FS#29545
- patch -p1 -i "${srcdir}"/fix-pkg-config.patch
+ patch -Np1 < ${srcdir}/findfreetype.patch
./bootstrap --prefix=/usr \
--mandir=/share/man \
@@ -34,13 +33,17 @@ build() {
}
package() {
- cd "${srcdir}"/${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
- vimpath="$pkgdir/usr/share/vim/vimfiles"
- install -Dm644 Docs/cmake-indent.vim ${vimpath}/indent/cmake-indent.vim
- install -Dm644 Docs/cmake-syntax.vim ${vimpath}/syntax/cmake-syntax.vim
- install -Dm644 Docs/cmake-mode.el ${pkgdir}/usr/share/emacs/site-lisp/cmake-mode.el
+ vimpath="${pkgdir}/usr/share/vim/vimfiles"
+ install -Dm644 Docs/cmake-indent.vim "${vimpath}"/indent/cmake-indent.vim
+ install -Dm644 Docs/cmake-syntax.vim "${vimpath}"/syntax/cmake-syntax.vim
- install -Dm644 Copyright.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 Docs/cmake-mode.el \
+ "${pkgdir}"/usr/share/emacs/site-lisp/cmake-mode.el
+ emacs -batch -f batch-byte-compile "${pkgdir}"/usr/share/emacs/site-lisp/cmake-mode.el
+
+ install -Dm644 Copyright.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}
diff --git a/abs/core/cmake/findfreetype.patch b/abs/core/cmake/findfreetype.patch
new file mode 100644
index 0000000..454b591
--- /dev/null
+++ b/abs/core/cmake/findfreetype.patch
@@ -0,0 +1,26 @@
+diff --git a/Modules/FindFreetype.cmake b/Modules/FindFreetype.cmake
+index 179dc00..0f5a2b4 100644
+--- a/Modules/FindFreetype.cmake
++++ b/Modules/FindFreetype.cmake
+@@ -62,10 +62,10 @@ find_path(FREETYPE_INCLUDE_DIR_ft2build ft2build.h
+ ENV GTKMM_BASEPATH
+ [HKEY_CURRENT_USER\\SOFTWARE\\gtkmm\\2.4;Path]
+ [HKEY_LOCAL_MACHINE\\SOFTWARE\\gtkmm\\2.4;Path]
+- PATH_SUFFIXES include/freetype2 include
++ PATH_SUFFIXES include/freetype2 include/freetype include
+ )
+
+-find_path(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
++find_path(FREETYPE_INCLUDE_DIR_freetype2 config/ftheader.h
+ HINTS
+ ENV FREETYPE_DIR
+ PATHS
+@@ -76,7 +76,7 @@ find_path(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
+ ENV GTKMM_BASEPATH
+ [HKEY_CURRENT_USER\\SOFTWARE\\gtkmm\\2.4;Path]
+ [HKEY_LOCAL_MACHINE\\SOFTWARE\\gtkmm\\2.4;Path]
+- PATH_SUFFIXES include/freetype2 include
++ PATH_SUFFIXES include/freetype2 include/freetype include include/freetype2/freetype
+ )
+
+ find_library(FREETYPE_LIBRARY
diff --git a/abs/core/cmake/fix-pkg-config.patch b/abs/core/cmake/fix-pkg-config.patch
deleted file mode 100644
index c9390ae..0000000
--- a/abs/core/cmake/fix-pkg-config.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-X-Git-Url: http://cmake.org/gitweb?p=cmake.git;a=blobdiff_plain;f=Modules%2FFindPkgConfig.cmake;h=39d3a76abd852df4a32eab5f8d5672fa24a7e4cf;hp=5d93ab151de792b4565cbef1927f372be633f4a6;hb=3ea850a5023060b84dcc0e6f0098c32c28b15807;hpb=ad3d2b450f1c2454cd1a3f416ef97631e2937eef
-
-diff --git a/Modules/FindPkgConfig.cmake b/Modules/FindPkgConfig.cmake
-index 5d93ab1..39d3a76 100644
---- a/Modules/FindPkgConfig.cmake
-+++ b/Modules/FindPkgConfig.cmake
-@@ -13,11 +13,10 @@
- # When the 'QUIET' argument is set, no status messages will be printed.
- #
- # It sets the following variables:
--# PKG_CONFIG_FOUND ... true if pkg-config works on the system
-+# PKG_CONFIG_FOUND ... if pkg-config executable was found
- # PKG_CONFIG_EXECUTABLE ... pathname of the pkg-config program
- # PKG_CONFIG_VERSION_STRING ... the version of the pkg-config program found
- # (since CMake 2.8.8)
--# PKG_CONFIG_FOUND ... if pkg-config executable was found
- #
- # For the following variables two sets of values exist; first one is the
- # common one and has the given PREFIX. The second set contains flags
-@@ -104,6 +103,11 @@ find_package_handle_standard_args(PkgConfig
- REQUIRED_VARS PKG_CONFIG_EXECUTABLE
- VERSION_VAR PKG_CONFIG_VERSION_STRING)
-
-+# This is needed because the module name is "PkgConfig" but the name of
-+# this variable has always been PKG_CONFIG_FOUND so this isn't automatically
-+# handled by FPHSA.
-+set(PKG_CONFIG_FOUND "${PKGCONFIG_FOUND}")
-+
- # Unsets the given variables
- macro(_pkgconfig_unset var)
- set(${var} "" CACHE INTERNAL "")