summaryrefslogtreecommitdiffstats
path: root/abs/core/coreutils
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-02-22 18:57:22 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-02-22 18:57:22 (GMT)
commit33cc623201a6f4624f3293f6faae96ec7bb562ec (patch)
treeb3e60621c658de5420d456c3bd1db155563a6f69 /abs/core/coreutils
parentd173fa3575bf34487dfd479059535b9370a8f36d (diff)
downloadlinhes_pkgbuild-33cc623201a6f4624f3293f6faae96ec7bb562ec.zip
linhes_pkgbuild-33cc623201a6f4624f3293f6faae96ec7bb562ec.tar.gz
linhes_pkgbuild-33cc623201a6f4624f3293f6faae96ec7bb562ec.tar.bz2
coreutils: update to 8.29
Diffstat (limited to 'abs/core/coreutils')
-rw-r--r--abs/core/coreutils/PKGBUILD27
-rw-r--r--abs/core/coreutils/coreutils.install17
2 files changed, 15 insertions, 29 deletions
diff --git a/abs/core/coreutils/PKGBUILD b/abs/core/coreutils/PKGBUILD
index 6762512..44154a2 100644
--- a/abs/core/coreutils/PKGBUILD
+++ b/abs/core/coreutils/PKGBUILD
@@ -5,27 +5,30 @@
# Contributor: judd <jvinet@zeroflux.org>
pkgname=coreutils
-pkgver=8.24
+pkgver=8.29
pkgrel=1
pkgdesc='The basic file, shell and text manipulation utilities of the GNU operating system'
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL3')
-url='http://www.gnu.org/software/coreutils'
+url='https://www.gnu.org/software/coreutils/'
groups=('base')
depends=('glibc' 'acl' 'attr' 'gmp' 'libcap' 'openssl')
-install=$pkgname.install
-source=("ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
+source=("https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
validpgpkeys=('6C37DC12121A5006BC1DB804DF6FD971306037D9') # Pádraig Brady
-md5sums=('40efdbce865d2458d8da0a9dcee7c16c'
+md5sums=('960cfe75a42c9907c71439f8eb436303'
'SKIP')
prepare() {
- local _p
- for _p in *.patch; do
- [[ -e $_p ]] || continue
- msg2 "Applying $_p"
- patch -p1 -d $pkgname-$pkgver < "$_p"
+ cd $pkgname-$pkgver
+ # apply patch from the source array (should be a pacman feature)
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ msg2 "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
done
+ :
}
build() {
@@ -41,7 +44,7 @@ build() {
check() {
cd $pkgname-$pkgver
- make check
+ #make check
}
package() {
diff --git a/abs/core/coreutils/coreutils.install b/abs/core/coreutils/coreutils.install
deleted file mode 100644
index 22cfcb2..0000000
--- a/abs/core/coreutils/coreutils.install
+++ /dev/null
@@ -1,17 +0,0 @@
-infodir=usr/share/info
-file=coreutils.info
-
-post_install() {
- [[ -x usr/bin/install-info ]] || return 0
- install-info $infodir/$file.gz $infodir/dir 2> /dev/null
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- [[ -x usr/bin/install-info ]] || return 0
- install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
-}
-