summaryrefslogtreecommitdiffstats
path: root/abs/core/ctntad
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-02-16 23:44:04 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-02-19 19:03:02 (GMT)
commitc50e43346a227bd2f968fa4b2b0dbe33180e6021 (patch)
tree423c5341a89dcfb1106bf4c39a1ed617ad35bc5d /abs/core/ctntad
parent798be4135a1867350244b32359bf7fbd9ae1f091 (diff)
downloadlinhes_pkgbuild-c50e43346a227bd2f968fa4b2b0dbe33180e6021.zip
linhes_pkgbuild-c50e43346a227bd2f968fa4b2b0dbe33180e6021.tar.gz
linhes_pkgbuild-c50e43346a227bd2f968fa4b2b0dbe33180e6021.tar.bz2
ctntad: first inclusion
refs #954
Diffstat (limited to 'abs/core/ctntad')
-rw-r--r--abs/core/ctntad/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/core/ctntad/PKGBUILD b/abs/core/ctntad/PKGBUILD
new file mode 100644
index 0000000..9135dae
--- /dev/null
+++ b/abs/core/ctntad/PKGBUILD
@@ -0,0 +1,28 @@
+#6 Maintainer: Jameson Pugh <imntreal@gmail.com>
+pkgname=ctntad
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Ceton InfiniTV Tunning Adapter Driver"
+arch=('i686' 'x86_64')
+url="http://cetoncorp.com/infinitv_support/linux_drivers/"
+license=('GPL')
+depends=('gupnp' 'libgusb')
+source=("http://cetoncorp.com/downloads/$pkgname-$pkgver.tar.gz")
+sha256sums=('7929eb2e69868cc2969a95f8c93320bcf003c5276ef4e7c49a63b8df7f3855d9')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # fix undefined reference to symbol 'g_thread_init'
+ sed -i "s|g_thread_init(NULL);|/*g_thread_init(NULL);*/|" src/main.c
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: