summaryrefslogtreecommitdiffstats
path: root/abs/core/curl
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-01-18 00:05:46 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-01-18 00:05:46 (GMT)
commitb26880134f7390c9ad6fb225b04eda44341a0dea (patch)
tree2052fec24523cb6fe98e4198bbdd959e340ccdda /abs/core/curl
parentd234301a1a4623a4570242aba57cfdfbf13e8738 (diff)
downloadlinhes_pkgbuild-b26880134f7390c9ad6fb225b04eda44341a0dea.zip
linhes_pkgbuild-b26880134f7390c9ad6fb225b04eda44341a0dea.tar.gz
linhes_pkgbuild-b26880134f7390c9ad6fb225b04eda44341a0dea.tar.bz2
curl: update to 7.46.0
Diffstat (limited to 'abs/core/curl')
-rw-r--r--abs/core/curl/0001-connect-Try-all-addresses-in-first-connection-attemp.patch47
-rw-r--r--abs/core/curl/PKGBUILD6
2 files changed, 3 insertions, 50 deletions
diff --git a/abs/core/curl/0001-connect-Try-all-addresses-in-first-connection-attemp.patch b/abs/core/curl/0001-connect-Try-all-addresses-in-first-connection-attemp.patch
deleted file mode 100644
index f3428c7..0000000
--- a/abs/core/curl/0001-connect-Try-all-addresses-in-first-connection-attemp.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 4e1ece2e44f432c2614f2090155c0aaf2226ea80 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Bj=C3=B6rn=20Stenberg?= <bjorn@haxx.se>
-Date: Sat, 28 Dec 2013 13:42:57 +0100
-Subject: [PATCH] connect: Try all addresses in first connection attempt
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fixes a bug when all addresses in the first family fail immediately, due
-to "Network unreachable" for example, curl would hang and never try the
-next address family.
-
-Iterate through all address families when to trying establish the first
-connection attempt.
-
-Bug: http://curl.haxx.se/bug/view.cgi?id=1315
-Reported-by: Michal Górny and Anthony G. Basile
----
- lib/connect.c | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/lib/connect.c b/lib/connect.c
-index 4b6ee00..588ac28 100644
---- a/lib/connect.c
-+++ b/lib/connect.c
-@@ -1104,12 +1104,12 @@ CURLcode Curl_connecthost(struct connectdata *conn, /* context */
- conn->tempaddr[0]->ai_next == NULL ? timeout_ms : timeout_ms / 2;
-
- /* start connecting to first IP */
-- res = singleipconnect(conn, conn->tempaddr[0], &(conn->tempsock[0]));
-- while(res != CURLE_OK &&
-- conn->tempaddr[0] &&
-- conn->tempaddr[0]->ai_next &&
-- conn->tempsock[0] == CURL_SOCKET_BAD)
-- res = trynextip(conn, FIRSTSOCKET, 0);
-+ while(conn->tempaddr[0]) {
-+ res = singleipconnect(conn, conn->tempaddr[0], &(conn->tempsock[0]));
-+ if(res == CURLE_OK)
-+ break;
-+ conn->tempaddr[0] = conn->tempaddr[0]->ai_next;
-+ }
-
- if(conn->tempsock[0] == CURL_SOCKET_BAD)
- return res;
---
-1.8.5.2
-
diff --git a/abs/core/curl/PKGBUILD b/abs/core/curl/PKGBUILD
index 29d6892..90fc700 100644
--- a/abs/core/curl/PKGBUILD
+++ b/abs/core/curl/PKGBUILD
@@ -6,18 +6,18 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=curl
-pkgver=7.39.0
+pkgver=7.46.0
pkgrel=1
pkgdesc="An URL retrieval utility and library"
arch=('i686' 'x86_64')
url="http://curl.haxx.se"
license=('MIT')
-depends=('ca-certificates' 'krb5' 'libssh2' 'libidn' 'openssl' 'zlib')
+depends=('ca-certificates' 'krb5' 'libidn' 'libssh2' 'openssl' 'zlib')
provides=('libcurl.so')
options=('strip' 'debug')
source=("http://curl.haxx.se/download/$pkgname-$pkgver.tar.gz"{,.asc}
curlbuild.h)
-md5sums=('88c5650122873712296d4b1db3f12e6c'
+md5sums=('230e682d59bf8ab6eca36da1d39ebd75'
'SKIP'
'751bd433ede935c8fae727377625a8ae')
validpgpkeys=('914C533DF9B2ADA2204F586D78E11C6B279D5C91') # Daniel Stenberg